summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-12-03 02:35:38 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-12-03 02:38:00 +0100
commit4cb11ed6fb51c28451e953d884732c783431ad9b (patch)
tree8e2ef672af5bff1c79df1605ec2232c33403a67f
parentnet-misc/telnet-bsd: Fix compilation with format-security (diff)
downloadgentoo-4cb11ed6fb51c28451e953d884732c783431ad9b.tar.gz
gentoo-4cb11ed6fb51c28451e953d884732c783431ad9b.tar.bz2
gentoo-4cb11ed6fb51c28451e953d884732c783431ad9b.zip
sys-block/open-isns: Bump to v0.98
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--sys-block/open-isns/Manifest1
-rw-r--r--sys-block/open-isns/open-isns-0.98.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-block/open-isns/Manifest b/sys-block/open-isns/Manifest
index 769f69f60c55..1956e6a87e0c 100644
--- a/sys-block/open-isns/Manifest
+++ b/sys-block/open-isns/Manifest
@@ -1 +1,2 @@
DIST open-isns-0.97.tar.gz 278317 SHA256 c1c9ae740172e55a1ff33bc22151ec3d916562bf5d60c8420cd64496343683a9 SHA512 78c934162d5a1d093bccd49449d4ef369b896d34309d76b4963d643a699640617c4fe064388c481c35b9be26e012f19713f3aad378af9ad88fa94c3d300e919d WHIRLPOOL b69d99e883bfcc2b4f8c2cd8aeb0b3bc113eb0d7163de0b6d614815d6979de059d3ea8bc709590a211faf7c4cdbeefe823bd6c9bb077889c201f8c044a5bb832
+DIST open-isns-0.98.tar.gz 278410 BLAKE2B f90df85de4d5fd2abdcd267e3c873dff62fcac523ee280e21def057eca366bbba21c2b3bfbf5cc0798b8d0f3b0d5028ebb49000cccc850abdfb85142a7b66c34 SHA512 04263b9ace9d272f4e3776c4e1a034815475590d4b4864217a6200fcd5baea391cd788723db3c17fe0d764efc9769a70a3d2167b00e5998fb4bcb8d5fe2547ed
diff --git a/sys-block/open-isns/open-isns-0.98.ebuild b/sys-block/open-isns/open-isns-0.98.ebuild
new file mode 100644
index 000000000000..a392ec70ea15
--- /dev/null
+++ b/sys-block/open-isns/open-isns-0.98.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="iSNS server and client for Linux"
+HOMEPAGE="https://github.com/open-iscsi/open-isns"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug slp ssl static"
+
+DEPEND="
+ ssl? ( dev-libs/openssl:= )
+ slp? ( net-libs/openslp )"
+RDEPEND="${DEPEND}"
+
+PATCHES=()
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
+ append-lfs-flags
+ econf $(use_with slp) \
+ $(use_with ssl security) \
+ $(use_enable !static shared)
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_hdrs
+ emake DESTDIR="${D}" install_lib
+}