summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2017-10-01 15:34:36 +0200
committerMart Raudsepp <leio@gentoo.org>2017-10-31 00:34:14 +0200
commit4de1adff4ae818c8ba9d7e82e14253dddcb5146a (patch)
treef9fa243e980fa822f016ec99aebd144712c96823
parentmedia-libs/cogl: remove unused patches (diff)
downloadgentoo-4de1adff4ae818c8ba9d7e82e14253dddcb5146a.tar.gz
gentoo-4de1adff4ae818c8ba9d7e82e14253dddcb5146a.tar.bz2
gentoo-4de1adff4ae818c8ba9d7e82e14253dddcb5146a.zip
media-libs/libmediaart: remove unused patch
-rw-r--r--media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch47
1 files changed, 0 insertions, 47 deletions
diff --git a/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch b/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
deleted file mode 100644
index ecf9de908cf..00000000000
--- a/media-libs/libmediaart/files/libmediaart-0.7.0-qt5.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Solves automagic selection of Qt version.
-
-https://bugs.gentoo.org/show_bug.cgi?id=523122
-https://bugzilla.gnome.org/show_bug.cgi?id=737174
-
-diff --git a/configure.ac b/configure.ac
-index e9ead09..3ee710a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -206,6 +206,10 @@ AC_ARG_ENABLE(qt,
- AS_HELP_STRING([--enable-qt],
- [enable Qt support, (MP3 album art) [[default=auto]]]),,
- [enable_qt=auto])
-+AC_ARG_WITH(qt-version,
-+ AS_HELP_STRING([--with-qt-version=major],
-+ [Force specific Qt version [[default=auto]]]),,
-+ [with_qt_version=auto])
-
- selected_for_media_art="no (disabled)"
-
-@@ -218,14 +222,18 @@ if test "x$enable_qt" == "xyes" && test "x$enable_gdkpixbuf" == "xyes"; then
- fi
-
- if test "x$enable_qt" != "xno" && test "x$enable_gdkpixbuf" != "xyes"; then
-- PKG_CHECK_MODULES(QT5,
-- [Qt5Gui >= $QT5_REQUIRED],
-- [have_qt5=yes],
-- [have_qt5=no])
-- PKG_CHECK_MODULES(QT4,
-- [QtGui >= $QT4_REQUIRED],
-- [have_qt4=yes],
-- [have_qt4=no])
-+ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x5"; then
-+ PKG_CHECK_MODULES(QT5,
-+ [Qt5Gui >= $QT5_REQUIRED],
-+ [have_qt5=yes],
-+ [have_qt5=no])
-+ fi
-+ if test "x$with_qt_version" == "xauto" || test "x$with_qt_version" == "x4"; then
-+ PKG_CHECK_MODULES(QT4,
-+ [QtGui >= $QT4_REQUIRED],
-+ [have_qt4=yes],
-+ [have_qt4=no])
-+ fi
-
- if test "x$have_qt5" = "xyes"; then
- BACKEND_CFLAGS="$QT5_CFLAGS -fPIC"