summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-04-05 22:09:27 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-04-07 22:45:33 +0100
commit4e796211177f562ec2ffa223f7ab6de5c47739e2 (patch)
tree9ed2e65b4f0becad86ec9aecfdf236e9daf4f181
parentdev-java/jetty-npn-api: New package, required by netty-handler (diff)
downloadgentoo-4e796211177f562ec2ffa223f7ab6de5c47739e2.tar.gz
gentoo-4e796211177f562ec2ffa223f7ab6de5c47739e2.tar.bz2
gentoo-4e796211177f562ec2ffa223f7ab6de5c47739e2.zip
dev-java/jetty-alpn-api: New package, required by netty-handler
Thanks to wltjr for the original ebuild. Package-Manager: portage-2.2.28
-rw-r--r--dev-java/jetty-alpn-api/Manifest1
-rw-r--r--dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild27
-rw-r--r--dev-java/jetty-alpn-api/metadata.xml14
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/jetty-alpn-api/Manifest b/dev-java/jetty-alpn-api/Manifest
new file mode 100644
index 000000000000..bfeb23ea134c
--- /dev/null
+++ b/dev-java/jetty-alpn-api/Manifest
@@ -0,0 +1 @@
+DIST alpn-api-1.1.2.v20150522.tar.gz 4246 SHA256 d6cb4ca709fee42a0f551447fbefcf66a483c78487923e671c6c553b57f3bb96 SHA512 5c7cedf80bf7b3e27fe365df2fb1a2b0f4eb5d94416f54565c960036c73a79aaee50fb7d00a0a856f2808be7dafa921b8ad89772101ff7bd97fe452a0e395e79 WHIRLPOOL b05a44bf094bd3f87699c8577ddf14e1942145464fce4caaf19a6bb7766d35851605303b25eb3caad98c0f1767fb142166e019fbe2990524c67b577b34a1b85a
diff --git a/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild b/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild
new file mode 100644
index 000000000000..fe5a1584867e
--- /dev/null
+++ b/dev-java/jetty-alpn-api/jetty-alpn-api-1.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN/jetty-/}"
+MY_PV="${PV}.v20150522"
+MY_P="${MY_PN}-${MY_PV}"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jetty's ALPN API"
+HOMEPAGE="http://www.eclipse.org/jetty/documentation/current/alpn-chapter.html"
+SRC_URI="https://github.com/eclipse/jetty.alpn/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.7"
+
+DEPEND=">=virtual/jdk-1.7"
+
+S="${WORKDIR}/${PN//-/.}-${MY_P}"
+JAVA_SRC_DIR="src/main/java"
diff --git a/dev-java/jetty-alpn-api/metadata.xml b/dev-java/jetty-alpn-api/metadata.xml
new file mode 100644
index 000000000000..d0ea9f190876
--- /dev/null
+++ b/dev-java/jetty-alpn-api/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eclipse/jetty.alpn.api</remote-id>
+ </upstream>
+ <longdescription>The Jetty project provides an implementation of the TLS extension for ALPN for OpenJDK 7 and OpenJDK 8. ALPN allows the application layer to negotiate which protocol to use over the secure connection.
+
+Any protocol can be negotiated by ALPN within a TLS connection. The protocols that are most commonly negotiated are HTTP/2 (for browsers that support it) and, historically, SPDY. The ALPN implementation is therefore not HTTP/2 or SPDY specific in any way. Jetty's ALPN implementation, although hosted under the umbrella of the Jetty project, is independent of Jetty (the Servlet Container); you can use the ALPN implementation in any other Java network server.</longdescription>
+</pkgmetadata>