summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-01-04 19:27:06 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-04 19:38:22 -0500
commit4f0828759b7a0efbded6036ad144b94ba6fc2acd (patch)
tree67f2e549bb16b340212efc6c83d2cb6a0634c003
parentmedia-libs/sdl2-mixer: add workaround to bad SOURCES building code (bug #570804) (diff)
downloadgentoo-4f0828759b7a0efbded6036ad144b94ba6fc2acd.tar.gz
gentoo-4f0828759b7a0efbded6036ad144b94ba6fc2acd.tar.bz2
gentoo-4f0828759b7a0efbded6036ad144b94ba6fc2acd.zip
sys-devel/prelink: clean up files in /var
We don't need the state/log files to exist ahead of time (as the cronjob will create them on demand), so punt them entirely to clean things up. Also update to EAPI=5 while we're here, and punt an old unused patch.
-rw-r--r--sys-devel/prelink/files/prelink-20061201-prelink-conf.patch31
-rw-r--r--sys-devel/prelink/prelink-20130503-r1.ebuild79
2 files changed, 79 insertions, 31 deletions
diff --git a/sys-devel/prelink/files/prelink-20061201-prelink-conf.patch b/sys-devel/prelink/files/prelink-20061201-prelink-conf.patch
deleted file mode 100644
index 9397088c5cd8..000000000000
--- a/sys-devel/prelink/files/prelink-20061201-prelink-conf.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- doc/prelink.conf.orig 2008-08-29 08:18:59.000000000 -0400
-+++ doc/prelink.conf 2008-08-29 08:21:48.000000000 -0400
-@@ -16,8 +16,11 @@
- -b *.a
- -b *.js
- -b /lib/modules
---b /usr/lib/locale
---b /usr/X11R6/lib{,64}/X11/xfig
-+-b /usr/lib{,32,64}/locale
-+-b /usr/lib{,32,64}/wine
-+-b /usr/lib{,32,64}/valgrind
-+-b /usr/X11R6/lib{,32,64}/X11/xfig
-+-b /usr/src
- -l /bin
- -l /usr/bin
- -l /sbin
-@@ -27,9 +30,9 @@
- -l /usr/games
- -l /usr/libexec
- -l /var/ftp/bin
---l /lib{,64}
---l /usr/lib{,64}
---l /usr/X11R6/lib{,64}
---l /usr/kerberos/lib{,64}
-+-l /lib{,32,64}
-+-l /usr/lib{,32,64}
-+-l /usr/X11R6/lib{,32,64}
-+-l /usr/kerberos/lib{,32,64}
- -l /usr/X11R6/LessTif
---l /var/ftp/lib{,64}
-+-l /var/ftp/lib{,32,64}
diff --git a/sys-devel/prelink/prelink-20130503-r1.ebuild b/sys-devel/prelink/prelink-20130503-r1.ebuild
new file mode 100644
index 000000000000..7e13d8d17b6e
--- /dev/null
+++ b/sys-devel/prelink/prelink-20130503-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Modifies ELFs to avoid runtime symbol resolutions resulting in faster load times"
+HOMEPAGE="https://people.redhat.com/jakub/prelink"
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+#SRC_URI="https://people.redhat.com/jakub/prelink/${P}.tar.bz2"
+
+# if not available on jakub's dev space extract the distfile with rpm2tarbz2 from
+# https://mirrors.kernel.org/fedora/development/rawhide/source/SRPMS/p/prelink-[ver].src.rpm
+#
+# track http://pkgs.fedoraproject.org/cgit/prelink.git/ for updates
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -arm ~ppc ~ppc64 ~x86"
+IUSE="selinux"
+
+DEPEND=">=dev-libs/elfutils-0.100[static-libs(+)]
+ selinux? ( sys-libs/libselinux[static-libs(+)] )
+ !dev-libs/libelf
+ >=sys-libs/glibc-2.8"
+RDEPEND="${DEPEND}
+ >=sys-devel/binutils-2.18"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20130503-prelink-conf.patch
+ epatch "${FILESDIR}"/${PN}-20130503-libiberty-md5.patch
+ epatch "${FILESDIR}"/${PN}-armhf-dynamic-linker.patch
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #469126
+
+ sed -i -e '/^CC=/s: : -Wl,--disable-new-dtags :' testsuite/functions.sh #100147
+ # >=binutils-2.22 --no-copy-dt-needed-entries is the default
+ # --copy-dt-needed-entries was renamed from --add-needed in 2.21, use the
+ # former so we don't have to bump the dep
+ sed -i \
+ -e '/CCLINK=/s:CCLINK="$(CC):& -Wl,--add-needed :' \
+ -e '/CXXLINK=/s:CXXLINK="$(CXX):& -Wl,--add-needed :' \
+ testsuite/Makefile.am
+
+ has_version 'dev-libs/elfutils[threads]' && append-ldflags -pthread
+
+ eautoreconf # prevent maintainer mode
+
+ # have to do this after eautoreconf or automake barfs on the trailing
+ # backslash of the previous line
+ sed -i -e 's:undosyslibs.sh::' testsuite/Makefile.in #254201
+
+ export ac_cv_{header_selinux_selinux_h,lib_selinux_is_selinux_enabled}=$(usex selinux)
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins doc/prelink.conf
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/prelink.cron prelink
+ newconfd "${FILESDIR}"/prelink.confd prelink
+}
+
+pkg_postinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ elog "You may wish to read the Gentoo Linux Prelink Guide, which can be"
+ elog "found online at:"
+ elog " https://wiki.gentoo.org/wiki/Prelink"
+ elog "Please edit /etc/conf.d/prelink to enable and configure prelink"
+ fi
+}