summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-06-07 12:21:55 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-06-08 19:58:31 -0400
commit4fa6deec130603d0fe3ce9196a0209481cfe366e (patch)
tree60c4743c15eb58ba0a8def6b93f4e459d3d9fd77
parentdev-qt/qt-docs: version bump (diff)
downloadgentoo-4fa6deec130603d0fe3ce9196a0209481cfe366e.tar.gz
gentoo-4fa6deec130603d0fe3ce9196a0209481cfe366e.tar.bz2
gentoo-4fa6deec130603d0fe3ce9196a0209481cfe366e.zip
dev-python/rst-linker: bump to 1.7
Closes: https://github.com/gentoo/gentoo/pull/1622 Package-Manager: portage-2.3.0_rc1
-rw-r--r--dev-python/rst-linker/Manifest1
-rw-r--r--dev-python/rst-linker/rst-linker-1.7.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index 1f4355d30687..5637ade29171 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1 +1,2 @@
DIST rst.linker-1.6.tar.gz 6439 SHA256 e1eab99dba26c4562f1a034bd0122f84035f0e54750b20ca1e017ed225c66a2e SHA512 f2511f2bef0ef90b9b9bcda11542e768d242cde5d617f17bec1c23cb21819510703033c63b3dda2cacae73a605de2d8930512e040c6703dd881b4dc0d7022baf WHIRLPOOL c097a20d3bd3f3cdc7aeade9a586818a47ad282877d47999de6aaa240595849b127ef84ee25e677bcfc21ce9b4b99e3e7fe7b71d8571ba465d0854b1961350c2
+DIST rst.linker-1.7.tar.gz 6798 SHA256 59038b0dce170f7d6459132a1b7358b01f71f372afbf5b1c07d0862ba4a5042e SHA512 380cd1b36a1153a6512144b7c83be75dfa95ce397437d34cb76c4c41de6266c77cf1f811f4fb0576838e10bd78e1f46394df11b0f7dc5e3fafeef36b6e8c9ba0 WHIRLPOOL 7d323528ed0c7bba5db1159eb18063a4b191d81d400c1e8d02d0dcff3265183ca4ca0d56de5c674883dc1d02ea77eb7ec83c1b08d4622f4d820f5a1702a5833b
diff --git a/dev-python/rst-linker/rst-linker-1.7.ebuild b/dev-python/rst-linker/rst-linker-1.7.ebuild
new file mode 100644
index 000000000000..e0ad47dab76e
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-1.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="https://github.com/jaraco/rst.linker"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/path-py[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ py.test --ignore=rst || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}