summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-12 21:56:10 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-12 21:56:10 +0900
commit511501b1893437d0f2cf30d98ee77d8b17f70fa5 (patch)
treed8edcd7005cf4310b7da41630d1753ba67650677
parentmail-client/sylpheed: drop old (diff)
downloadgentoo-511501b1893437d0f2cf30d98ee77d8b17f70fa5.tar.gz
gentoo-511501b1893437d0f2cf30d98ee77d8b17f70fa5.tar.bz2
gentoo-511501b1893437d0f2cf30d98ee77d8b17f70fa5.zip
mail-client/sylpheed: new upstream release
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--mail-client/sylpheed/Manifest1
-rw-r--r--mail-client/sylpheed/sylpheed-3.6.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/mail-client/sylpheed/Manifest b/mail-client/sylpheed/Manifest
index c5317700d3e5..c21fe885dd24 100644
--- a/mail-client/sylpheed/Manifest
+++ b/mail-client/sylpheed/Manifest
@@ -1,2 +1,3 @@
DIST sylpheed-3.4.2.tar.bz2 3474176 SHA256 198de08d01a5c150adae6b6612da80674bbc7ed59b58bbd7508124b869322ba3 SHA512 1bfaf5636facb6ca55173e914904be7f9fb9ca98eb440f5b548fbbbe03f5dfb5428801e878f3275d3683e715d0b4bd33f63f69f5f98578ce1a25cef695406b5e WHIRLPOOL a7dda342adb598027765c5ab6d14ae3e850bf39ff63d90a79927fa2aec1bf539454357cb6dea8664d21f68deeccf78fada264d04b0a14ff311ff5827717c4aa8
DIST sylpheed-3.5.1.tar.bz2 3561816 SHA256 3a5a04a13a0e2f32cdbc6e09d92b5143ca96df5fef23425cd81d96b8bd5b1087 SHA512 264aafb40eaa163405074480b2deb7eefe0d2158a107d9b26bc35d5506dcf5a52cf5712b81bd4c06b4c76e48c6e372c74473e5371bbdc80f230267f3b211c7f5 WHIRLPOOL 500978315913b99148d83df1f46991144ec467625837d422ed5ec9f4ce8a344f48e4ca6da7c25ca8ae5ed950c1464551de5e7da90ab27a9a7f2b1998ee4846b7
+DIST sylpheed-3.6.0.tar.bz2 3568998 SHA256 eba4a70b43b49dbf419934796677a69a71d069b71b0dd697a0008836be4db345 SHA512 84c59e327690ed7e637e9ce60e630da6cdad771ccc278e31e490ed643da55c295fb47e999ad421fc59dbbcfed990882022b96cf478bd47253692d2e86279c591 WHIRLPOOL 6b27d42e9ad2a27988ebe1aa37354ed95e48ba5a1be20626294f605b8bd3010d26addf11f2971adf86b563c7dd23d5c3da3851bf5137516097ff253217e01ed4
diff --git a/mail-client/sylpheed/sylpheed-3.6.0.ebuild b/mail-client/sylpheed/sylpheed-3.6.0.ebuild
new file mode 100644
index 000000000000..aa8d3e87a7be
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.6.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://${PN}.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap libressl nls oniguruma pda spell ssl xface"
+
+CDEPEND="net-libs/liblockfile
+ x11-libs/gtk+:2
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? (
+ app-text/gtkspell:2
+ dev-libs/dbus-glib
+ )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ xface? ( media-libs/compface )"
+
+DOCS="AUTHORS ChangeLog* NEW* PLUGIN* README* TODO*"
+
+src_configure() {
+ local htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/${PN}/plugins \
+ --with-manualdir="${htmldir}"/manual \
+ --with-faqdir="${htmldir}"/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ default
+
+ doicon *.png
+ domenu *.desktop
+
+ cd plugin/attachment_tool
+ emake DESTDIR="${D}" install-plugin
+ docinto plugin/attachment_tool
+ dodoc README
+}