summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2020-02-06 16:28:50 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-02-06 16:29:16 +0100
commit519c6e1201e4113f431446c807d13a3775e0116e (patch)
treea0c2eba3c2b394291d33f59959553ad0f5cc9409
parentsys-apps/systemd: fix segfault in systemd-sysctl (diff)
downloadgentoo-519c6e1201e4113f431446c807d13a3775e0116e.tar.gz
gentoo-519c6e1201e4113f431446c807d13a3775e0116e.tar.bz2
gentoo-519c6e1201e4113f431446c807d13a3775e0116e.zip
net-vpn/wireguard-tools: bump to 1.0.20200206
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--net-vpn/wireguard-tools/Manifest2
-rw-r--r--net-vpn/wireguard-tools/wireguard-tools-1.0.20200206.ebuild (renamed from net-vpn/wireguard-tools/wireguard-tools-1.0.20200121.ebuild)2
-rw-r--r--net-vpn/wireguard-tools/wireguard-tools-9999.ebuild104
3 files changed, 2 insertions, 106 deletions
diff --git a/net-vpn/wireguard-tools/Manifest b/net-vpn/wireguard-tools/Manifest
index e31bfc087d7b..ab902b9c8aa3 100644
--- a/net-vpn/wireguard-tools/Manifest
+++ b/net-vpn/wireguard-tools/Manifest
@@ -1 +1 @@
-DIST wireguard-tools-1.0.20200121.tar.xz 92804 BLAKE2B 206a6f3da102c4473c160f584de834704ea31e2f2dc842a8c5c28d66cf4ffe40746aca22d8efe336ab4c0433ef673a06468816b7e6cc51e80740acdb38782eaf SHA512 cd22467916c59ab53440e072fee6d0b01f2f9ee06fc3b71de4e74bc3aab05caf25519e5f723d9d160c491f917b7f064ee6b491c74edb52d7d2c29a08d86e41c2
+DIST wireguard-tools-1.0.20200206.tar.xz 92288 BLAKE2B 028717e09177ecd5836af32917ab62b645c027e72dbe69c1874db2a54675f957cb6cd551cf03f0a29e5c328abd9f3c33db001f680f3980a958aa1b47a673944d SHA512 c1ea44afb105ce11595f761d1c44298341fc9f919a01d17b77c9f1ee2ff314a75c59277c2561278016a64abc7c6ea970e04539658bfd1998f65328bc21139512
diff --git a/net-vpn/wireguard-tools/wireguard-tools-1.0.20200121.ebuild b/net-vpn/wireguard-tools/wireguard-tools-1.0.20200206.ebuild
index 5600d6cff472..641da7119c1f 100644
--- a/net-vpn/wireguard-tools/wireguard-tools-1.0.20200121.ebuild
+++ b/net-vpn/wireguard-tools/wireguard-tools-1.0.20200206.ebuild
@@ -22,7 +22,7 @@ SLOT="0"
IUSE="+wg-quick"
BDEPEND="virtual/pkgconfig"
-DEPEND="net-libs/libmnl"
+DEPEND=""
RDEPEND="${DEPEND}
wg-quick? (
|| ( net-firewall/nftables net-firewall/iptables )
diff --git a/net-vpn/wireguard-tools/wireguard-tools-9999.ebuild b/net-vpn/wireguard-tools/wireguard-tools-9999.ebuild
deleted file mode 100644
index bd16ac3af082..000000000000
--- a/net-vpn/wireguard-tools/wireguard-tools-9999.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info bash-completion-r1 systemd
-
-DESCRIPTION="Required tools for WireGuard, such as wg(8) and wg-quick(8)"
-HOMEPAGE="https://www.wireguard.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.zx2c4.com/wireguard-tools"
- KEYWORDS=""
-else
- SRC_URI="https://git.zx2c4.com/wireguard-tools/snapshot/wireguard-tools-${PV}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+wg-quick"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="net-libs/libmnl"
-RDEPEND="${DEPEND}
- wg-quick? (
- || ( net-firewall/nftables net-firewall/iptables )
- virtual/resolvconf
- )
- !<virtual/wireguard-1
-"
-
-wg_quick_optional_config_nob() {
- CONFIG_CHECK="$CONFIG_CHECK ~$1"
- declare -g ERROR_$1="CONFIG_$1: This option is required for automatic routing of default routes inside of wg-quick(8), though it is not required for general WireGuard usage."
-}
-
-pkg_setup() {
- use wg-quick || return 0
- wg_quick_optional_config_nob IP_ADVANCED_ROUTER
- wg_quick_optional_config_nob IP_MULTIPLE_TABLES
- wg_quick_optional_config_nob IPV6_MULTIPLE_TABLES
- if has_version net-firewall/nftables; then
- wg_quick_optional_config_nob NF_TABLES
- wg_quick_optional_config_nob NF_TABLES_IPV4
- wg_quick_optional_config_nob NF_TABLES_IPV6
- wg_quick_optional_config_nob NFT_CT
- wg_quick_optional_config_nob NFT_FIB
- wg_quick_optional_config_nob NFT_FIB_IPV4
- wg_quick_optional_config_nob NFT_FIB_IPV6
- elif has_version net-firewall/iptables; then
- wg_quick_optional_config_nob NETFILTER_XTABLES
- wg_quick_optional_config_nob NETFILTER_XT_MARK
- wg_quick_optional_config_nob NETFILTER_XT_CONNMARK
- wg_quick_optional_config_nob NETFILTER_XT_MATCH_COMMENT
- wg_quick_optional_config_nob IP6_NF_RAW
- wg_quick_optional_config_nob IP_NF_RAW
- wg_quick_optional_config_nob IP6_NF_FILTER
- wg_quick_optional_config_nob IP_NF_FILTER
- fi
- linux-info_pkg_setup
-}
-
-src_compile() {
- emake RUNSTATEDIR="${EPREFIX}/run" -C src CC="$(tc-getCC)" LD="$(tc-getLD)"
-}
-
-src_install() {
- dodoc README.md
- dodoc -r contrib
- emake \
- WITH_BASHCOMPLETION=yes \
- WITH_SYSTEMDUNITS=yes \
- WITH_WGQUICK=$(usex wg-quick) \
- DESTDIR="${D}" \
- BASHCOMPDIR="$(get_bashcompdir)" \
- SYSTEMDUNITDIR="$(systemd_get_systemunitdir)" \
- PREFIX="${EPREFIX}/usr" \
- -C src install
-}
-
-pkg_postinst() {
- einfo
- einfo "After installing WireGuard, if you'd like to try sending some packets through"
- einfo "WireGuard, you may use, for testing purposes only, the insecure client.sh"
- einfo "test example script:"
- einfo
- einfo " \$ bzcat ${ROOT}/usr/share/doc/${PF}/contrib/ncat-client-server/client.sh.bz2 | sudo bash -"
- einfo
- einfo "This will automatically setup interface wg0, through a very insecure transport"
- einfo "that is only suitable for demonstration purposes. You can then try loading the"
- einfo "hidden website or sending pings:"
- einfo
- einfo " \$ chromium http://192.168.4.1"
- einfo " \$ ping 192.168.4.1"
- einfo
- einfo "If you'd like to redirect your internet traffic, you can run it with the"
- einfo "\"default-route\" argument. You may not use this server for any abusive or illegal"
- einfo "purposes. It is for quick testing only."
- einfo
- einfo "More info on getting started can be found at: https://www.wireguard.com/quickstart/"
- einfo
-}