summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-10 14:15:34 -0500
committerWilliam Hubbs <williamh@gentoo.org>2015-08-10 14:18:14 -0500
commit540dfea7cd2f1699cbbfa9287ca7bf05987cac33 (patch)
tree7b6e6f51e85f3f88feb09dc27380b928ad4111d2
parentwww-servers/monkeyd: do verbose build for 1.6.0. (diff)
downloadgentoo-540dfea7cd2f1699cbbfa9287ca7bf05987cac33.tar.gz
gentoo-540dfea7cd2f1699cbbfa9287ca7bf05987cac33.tar.bz2
gentoo-540dfea7cd2f1699cbbfa9287ca7bf05987cac33.zip
dev-go/go-eapache-queue: convert to use the go eclasses
-rw-r--r--dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild35
1 files changed, 1 insertions, 34 deletions
diff --git a/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild b/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
index 8ea5793b5cd3..a30d4a755254 100644
--- a/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
+++ b/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
@@ -12,6 +12,7 @@ if [[ ${PV} = *9999* ]]; then
else
KEYWORDS="~amd64"
SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -22,37 +23,3 @@ SLOT="0/${PV}"
IUSE=""
DEPEND=""
RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
-src_install() {
- rm -rf src/${EGO_SRC}/.git* || die
- golang-build_src_install
-}