summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-06 08:57:04 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-06 09:39:18 +0200
commit55b2e7a206d7b31ca206bbd5b140bc34365cd464 (patch)
treed1f4e842ce932c25631b0fb445046fbf3b4f4171
parentnet-irc/weechat: 2.9 ppc64 stable, bug #740444 (diff)
downloadgentoo-55b2e7a206d7b31ca206bbd5b140bc34365cd464.tar.gz
gentoo-55b2e7a206d7b31ca206bbd5b140bc34365cd464.tar.bz2
gentoo-55b2e7a206d7b31ca206bbd5b140bc34365cd464.zip
dev-ruby/shoulda: add ruby27
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/shoulda/shoulda-3.6.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/shoulda-3.6.0-r1.ebuild b/dev-ruby/shoulda/shoulda-3.6.0-r1.ebuild
new file mode 100644
index 000000000000..3f730dc42bb7
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-3.6.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE=""
+
+# This now more or less a meta-gem and it only contains features for
+# integration tests using Appraisals, which we don't currently package.
+RESTRICT=test
+
+ruby_add_rdepend ">=dev-ruby/shoulda-context-1.0.1
+ dev-ruby/shoulda-matchers:3"
+
+all_ruby_prepare() {
+ sed -e '/executables/,/^ end/d ; /test_files/d; s/git ls-files/find . -print/' -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}