summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-20 09:49:16 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-20 09:50:32 +0200
commit569015025d09f245f150051fc003e76ac5332be4 (patch)
tree767c29ace5e669f827410bc216da9567244d20d4
parentnet-analyzer/cacti-spine: Add live ebuild (diff)
downloadgentoo-569015025d09f245f150051fc003e76ac5332be4.tar.gz
gentoo-569015025d09f245f150051fc003e76ac5332be4.tar.bz2
gentoo-569015025d09f245f150051fc003e76ac5332be4.zip
net-analyzer/ipsumdump: Fix includes, set OS headers dependency
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Fixes: https://bugs.gentoo.org/692550 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/ipsumdump/files/ipsumdump-1.86-SIOCGSTAMP.patch10
-rw-r--r--net-analyzer/ipsumdump/ipsumdump-1.86-r1.ebuild37
-rw-r--r--net-analyzer/ipsumdump/ipsumdump-1.86.ebuild3
3 files changed, 49 insertions, 1 deletions
diff --git a/net-analyzer/ipsumdump/files/ipsumdump-1.86-SIOCGSTAMP.patch b/net-analyzer/ipsumdump/files/ipsumdump-1.86-SIOCGSTAMP.patch
new file mode 100644
index 000000000000..c2f0a74fff11
--- /dev/null
+++ b/net-analyzer/ipsumdump/files/ipsumdump-1.86-SIOCGSTAMP.patch
@@ -0,0 +1,10 @@
+--- a/src/fromdevice.cc
++++ b/src/fromdevice.cc
+@@ -47,6 +47,7 @@
+
+ #if FROMDEVICE_ALLOW_LINUX
+ # include <sys/socket.h>
++# include <linux/sockios.h>
+ # include <net/if.h>
+ # include <features.h>
+ # include <linux/if_packet.h>
diff --git a/net-analyzer/ipsumdump/ipsumdump-1.86-r1.ebuild b/net-analyzer/ipsumdump/ipsumdump-1.86-r1.ebuild
new file mode 100644
index 000000000000..25325a3484db
--- /dev/null
+++ b/net-analyzer/ipsumdump/ipsumdump-1.86-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple TCP/IP Dump summarizer/analyzer"
+HOMEPAGE="http://read.seas.harvard.edu/~kohler/ipsumdump/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="the-Click-license"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ipv6 +nanotimestamp"
+
+RDEPEND="
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ dev-libs/expat
+ sys-apps/texinfo
+ virtual/os-headers
+"
+DOCS=(
+ NEWS.md
+ README.md
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.86-SIOCGSTAMP.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable ipv6 ip6) \
+ $(use_enable nanotimestamp)
+}
diff --git a/net-analyzer/ipsumdump/ipsumdump-1.86.ebuild b/net-analyzer/ipsumdump/ipsumdump-1.86.ebuild
index 182f6ec8e8f8..784df50ece56 100644
--- a/net-analyzer/ipsumdump/ipsumdump-1.86.ebuild
+++ b/net-analyzer/ipsumdump/ipsumdump-1.86.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,6 +20,7 @@ DEPEND="
dev-lang/perl
dev-libs/expat
sys-apps/texinfo
+ virtual/os-headers
"
DOCS=(
NEWS.md