summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-23 11:54:54 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-23 12:49:12 +0100
commit5736ced70b923fe72e76d7337fd7f1265e5f1013 (patch)
tree828b1a8dafba51441251c097551a0fbb867b8eb5
parentsys-devel/clang-runtime: Bump to 11.1.0-rc2 (diff)
downloadgentoo-5736ced70b923fe72e76d7337fd7f1265e5f1013.tar.gz
gentoo-5736ced70b923fe72e76d7337fd7f1265e5f1013.tar.bz2
gentoo-5736ced70b923fe72e76d7337fd7f1265e5f1013.zip
xfce-base/thunar: Bump to 4.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.17.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 317dec8d71c0..dceeeb3098ef 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,2 +1,3 @@
DIST thunar-1.8.16.tar.bz2 2479718 BLAKE2B 2de72f0b9977a9815c0a7f0376ceb01ddd5a68dda6c33e7d99f34378f00086e6652fa2cfcecd12129811ed6e78d45c7a1b321563ad98c5257bb6d3c58689c60d SHA512 1d096c7328b6131f097663d8f769a1e7a2a15cb24ca5116e28de38162cf1c5c544b8ed856b0d3df758947154b9e76ca720d3c614e7dca4edb71e8a219438e7a7
DIST thunar-4.16.2.tar.bz2 2434525 BLAKE2B e50fb41d7d333fe23729ddc01ce7e1313124ad3607e0e57fd210794b21f83fb83cd2a4ef9845638c0e10ceb5995392b754991600fc242e4a7e11af6a55971624 SHA512 761bc2b2106db523b5b56b9f330a42e487aeccd144d2118956a67d6935ee6d795edf543a815c3e035dd7cc4b0965679811d39d9c5e6b6f7ca84eb362f22561e0
+DIST thunar-4.17.0.tar.bz2 2448027 BLAKE2B c3890dfe22384ecaa7a71805c68938d59cdfcd0a602512395e9011692de242c808dc13229c0c3b3ad93973845fe9e291cee4f3b6275fc87c75efade7731d580e SHA512 6a344f89ae51c4c0cbdbac1542558aeab3c0eb45a79320e58785033a3faa2ff95751e72e089f6a2ff23056a18a403845a2b5603c89550a6ba2e0c8286f75a5e4
diff --git a/xfce-base/thunar/thunar-4.17.0.ebuild b/xfce-base/thunar/thunar-4.17.0.ebuild
new file mode 100644
index 000000000000..a50b1046a411
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.17.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+DEPEND=">=dev-libs/glib-2.50
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-4.15.3:=
+ >=xfce-base/libxfce4ui-4.15.3:=
+ >=xfce-base/libxfce4util-4.15.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )"
+RDEPEND="${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}