summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2021-06-23 10:07:37 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-06-29 19:01:39 +0200
commit5cbb80329caf44fa9ac1c856da4445d853811aca (patch)
treeaafad6fc7b366fcb6c352ac5ad93fec15e6c19a3
parentsys-apps/plocate: add myself as maintainer (diff)
downloadgentoo-5cbb80329caf44fa9ac1c856da4445d853811aca.tar.gz
gentoo-5cbb80329caf44fa9ac1c856da4445d853811aca.tar.bz2
gentoo-5cbb80329caf44fa9ac1c856da4445d853811aca.zip
sys-apps/plocate: add plocate-1.1.8
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Signed-off-by: Florian Schmaus <flow@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/21385
-rw-r--r--sys-apps/plocate/Manifest1
-rw-r--r--sys-apps/plocate/plocate-1.1.8.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index d732a44c7639..fe3b3f145814 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -1 +1,2 @@
DIST plocate-1.1.7.tar.gz 71546 BLAKE2B 3ea93c7fcea243d60e61dd9956d4eaef3f09d017d5b2487466e4bccbfb6ff6d2e2e328c3df7809eac3ca5c5e0941e67178c1707f3e16154a9d2c756dab3aea00 SHA512 48ca7bcb439e6ddfbc11f0679bb44ee7173be7f7a856d51d56143bd86e219e19683312036bfa96434a0eaaf0b6df58a1843ecae917143f8f0fbac83b39cb0b4b
+DIST plocate-1.1.8.tar.gz 71569 BLAKE2B 06ad0e9535b76bf0102cdeeb6014e2d84f85f51f5926520566e9c6871f04ac09651bb0674ed679d2a4c0d4e516e55dfef35a7021112fad3549bf76993554aeb5 SHA512 a685347df64ac1a3eb7789cb7023b4d0ffed5fb7435a4bd88c3943991e145a387829532ec0c01d30d851b97b8d3173ff4c7c274775e639b75f0b1b45e5bca2a6
diff --git a/sys-apps/plocate/plocate-1.1.8.ebuild b/sys-apps/plocate/plocate-1.1.8.ebuild
new file mode 100644
index 000000000000..a708c02300a6
--- /dev/null
+++ b/sys-apps/plocate/plocate-1.1.8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Posting locate is a much faster locate"
+HOMEPAGE="https://plocate.sesse.net/"
+SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
+
+# GPL-2 for updatedb
+# GPL-2+ for plocate itself
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+io-uring"
+
+RDEPEND="
+ acct-group/locate
+ app-arch/zstd:=
+ io-uring? ( sys-libs/liburing:= )
+ !sys-apps/mlocate
+"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~IO_URING"
+ERROR_IO_URING="required for USE=io-uring"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.5-no-systemd-check.patch
+)
+
+src_prepare() {
+ # Pretend liburing dep doesn't exist when USE flag off
+ if ! use io-uring; then
+ sed -i "s/dependency('liburing/dependency('/" meson.build || die
+ fi
+
+ # We'll install the manpage ourself to locate.1
+ sed -i "/install_man('plocate.1')/d" meson.build || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlocategroup=locate
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc README NEWS
+ newman "${S}"/${PN}.1 locate.1
+ dosym plocate /usr/bin/locate
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/plocate-cron.conf
+ fperms 0644 /etc/{updatedb,plocate-cron}.conf
+
+ insinto /etc/cron.daily
+ # Ensure that the cron file has the same name as the
+ # systemd-timer, to avoid plocate being run twice daily on systems
+ # with a systemd compatiblity layer. See also bug #780351.
+ newins "${FILESDIR}"/plocate.cron plocate-updatedb
+ fperms 0755 /etc/cron.daily/plocate-updatedb
+
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+ fi
+}