summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2018-02-14 16:11:04 +0100
committerUltrabug <ultrabug@gentoo.org>2018-02-14 16:11:04 +0100
commit5f6dab2fc0746430fde372788bfbf15ce51d3653 (patch)
tree4c563744a3adb9cf601d66d20ec3609501efbd57
parentwww-servers/uwsgi: drop old (diff)
downloadgentoo-5f6dab2fc0746430fde372788bfbf15ce51d3653.tar.gz
gentoo-5f6dab2fc0746430fde372788bfbf15ce51d3653.tar.bz2
gentoo-5f6dab2fc0746430fde372788bfbf15ce51d3653.zip
app-admin/mongo-tools: version bump fix #647470
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.4.13.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 498276f23fda..590cb75622cd 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -5,4 +5,5 @@ DIST mongo-tools-3.2.13.tar.gz 2712076 BLAKE2B 66e76e049b6a322e05dea21c241d983eb
DIST mongo-tools-3.2.16.tar.gz 2720003 BLAKE2B e5cb694549b5c70cd07fc8e891b1a78cffec0f99aab62978c70d38c01d9b1ae9c401f9618d24d9afc036ae66657eac40f710076d177497b51c97b963cff31d86 SHA512 61c8cfd04a36e329c3573b73945d20a5623e1aa0a3430b309530e85e4289a27a46a850ec48ede7f04e66e67e23745ef26f5f4ddcf68ffeb647128e3d2526a724
DIST mongo-tools-3.2.17.tar.gz 2719970 BLAKE2B 666b67d8abdd10f7fa7c557e3c3906fb3cc6bcfa0b97a05e39e5f1ea923d2beb5ec249b3b0a521c4cce4bd595bf18672d8bce38152f84825bb3fffb058fd3b29 SHA512 62c2540027e07b8276621e08d13657864d16021030e3c8f9bc0d351454319d448f889cf6a48b8467ea3270365376ed0c3beb42ceae3f28357910148c6b4054b2
DIST mongo-tools-3.4.10.tar.gz 4719399 BLAKE2B 8165248bf58f2ea2b02e365a3609c72b72e98dd5902f176e251fa2add1ad26e90900e06c35dc6db4dbe161e541bedfc1776f5e15bbb41dcc9a7be17800424362 SHA512 b861bb3fb1a32c3aa2efefcf6a13bb6d4783ac1a9b006c477fd04deb338cbf6b7adc3944bc6919513b92bd96b8500813ff4af49c9dec0719ebd2fdaa99bc39a5
+DIST mongo-tools-3.4.13.tar.gz 4719488 BLAKE2B 27c7716b21f1a23408d0f31aee111c5877f5172121a987c234ff01eb2690bbc71bca4e00fc13b701ca6b91dce0c9aaae43c2239a60a52e130e1390bf5bafef60 SHA512 c233268328ef868ec06c9a9d83009141b39c84ba642e7de7dece3210717ba8de600f39896a30ed23d1577db9f4697c3a8d720cf35248bca2b00a17642b043237
DIST mongo-tools-3.6.2.tar.gz 4693924 BLAKE2B 61c44d579f6eb4013ee6c0118ebe89a2d454ef8cf6ad933479885cb71d169185272b03d9c63fa738d67bbd1b9efd4bc964eb17adcc5002508589d198cdb17752 SHA512 5ac2b1d2b33271f63c406c69bd8a576a21f4dcaa6f75839e0f907ebc9968f0e121eb3800e88da050c120856e7ddda4f12d551bb731d4acac0f5cf09f66fc948a
diff --git a/app-admin/mongo-tools/mongo-tools-3.4.13.ebuild b/app-admin/mongo-tools/mongo-tools-3.4.13.ebuild
new file mode 100644
index 000000000000..1ec457f1ee8f
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.4.13.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # do not substitute version because it uses git
+ sed -i '/^sed/,+3d' build.sh || die
+ sed -i '/^mv/d' build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+
+ # ensure we use bash wrt #582906
+ sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
+
+ default
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh ${myconf[@]} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}