summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-24 12:30:12 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-24 12:30:12 -0500
commit60687094052f6401808b6931746a4201957c2156 (patch)
treec4a9c2436f83703f81788bf0be101627eff43e65
parentwww-client/lynx: fix ncurses cross-compiling logic (diff)
downloadgentoo-60687094052f6401808b6931746a4201957c2156.tar.gz
gentoo-60687094052f6401808b6931746a4201957c2156.tar.bz2
gentoo-60687094052f6401808b6931746a4201957c2156.zip
sys-libs/ncurses: use the same has_version test #566008
The previous commit f5b7039a9bc8c63240340b947c80393e92e21afe added the :0 slot qualifier to the first has_version test but not to the second. This breaks when building ncurses-6.0:0 on a system that has SLOT=5 already installed.
-rw-r--r--sys-libs/ncurses/ncurses-6.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-libs/ncurses/ncurses-6.0-r1.ebuild b/sys-libs/ncurses/ncurses-6.0-r1.ebuild
index 9b5613869e45..47c80c494307 100644
--- a/sys-libs/ncurses/ncurses-6.0-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-6.0-r1.ebuild
@@ -188,7 +188,7 @@ do_configure() {
src_compile() {
# See comments in src_configure.
- if ! ROOT=/ has_version "~sys-libs/${P}" ; then
+ if ! ROOT=/ has_version "~sys-libs/${P}:0" ; then
BUILD_DIR="${WORKDIR}" \
do_compile cross -C progs tic
fi