summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2019-01-15 21:47:14 -0500
committerPatrice Clement <monsieurp@gentoo.org>2019-01-17 09:53:52 +0100
commit625c336da99af7ed08adc56ab05ccca57f6c88c9 (patch)
tree86b8c7326b14ed5bf540449bb1b1e3239dd99927
parentdev-java/oracle-jre-bin-1.8.0.181: removed obsolete (diff)
downloadgentoo-625c336da99af7ed08adc56ab05ccca57f6c88c9.tar.gz
gentoo-625c336da99af7ed08adc56ab05ccca57f6c88c9.tar.bz2
gentoo-625c336da99af7ed08adc56ab05ccca57f6c88c9.zip
app-misc/mosquitto: version bump to 1.5.5.
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/10845 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-misc/mosquitto/Manifest1
-rw-r--r--app-misc/mosquitto/mosquitto-1.5.5.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/app-misc/mosquitto/Manifest b/app-misc/mosquitto/Manifest
index a4a3696a6d5c..9336c0b65a5f 100644
--- a/app-misc/mosquitto/Manifest
+++ b/app-misc/mosquitto/Manifest
@@ -1,4 +1,5 @@
DIST mosquitto-1.4.14.tar.gz 365596 BLAKE2B 92bcb1fd9e67711d6ce8db5e767be31a1321866205cf4cad684d8b77a8b14a2eaf5e4367a74d5dd8f814f0d229dc77ce878879632c0c34c6a23f7975bf6ae8c7 SHA512 dc75a971354f87deeb79f32435acfae9bc561a1a24a75ee4940a35176ff91758071930d2105d8dee2a090e07527dbfaa5692bece67e03cc87e8b4b8b46f846c2
DIST mosquitto-1.5.3.tar.gz 425844 BLAKE2B d868dd67cd86e57f6af8e5556e0cee520f60cac4f16a24ceeec163acf5663339908d77304b7e70898ef5afaeeabb57c2a2857df297600180e1b9db6f2bf990b1 SHA512 8aa4f85914316c2dc08908a649779946ab33b23ea669c6f7eed0d8a1af7ae26381cfe1a50c32d220658f8693ef6a86045690824af4b7ca0271426ff3455e7796
DIST mosquitto-1.5.4.tar.gz 430602 BLAKE2B 3d9aefdd6caac926fd211df20932904dbccd4bae923bcf2ca1f698d962098fdd606145d229c849dc87ab4daf10af97dc1ecd9e1b4073e9abf67ca8bd17856311 SHA512 4e7ae21304afa843d4d48a8ea0bcf0173deca25961bcd294f86eedbdd8ec59eeca3c8cf5f2d72765128756b2cdf9460f5718041a67c66ce6ac76679cdac247c7
+DIST mosquitto-1.5.5.tar.gz 431998 BLAKE2B d6963235c70fd5ad1f73ea6964e800041afd6fad89a83f3d2c5fd6d843048f328dc93368c99e83820f110dfabd56783fa175a1169bc75316331df62f846409f3 SHA512 4984a8c3a48450ae87dfca9ea825433332c22a5c1b214b7c6d134789675431ba1bcebaceea2fe32c5d32c91ec47b9ded7b61c0c2caf6551f10e4f8dc455a5351
DIST mosquitto-1.5.tar.gz 419614 BLAKE2B d405e1e4f967f1030229a2e64793b84a3c8dc356a3b8d95a9bfc50a623cdb79517bbcfda87275f23c44002f3a41a20db58fed5a33d2c7d63da95e0d6d15951bb SHA512 29b82bc0c6510fa5062cb43c06bd91ce5223be5689cba077df8b2cb5ac377cb125b8a8bb292b53bcec0d4b186977c25c3ecdd8c92d4ed996fde07f8c759c0668
diff --git a/app-misc/mosquitto/mosquitto-1.5.5.ebuild b/app-misc/mosquitto/mosquitto-1.5.5.ebuild
new file mode 100644
index 000000000000..30791550cf93
--- /dev/null
+++ b/app-misc/mosquitto/mosquitto-1.5.5.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit systemd user toolchain-funcs python-any-r1
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="https://mosquitto.org/"
+SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ srv? ( net-dns/c-ares )
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ websockets? ( net-libs/libwebsockets )"
+
+_emake() {
+ LIBDIR=$(get_libdir)
+ emake \
+ CC="$(tc-getCC)" \
+ LIB_SUFFIX="${LIBDIR:3}" \
+ WITH_BRIDGE="$(usex bridge)" \
+ WITH_PERSISTENCE="$(usex persistence)" \
+ WITH_SRV="$(usex srv)" \
+ WITH_TLS="$(usex ssl)" \
+ WITH_WEBSOCKETS="$(usex websockets)" \
+ WITH_WRAP="$(usex tcpd)" \
+ "$@"
+}
+
+pkg_setup() {
+ enewgroup mosquitto
+ enewuser mosquitto -1 -1 -1 mosquitto
+}
+
+src_prepare() {
+ default
+ if use persistence; then
+ sed -i -e "/^#autosave_interval/s|^#||" \
+ -e "s|^#persistence false$|persistence true|" \
+ -e "/^#persistence_file/s|^#||" \
+ -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+ mosquitto.conf || die
+ fi
+
+ # Remove prestripping
+ sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
+ client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
+
+ python_setup
+ rm test/{broker,lib}/ptest.py || die
+ python_fix_shebang test
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake test
+}
+
+src_install() {
+ _emake DESTDIR="${D}" prefix=/usr install
+ keepdir /var/lib/mosquitto
+ fowners mosquitto:mosquitto /var/lib/mosquitto
+ dodoc readme.md CONTRIBUTING.md ChangeLog.txt
+ doinitd "${FILESDIR}"/mosquitto
+ insinto /etc/mosquitto
+ doins mosquitto.conf
+ systemd_dounit "${FILESDIR}/mosquitto.service"
+
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto "/usr/share/doc/${PF}"
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "The Python module has been moved out of mosquitto."
+ elog "See https://mosquitto.org/documentation/python/"
+ else
+ elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
+ elog ""
+ elog " rc-update add mosquitto default"
+ elog " or"
+ elog " systemctl enable mosquitto"
+ fi
+}