summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-28 10:39:22 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-28 10:40:04 -0700
commit62baa97969a52b3f25dff221604523d56855fac2 (patch)
tree6efabf9edeefa9f2d9e758b0f2605cbaa0fb5e71
parentgames-puzzle/skoosh: Remove (diff)
downloadgentoo-62baa97969a52b3f25dff221604523d56855fac2.tar.gz
gentoo-62baa97969a52b3f25dff221604523d56855fac2.tar.bz2
gentoo-62baa97969a52b3f25dff221604523d56855fac2.zip
mail-client/mail-notification: Remove
Closes: https://bugs.gentoo.org/713030 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--mail-client/mail-notification/Manifest1
-rw-r--r--mail-client/mail-notification/files/mail-notification-5.4-remove-ubuntu-special-case.patch33
-rw-r--r--mail-client/mail-notification/files/mail-notification-dont-link-against-bsd-compat.patch10
-rw-r--r--mail-client/mail-notification/files/mail-notification-jb-gcc-format.patch15
-rw-r--r--mail-client/mail-notification/mail-notification-5.4-r10.ebuild110
-rw-r--r--mail-client/mail-notification/metadata.xml17
-rw-r--r--profiles/package.mask6
7 files changed, 0 insertions, 192 deletions
diff --git a/mail-client/mail-notification/Manifest b/mail-client/mail-notification/Manifest
deleted file mode 100644
index 653bebe61828..000000000000
--- a/mail-client/mail-notification/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST mail-notification-9ae8768.tar.gz 573948 BLAKE2B 03ca4d8007aa0ec2d0caa01934c1e127b629c3c41e28e88fb24bc3fae21052a0c315e4784162afd7e0aac524b1f6510f897895bd37d7684ca6f2a81e1247ffeb SHA512 57ddeb63816dd1db1b732dd13fedeb366e1d82f070feb3f9cf854a85a0e66ab2a60a92126fa57cdc338df699e304007dd84593ea1d6185b08c21a018e441629b
diff --git a/mail-client/mail-notification/files/mail-notification-5.4-remove-ubuntu-special-case.patch b/mail-client/mail-notification/files/mail-notification-5.4-remove-ubuntu-special-case.patch
deleted file mode 100644
index b3501c863625..000000000000
--- a/mail-client/mail-notification/files/mail-notification-5.4-remove-ubuntu-special-case.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/jbsrc/lib/src/core/jb-feature.c.~1~ 2008-04-27 16:47:27.000000000 +0200
-+++ b/jbsrc/lib/src/core/jb-feature.c 2008-07-22 11:40:50.856886210 +0200
-@@ -164,8 +164,6 @@
- static void
- gconf_configure (void)
- {
-- JBVariable *variable;
--
- jb_require_program("gconftool-2");
-
- if (! strcmp(jb_variable_get_string("gconf-config-source"), "autodetect"))
-@@ -178,21 +176,6 @@
- jb_variable_set_string("gconf-config-source", config_source);
- g_free(config_source);
- }
--
-- /* fix the default schemas dir on Ubuntu */
-- variable = jb_variable_get_variable_or_error("gconf-schemas-dir");
-- if (! variable->user_set)
-- {
-- static const char *ubuntu_dir = "$datadir/gconf/schemas";
-- char *expanded;
--
-- expanded = jb_variable_expand(ubuntu_dir, NULL);
--
-- if (g_file_test(expanded, G_FILE_TEST_IS_DIR))
-- jb_variable_set_string("gconf-schemas-dir", ubuntu_dir);
--
-- g_free(expanded);
-- }
- }
-
- static void
diff --git a/mail-client/mail-notification/files/mail-notification-dont-link-against-bsd-compat.patch b/mail-client/mail-notification/files/mail-notification-dont-link-against-bsd-compat.patch
deleted file mode 100644
index 4f203c0179cd..000000000000
--- a/mail-client/mail-notification/files/mail-notification-dont-link-against-bsd-compat.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/jbsrc/jb.c.orig 2014-01-19 20:06:48.525462981 +0100
-+++ b/jbsrc/jb.c 2014-01-19 20:07:36.087934897 +0100
-@@ -425,7 +425,6 @@
- */
- jb_compile_options_add_cflags(object->compile_options, "-std=c99");
- jb_compile_options_add_cppflags(object->compile_options, "-D_BSD_SOURCE -D_POSIX_C_SOURCE=199309L");
-- jb_compile_options_add_libs(object->compile_options, "-lbsd-compat");
- }
-
- jb_compile_options_add_string_defines(object->compile_options,
diff --git a/mail-client/mail-notification/files/mail-notification-jb-gcc-format.patch b/mail-client/mail-notification/files/mail-notification-jb-gcc-format.patch
deleted file mode 100644
index c99b01eda48f..000000000000
--- a/mail-client/mail-notification/files/mail-notification-jb-gcc-format.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: epienbroek-mail-notification-eab5c13/jbsrc/lib/src/core/jb-util.c
-===================================================================
---- epienbroek-mail-notification-eab5c13.orig/jbsrc/lib/src/core/jb-util.c
-+++ epienbroek-mail-notification-eab5c13/jbsrc/lib/src/core/jb-util.c
-@@ -208,6 +208,10 @@ jb_message_result_string_format (const c
- g_free(message);
- }
-
-+#if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ > 4)
-+static void print_warning_or_error (const char *prefix, const char *format, va_list args) __attribute__ ((format(printf, 1, 0)));
-+#endif
-+
- static void
- print_warning_or_error (const char *prefix, const char *format, va_list args)
- {
diff --git a/mail-client/mail-notification/mail-notification-5.4-r10.ebuild b/mail-client/mail-notification/mail-notification-5.4-r10.ebuild
deleted file mode 100644
index 4c0b026eefaf..000000000000
--- a/mail-client/mail-notification/mail-notification-5.4-r10.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2 multilib flag-o-matic toolchain-funcs
-
-DESCRIPTION="Status icon informing about new mail"
-HOMEPAGE="http://www.nongnu.org/mailnotify/ https://github.com/epienbroek/mail-notification"
-
-GIT_REVISION="9ae8768" # Same as Fedora
-SRC_URI="https://github.com/epienbroek/${PN}/tarball/${GIT_REVISION} -> ${PN}-${GIT_REVISION}.tar.gz"
-S="${WORKDIR}/epienbroek-${PN}-${GIT_REVISION}"
-
-KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-linux"
-SLOT="0"
-LICENSE="GPL-3"
-IUSE="+gnome-keyring libressl sasl ssl sylpheed"
-
-LANGS="bg ca cs de es fr ja nl pl pt pt_BR ru sr sr@Latn sv"
-
-# gmime is actually optional, but it's used by so much of the package
-# it's pointless making it optional. gnome-keyring is required for
-# several specific access methods, and thus linked to those USE flags
-# instead of adding a keyring USE flag.
-RDEPEND="
- x11-libs/gtk+:3
- >=dev-libs/glib-2.14:2
- >=gnome-base/gconf-2.6
- >=gnome-base/libgnomeui-2.14
- dev-libs/dbus-glib
- dev-libs/gmime:2.6
- >=x11-libs/libnotify-0.4.1
- gnome-keyring? ( gnome-base/libgnome-keyring )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- sasl? ( >=dev-libs/cyrus-sasl-2 )
- sylpheed? ( mail-client/sylpheed )
-"
-DEPEND="${RDEPEND}
- app-text/rarian
- dev-util/gob
- sys-devel/gettext
- virtual/pkgconfig
- >=dev-util/intltool-0.35.0
-"
-# this now uses JB (the Jean-Yves Lefort's Build System) as a build system
-# instead of autotools, this is a little helper function that basically does
-# the same thing as use_enable
-use_var() {
- echo "${2:-$1}=$(usex $1)"
-}
-
-src_prepare() {
- sed -i -e '/jb_rule_set_install_message/d' \
- -e '/jb_rule_add_install_command/d' \
- jbsrc/jb.c || die
-
- # Ensure we never append -Werror
- sed -i -e 's/ -Werror//' jb jbsrc/jb.c || die
-
- # We are not Ubuntu, and this could be the cause of #215281
- eapply "${FILESDIR}/${P}-remove-ubuntu-special-case.patch"
-
- # Apply Fedora patches
- # Fix gcc warning
- eapply "${FILESDIR}/${PN}-jb-gcc-format.patch"
- # Fix build with latest libc
- eapply "${FILESDIR}/${PN}-dont-link-against-bsd-compat.patch"
-
- gnome2_src_prepare
-}
-
-src_configure() {
- set -- \
- ./jb configure destdir="${D}" prefix="${EPREFIX}/usr" libdir="${EPREFIX}/usr/$(get_libdir)" \
- sysconfdir="${EPREFIX}/etc" localstatedir="${EPREFIX}/var" cc="$(tc-getCC)" \
- cflags="${CFLAGS}" cppflags="${CXXFLAGS}" ldflags="${LDFLAGS}" \
- scrollkeeper-dir="${EPREFIX}/var/lib/scrollkeeper" \
- $(use_var gnome-keyring gmail) \
- $(use_var gnome-keyring imap) \
- $(use_var gnome-keyring pop3) \
- $(use_var sasl) \
- $(use_var ssl) \
- $(use_var sylpheed)
- echo "$@"
- "$@" || die
-}
-
-src_compile() {
- ./jb build || die
-}
-
-src_install() {
- GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1" ./jb install || die
- einstalldocs
- rm -rf "${ED}/var/lib/scrollkeeper"
-
- if [[ -n ${LINGUAS+set} ]]; then
- einfo "Cleaning up locales..."
- for lang in ${LANGS}; do
- if has ${lang} ${LINGUAS}; then
- einfo "- keeping ${lang}"
- else
- rm -Rf "${D}"/usr/share/locale/"${lang}" || die
- fi
- done
- fi
-}
diff --git a/mail-client/mail-notification/metadata.xml b/mail-client/mail-notification/metadata.xml
deleted file mode 100644
index 7065e3c706b0..000000000000
--- a/mail-client/mail-notification/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>
-A GNOME trayicon which checks for email. Supports mbox, MH,
-Maildir, IMAP, Sylpheed, POP3, Gmail and Evolution. Authenticates via
-apop, ssl, sasl.
-</longdescription>
- <use>
- <flag name="sylpheed">Enable support for MH mailboxes used by
- <pkg>mail-client/sylpheed</pkg></flag>
- </use>
- <upstream>
- <remote-id type="github">epienbroek/mail-notification</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 7d2dac67c649..1f172b84b2e2 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -750,12 +750,6 @@ dev-util/buildbot-www
net-fs/ncpfs
net-misc/ipx-utils
-# Matt Turner <mattst88@gentoo.org> (2020-03-28)
-# Last release 2008. Last upstream commit 2013. Blocks removal of
-# gnome-base/libgnome-keyring
-# Bug #713030
-mail-client/mail-notification
-
# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-03-27)
# Vulnerable old version of icedtea-web #711392
# new version is not packaged yet