summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-08 14:13:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-08 14:22:23 +0200
commit65d6ff85d282ebb670794c26b9fc7b77b2280455 (patch)
treef85b465da03c893e9c0211864dadaa054dd143ce
parentdev-ros/pcl_conversions: Bump to 1.6.1. (diff)
downloadgentoo-65d6ff85d282ebb670794c26b9fc7b77b2280455.tar.gz
gentoo-65d6ff85d282ebb670794c26b9fc7b77b2280455.tar.bz2
gentoo-65d6ff85d282ebb670794c26b9fc7b77b2280455.zip
dev-ros/pcl_ros: Bump to 1.6.1.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--dev-ros/pcl_ros/Manifest1
-rw-r--r--dev-ros/pcl_ros/pcl_ros-1.6.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ros/pcl_ros/Manifest b/dev-ros/pcl_ros/Manifest
index f9ec2f6395fc..16bae660b40c 100644
--- a/dev-ros/pcl_ros/Manifest
+++ b/dev-ros/pcl_ros/Manifest
@@ -1 +1,2 @@
DIST perception_pcl-1.5.4.tar.gz 73829 BLAKE2B cfc6e964691da42717d134e0b639ef4af4491074de171a84d081bf66c061a51b7c2da750ff539dd784a7a4c34cfdfe18d7d2e38c4e6d0370fbc441f9b3a6196d SHA512 e9da9b2f9b602b67bceec9b0adf515b500d77c9e5c2dbdc1f63bf5a91419bbf7f9f41d602646b8197dffcf7a077b63eb402a507dbc6bb96405a8f4d64576e36e
+DIST perception_pcl-1.6.1.tar.gz 82552 BLAKE2B a442c9df193e38b6aca9e45ec3a469d6603bc2c909fc8c33ad612b2b6448956863555608cb0a0102593e2e71aa7f54ae88b677c2bfbde7df23b114ff4ca83c8f SHA512 c0b63833dd12f3eee5f5ec1e5d8f8bd9c001f1f1787572717a0845fa9a18862bb49a134638f9f0bde5587ac26ab8fd9e6534fcd5ed6b69842780a6fd3762fb5c
diff --git a/dev-ros/pcl_ros/pcl_ros-1.6.1.ebuild b/dev-ros/pcl_ros/pcl_ros-1.6.1.ebuild
new file mode 100644
index 000000000000..8a6af2083788
--- /dev/null
+++ b/dev-ros/pcl_ros/pcl_ros-1.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library) ROS interface stack"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rosbag
+ dev-ros/rosconsole
+ dev-ros/roslib
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ >=dev-cpp/eigen-3.2.5:3
+ dev-ros/pluginlib
+ dev-libs/console_bridge:=
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/tf2_eigen
+ dev-ros/nodelet
+ dev-ros/nodelet_topic_tools
+ sci-libs/pcl:=[qhull]
+ >=dev-ros/pcl_conversions-0.2.1-r1
+ dev-libs/boost:=[threads]
+ dev-ros/pcl_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"