summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-10-24 15:45:12 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-10-24 15:45:32 -0500
commit674cec4411552e0f53794d9680278da740433567 (patch)
tree24ce025979fa60e3ca2784c1118bec65d944a8fe
parentdev-lang/gnat-gpl does not build with jit and march=native (diff)
downloadgentoo-674cec4411552e0f53794d9680278da740433567.tar.gz
gentoo-674cec4411552e0f53794d9680278da740433567.tar.bz2
gentoo-674cec4411552e0f53794d9680278da740433567.zip
sys-apps/openrc: 0.39.1 bump for bug #669500.
closes: https://bugs.gentoo.org/669500 Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-apps/openrc/Manifest1
-rw-r--r--sys-apps/openrc/openrc-0.39.1.ebuild326
2 files changed, 327 insertions, 0 deletions
diff --git a/sys-apps/openrc/Manifest b/sys-apps/openrc/Manifest
index e5539ebf73a9..eda265b18506 100644
--- a/sys-apps/openrc/Manifest
+++ b/sys-apps/openrc/Manifest
@@ -4,4 +4,5 @@ DIST openrc-0.36.tar.gz 240179 BLAKE2B 1361d22782d6063e7fce61a98ef1e1f754d0208ec
DIST openrc-0.37.tar.gz 240928 BLAKE2B b802260a3bd71e6d8e6d54b21007024481d42a4f179eff824a39fb91f5b1cd4f7a2fd52d9e7f23b1077965b57d319a99a5b39b8cd2d7f66dfe272b4497d53a22 SHA512 16235774ad28a66308dd1ea00238b4025a4d26c9c0bb6cdb032f28d00479520c4c5fdb349f82d33a535eee3d491d0349b5871b15cae30ef296ec476883965b83
DIST openrc-0.38.2.tar.gz 240924 BLAKE2B a50e567aa3ac1edfd4e7cbdfbf3d7ce6ac39b7d7c2b4a9bcc8cf088735fa436a334eb077ecb10b67f6f5faab979ba62729aca4f3f61e12167cbd48fc8a7f3776 SHA512 5c5f1cfa9990970a02619c5b97c0d424d921fe16e83767372beee9a7b296c6ea33b43ae4045cf7266254b98871a5d347de1040443fe8fc68d7b9d164eed909e6
DIST openrc-0.38.3.tar.gz 238031 BLAKE2B 87d1546e21d581feda4064cd64bf43f762203becdcc4b002bf868f17403bd42770cb1106a8bc383c8d69e19ad66ad2bedaa7090c95206597e8a9b6e2ba481dcc SHA512 6bb42ccdab5fb24b11f5042bf19850f440d3494b6bd1d7b8db31b592f051fcd26feac1c8d9ef515238c53c6f5bf98a8c367a48471c178ae829e05c56bd24cfde
+DIST openrc-0.39.1.tar.gz 243215 BLAKE2B 81b722626e301c6b98c4f29c521ba725748aa5f29958f40d9e83c675bb3cd100baf8a5b0cc7a2fb183b9fa7150756c5b29d863d12df680790a83ed40a2fca278 SHA512 88fad7787776afbe5cb9558e96d6f6056c4854604bc4bbc60db26ec31fc8e40fb184fcb7cd6ba7bf1464f862e4f1db79b28607db9bac34f3a33261c07d134e4e
DIST openrc-0.39.tar.gz 243270 BLAKE2B d9ce9c48edfe867468c286bf24f2aa4591dd77f44f7b93cac41bf9035984ef0b0b9e35b6ba356e0733bad048567c856ef05e6ecc1736b8ce1824d71e775b4343 SHA512 ced69869ead3f3e84ec9b9746c7f5a0cb205d5ebac07d6743a187739021571a96932cf07f5cfc3d79e15d00d4ea977bb54574f36037eafe1b34043525f1f8764
diff --git a/sys-apps/openrc/openrc-0.39.1.ebuild b/sys-apps/openrc/openrc-0.39.1.ebuild
new file mode 100644
index 000000000000..78e08b97990d
--- /dev/null
+++ b/sys-apps/openrc/openrc-0.39.1.ebuild
@@ -0,0 +1,326 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic pam toolchain-funcs
+
+DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
+HOMEPAGE="https://github.com/openrc/openrc/"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/OpenRC/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="audit debug ncurses pam newnet prefix +netifrc selinux static-libs
+ unicode kernel_linux kernel_FreeBSD"
+
+COMMON_DEPEND="kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-ubin-9.0_rc sys-process/fuser-bsd ) )
+ ncurses? ( sys-libs/ncurses:0= )
+ pam? (
+ sys-auth/pambase
+ virtual/pam
+ )
+ audit? ( sys-process/audit )
+ kernel_linux? (
+ sys-process/psmisc
+ !<sys-process/procps-3.3.9-r2
+ )
+ selinux? (
+ sys-apps/policycoreutils
+ >=sys-libs/libselinux-2.6
+ )
+ !<sys-apps/baselayout-2.1-r1
+ !<sys-fs/udev-init-scripts-27"
+DEPEND="${COMMON_DEPEND}
+ virtual/os-headers
+ ncurses? ( virtual/pkgconfig )"
+RDEPEND="${COMMON_DEPEND}
+ !prefix? (
+ kernel_linux? (
+ >=sys-apps/sysvinit-2.86-r6[selinux?]
+ virtual/tmpfiles
+ )
+ kernel_FreeBSD? ( sys-freebsd/freebsd-sbin )
+ )
+ selinux? (
+ >=sec-policy/selinux-base-policy-2.20170204-r4
+ >=sec-policy/selinux-openrc-2.20170204-r4
+ )
+ !<app-shells/gentoo-bashcomp-20180302
+ !<app-shells/gentoo-zsh-completions-20180228
+"
+
+PDEPEND="netifrc? ( net-misc/netifrc )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ local ver="git-${EGIT_VERSION:0:6}"
+ sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/gitver.mk || die
+ fi
+}
+
+src_compile() {
+ unset LIBDIR #266688
+
+ MAKE_ARGS="${MAKE_ARGS}
+ LIBNAME=$(get_libdir)
+ LIBEXECDIR=${EPREFIX}/lib/rc
+ MKBASHCOMP=yes
+ MKNET=$(usex newnet)
+ MKSELINUX=$(usex selinux)
+ MKAUDIT=$(usex audit)
+ MKPAM=$(usev pam)
+ MKSTATICLIBS=$(usex static-libs)
+ MKZSHCOMP=yes"
+
+ local brand="Unknown"
+ if use kernel_linux ; then
+ MAKE_ARGS="${MAKE_ARGS} OS=Linux"
+ brand="Linux"
+ elif use kernel_FreeBSD ; then
+ MAKE_ARGS="${MAKE_ARGS} OS=FreeBSD"
+ brand="FreeBSD"
+ fi
+ export BRANDING="Gentoo ${brand}"
+ use prefix && MAKE_ARGS="${MAKE_ARGS} MKPREFIX=yes PREFIX=${EPREFIX}"
+ export DEBUG=$(usev debug)
+ export MKTERMCAP=$(usev ncurses)
+
+ tc-export CC AR RANLIB
+ emake ${MAKE_ARGS}
+}
+
+# set_config <file> <option name> <yes value> <no value> test
+# a value of "#" will just comment out the option
+set_config() {
+ local file="${ED}/$1" var=$2 val com
+ eval "${@:5}" && val=$3 || val=$4
+ [[ ${val} == "#" ]] && com="#" && val='\2'
+ sed -i -r -e "/^#?${var}=/{s:=([\"'])?([^ ]*)\1?:=\1${val}\1:;s:^#?:${com}:}" "${file}"
+}
+
+set_config_yes_no() {
+ set_config "$1" "$2" YES NO "${@:3}"
+}
+
+src_install() {
+ emake ${MAKE_ARGS} DESTDIR="${D}" install
+
+ # move the shared libs back to /usr so ldscript can install
+ # more of a minimal set of files
+ # disabled for now due to #270646
+ #mv "${ED}"/$(get_libdir)/lib{einfo,rc}* "${ED}"/usr/$(get_libdir)/ || die
+ #gen_usr_ldscript -a einfo rc
+ gen_usr_ldscript libeinfo.so
+ gen_usr_ldscript librc.so
+
+ if ! use kernel_linux; then
+ keepdir /lib/rc/init.d
+ fi
+ keepdir /lib/rc/tmp
+
+ # Backup our default runlevels
+ dodir /usr/share/"${PN}"
+ cp -PR "${ED}"/etc/runlevels "${ED}"/usr/share/${PN} || die
+ rm -rf "${ED}"/etc/runlevels
+
+ # Setup unicode defaults for silly unicode users
+ set_config_yes_no /etc/rc.conf unicode use unicode
+
+ # Cater to the norm
+ set_config_yes_no /etc/conf.d/keymaps windowkeys '(' use x86 '||' use amd64 ')'
+
+ # On HPPA, do not run consolefont by default (bug #222889)
+ if use hppa; then
+ rm -f "${ED}"/usr/share/openrc/runlevels/boot/consolefont
+ fi
+
+ # Support for logfile rotation
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/openrc.logrotate openrc
+
+ # install gentoo pam.d files
+ newpamd "${FILESDIR}"/start-stop-daemon.pam start-stop-daemon
+ newpamd "${FILESDIR}"/start-stop-daemon.pam supervise-daemon
+
+ # install documentation
+ dodoc ChangeLog *.md
+ if use newnet; then
+ dodoc README.newnet
+ fi
+}
+
+add_boot_init() {
+ local initd=$1
+ local runlevel=${2:-boot}
+ # if the initscript is not going to be installed and is not
+ # currently installed, return
+ [[ -e "${ED}"/etc/init.d/${initd} || -e "${EROOT}"etc/init.d/${initd} ]] \
+ || return
+ [[ -e "${EROOT}"etc/runlevels/${runlevel}/${initd} ]] && return
+
+ # if runlevels dont exist just yet, then create it but still flag
+ # to pkg_postinst that it needs real setup #277323
+ if [[ ! -d "${EROOT}"etc/runlevels/${runlevel} ]] ; then
+ mkdir -p "${EROOT}"etc/runlevels/${runlevel}
+ touch "${EROOT}"etc/runlevels/.add_boot_init.created
+ fi
+
+ elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
+ ln -snf /etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
+}
+add_boot_init_mit_config() {
+ local config=$1 initd=$2
+ if [[ -e ${EROOT}${config} ]] ; then
+ if [[ -n $(sed -e 's:#.*::' -e '/^[[:space:]]*$/d' "${EROOT}"${config}) ]] ; then
+ add_boot_init ${initd}
+ fi
+ fi
+}
+
+pkg_preinst() {
+ local f LIBDIR=$(get_libdir)
+
+ # avoid default thrashing in conf.d files when possible #295406
+ if [[ -e "${EROOT}"etc/conf.d/hostname ]] ; then
+ (
+ unset hostname HOSTNAME
+ source "${EROOT}"etc/conf.d/hostname
+ : ${hostname:=${HOSTNAME}}
+ [[ -n ${hostname} ]] && set_config /etc/conf.d/hostname hostname "${hostname}"
+ )
+ fi
+
+ # set default interactive shell to sulogin if it exists
+ set_config /etc/rc.conf rc_shell /sbin/sulogin "#" test -e /sbin/sulogin
+
+ # termencoding was added in 0.2.1 and needed in boot
+ has_version ">=sys-apps/openrc-0.2.1" || add_boot_init termencoding
+
+ # swapfiles was added in 0.9.9 and needed in boot (february 2012)
+ has_version ">=sys-apps/openrc-0.9.9" || add_boot_init swapfiles
+
+ if ! has_version ">=sys-apps/openrc-0.11"; then
+ add_boot_init sysfs sysinit
+ fi
+
+ if ! has_version ">=sys-apps/openrc-0.11.3" ; then
+ migrate_udev_mount_script
+ fi
+
+ # these were added in 0.12.
+ if ! has_version ">=sys-apps/openrc-0.12"; then
+ add_boot_init loopback
+
+ # ensure existing /etc/conf.d/net is not removed
+ # undoes the hack to get around CONFIG_PROTECT in openrc-0.11.8 and earlier
+ # this needs to stay in openrc ebuilds for a long time. :(
+ # Added in 0.12.
+ if [[ -f "${EROOT}"etc/conf.d/net ]]; then
+ einfo "Modifying conf.d/net to keep it from being removed"
+ cat <<-EOF >>"${EROOT}"etc/conf.d/net
+
+# The network scripts are now part of net-misc/netifrc
+# In order to avoid sys-apps/${P} from removing this file, this comment was
+# added; you can safely remove this comment. Please see
+# /usr/share/doc/netifrc*/README* for more information.
+EOF
+ fi
+ fi
+ has_version ">=sys-apps/openrc-0.14" || add_boot_init binfmt
+
+ if ! has_version ">=sys-apps/openrc-0.18.3"; then
+ add_boot_init mtab
+ if [[ -f "${EROOT}"etc/mtab ]] && [[ ! -L "${EROOT}"etc/mtab ]]; then
+ ewarn "${EROOT}etc/mtab will be replaced with a"
+ ewarn "symbolic link to /proc/self/mounts on the next"
+ ewarn "reboot."
+ ewarn "Change the setting in ${EROOT}etc/conf.d/mtab"
+ ewarn "if you do not want this to happen."
+ fi
+ fi
+
+ has_version ">=sys-apps/openrc-0.35" || add_boot_init cgroups sysinit
+
+}
+
+# >=OpenRC-0.11.3 requires udev-mount to be in the sysinit runlevel with udev.
+migrate_udev_mount_script() {
+ if [ -e "${EROOT}"etc/runlevels/sysinit/udev -a \
+ ! -e "${EROOT}"etc/runlevels/sysinit/udev-mount ]; then
+ add_boot_init udev-mount sysinit
+ fi
+ return 0
+}
+
+pkg_postinst() {
+ local LIBDIR=$(get_libdir)
+
+ # Make our runlevels if they don't exist
+ if [[ ! -e "${EROOT}"etc/runlevels ]] || [[ -e "${EROOT}"etc/runlevels/.add_boot_init.created ]] ; then
+ einfo "Copying across default runlevels"
+ cp -RPp "${EROOT}"usr/share/${PN}/runlevels "${EROOT}"etc
+ rm -f "${EROOT}"etc/runlevels/.add_boot_init.created
+ else
+ if [[ ! -e "${EROOT}"etc/runlevels/sysinit/devfs ]] ; then
+ mkdir -p "${EROOT}"etc/runlevels/sysinit
+ cp -RPp "${EROOT}"usr/share/${PN}/runlevels/sysinit/* \
+ "${EROOT}"etc/runlevels/sysinit
+ fi
+ if [[ ! -e "${EROOT}"etc/runlevels/shutdown/mount-ro ]] ; then
+ mkdir -p "${EROOT}"etc/runlevels/shutdown
+ cp -RPp "${EROOT}"usr/share/${PN}/runlevels/shutdown/* \
+ "${EROOT}"etc/runlevels/shutdown
+ fi
+ if [[ ! -e "${EROOT}"etc/runlevels/nonetwork/local ]]; then
+ cp -RPp "${EROOT}"usr/share/${PN}/runlevels/nonetwork \
+ "${EROOT}"etc/runlevels
+ fi
+ fi
+
+ if use hppa; then
+ elog "Setting the console font does not work on all HPPA consoles."
+ elog "You can still enable it by running:"
+ elog "# rc-update add consolefont boot"
+ fi
+
+ # Added for 0.35.
+ if use kernel_linux && [[ ! -h "${EROOT}"/lib ]]; then
+ if [[ -d "${EROOT}$(get_libdir)"/rc ]]; then
+ cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"lib
+ fi
+ elif ! use kernel_linux; then
+ if [[ -d "${EROOT}$(get_libdir)"/rc ]]; then
+ cp -RPp "${EROOT}$(get_libdir)/rc" "${EROOT}"lib
+ fi
+ fi
+
+ # update the dependency tree after touching all files #224171
+ [[ "${EROOT}" = "/" ]] && "${EROOT}"/lib/rc/bin/rc-depend -u
+
+ if ! use newnet && ! use netifrc; then
+ ewarn "You have emerged OpenRc without network support. This"
+ ewarn "means you need to SET UP a network manager such as"
+ ewarn " net-misc/netifrc, net-misc/dhcpcd, net-misc/wicd,"
+ ewarn "net-misc/NetworkManager, or net-vpn/badvpn."
+ ewarn "Or, you have the option of emerging openrc with the newnet"
+ ewarn "use flag and configuring /etc/conf.d/network and"
+ ewarn "/etc/conf.d/staticroute if you only use static interfaces."
+ ewarn
+ fi
+
+ if use newnet && [ ! -e "${EROOT}"etc/runlevels/boot/network ]; then
+ ewarn "Please add the network service to your boot runlevel"
+ ewarn "as soon as possible. Not doing so could leave you with a system"
+ ewarn "without networking."
+ ewarn
+ fi
+}