summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-19 09:28:10 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-19 09:28:10 +0100
commit67f1097ee091c53b1fc231a6ea813a5d3d80f287 (patch)
tree3726575851ca1812a7f6852a79311fcb063d3791
parentdev-ruby/acts_as_list: add 0.9.4 (diff)
downloadgentoo-67f1097ee091c53b1fc231a6ea813a5d3d80f287.tar.gz
gentoo-67f1097ee091c53b1fc231a6ea813a5d3d80f287.tar.bz2
gentoo-67f1097ee091c53b1fc231a6ea813a5d3d80f287.zip
games-mud/tf: Minor cosmetic fixes
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--games-mud/tf/tf-50_beta8-r2.ebuild42
1 files changed, 20 insertions, 22 deletions
diff --git a/games-mud/tf/tf-50_beta8-r2.ebuild b/games-mud/tf/tf-50_beta8-r2.ebuild
index 8da3b352e936..76d93c5d3180 100644
--- a/games-mud/tf/tf-50_beta8-r2.ebuild
+++ b/games-mud/tf/tf-50_beta8-r2.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_P="${P/_beta/b}"
+
DESCRIPTION="A small, flexible, screen-oriented MUD client (aka TinyFugue)"
HOMEPAGE="http://tinyfugue.sourceforge.net/"
-SRC_URI="mirror://sourceforge/tinyfugue/${MY_P}.tar.gz
- http://homepage.mac.com/mikeride/abelinc/scripts/allrootpatch.txt ->
- tf-allrootpatch.txt
- http://homepage.mac.com/mikeride/abelinc/scripts/allsrcpatch.txt ->
- tf-allsrcpatch.txt
+SRC_URI="
+ mirror://sourceforge/tinyfugue/${MY_P}.tar.gz
+ http://homepage.mac.com/mikeride/abelinc/scripts/allrootpatch.txt -> tf-allrootpatch.txt
+ http://homepage.mac.com/mikeride/abelinc/scripts/allsrcpatch.txt -> tf-allsrcpatch.txt
doc? ( mirror://sourceforge/tinyfugue/${MY_P}-help.tar.gz )"
LICENSE="GPL-2"
@@ -18,17 +18,18 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="+atcp debug doc +gmcp ipv6 +option102 ssl"
-RDEPEND="ssl? ( dev-libs/openssl:0= )
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
dev-libs/libpcre"
DEPEND=${RDEPEND}
S=${WORKDIR}/${MY_P}
PATCHES=(
- "${DISTDIR}"/tf-allrootpatch.txt
- "${DISTDIR}"/tf-allsrcpatch.txt
- "${FILESDIR}"/${P}-pcre.patch
- "${FILESDIR}"/${P}-stdarg.patch
+ "${DISTDIR}"/tf-allrootpatch.txt
+ "${DISTDIR}"/tf-allsrcpatch.txt
+ "${FILESDIR}"/${P}-pcre.patch
+ "${FILESDIR}"/${P}-stdarg.patch
)
src_configure() {
@@ -45,28 +46,25 @@ src_configure() {
src_install() {
dobin src/tf
newman src/tf.1.nroffman tf.1
- dodoc CHANGES CREDITS README
+
+ use doc && HTML_DOCS=( ../${MY_P}-help/{*.html,commands,topics} )
+ einstalldocs
insinto /usr/share/${PN}-lib
# the application looks for this file here if /changes is called.
# see comments on bug #23274
doins CHANGES
insopts -m0755
- doins tf-lib/*
- if use doc ; then
- cd ../${MY_P}-help || die
- dodoc -r *.html commands topics
- cd ../${MY_P} || die
- fi
+ doins -r tf-lib/.
}
pkg_postinst() {
- use ipv6 && {
- echo
+ if use ipv6; then
+ ewarn
ewarn "You have merged TinyFugue with IPv6-support."
ewarn "Support for IPv6 is still being experimental."
ewarn "If you experience problems with connecting to hosts,"
ewarn "try re-merging this package with USE="-ipv6""
- echo
- }
+ ewarn
+ fi
}