summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-12 11:56:13 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-12 16:25:32 +0100
commit6bdc25f1471b7b49c739b70176289a91be9dbf1f (patch)
treeddc4ffb6104798e2d0b993e30611cc51f9e8c762
parentsys-libs/libcxxabi: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo (diff)
downloadgentoo-6bdc25f1471b7b49c739b70176289a91be9dbf1f.tar.gz
gentoo-6bdc25f1471b7b49c739b70176289a91be9dbf1f.tar.bz2
gentoo-6bdc25f1471b7b49c739b70176289a91be9dbf1f.zip
sys-libs/libcxx: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 4470d669a1e9..a5f89acfb5aa 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -7,6 +7,8 @@ EAPI=6
# Ninja provides better scalability and cleaner verbose output, and is used
# throughout all LLVM projects.
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
EGIT_REPO_URI="http://llvm.org/git/libcxx.git
https://github.com/llvm-mirror/libcxx.git"
PYTHON_COMPAT=( python2_7 )
@@ -57,6 +59,9 @@ PATCHES=(
"${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
)
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}