summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-27 11:39:13 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-27 11:42:49 -0800
commit6c9d62bea0d70628eb05603d6a96264657520c79 (patch)
tree1f211553ad8dda34fe01d86dd763880392604709
parentdev-python/mako: 1.1.0 + py48 + pytest 4 (diff)
downloadgentoo-6c9d62bea0d70628eb05603d6a96264657520c79.tar.gz
gentoo-6c9d62bea0d70628eb05603d6a96264657520c79.tar.bz2
gentoo-6c9d62bea0d70628eb05603d6a96264657520c79.zip
app-shells/mcfly: bump to 0.3.6
fix ebuild QA issues and add licenses Bug: https://bugs.gentoo.org/694418 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-shells/mcfly/Manifest1
-rw-r--r--app-shells/mcfly/mcfly-0.3.6.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/app-shells/mcfly/Manifest b/app-shells/mcfly/Manifest
index 4ef7d051fd7a..e9fd459d301f 100644
--- a/app-shells/mcfly/Manifest
+++ b/app-shells/mcfly/Manifest
@@ -23,6 +23,7 @@ DIST libsqlite3-sys-0.10.0.crate 2175426 BLAKE2B dc7cbbcb632e2de1e8fcd6372cb0a82
DIST linked-hash-map-0.4.2.crate 15980 BLAKE2B f31e0dc6f6bb3af355981491e42ce70ac91cbcf059c3d7da8ad2160c40c379bf6d10aab1fdc8400df4497e30ae8dc8c37149ec23084b589fb9a17b8dcf7fbdb4 SHA512 e9ca0dcf09338b8bf2e669eae241b1d07a08c430b2c1fb8adde9a79218aac8f0ad3a13d515202fbf7d0d6f3607e64c4fb3b8b9fe9190655897ae7aeeeb91dbce
DIST lru-cache-0.1.1.crate 8645 BLAKE2B 027f7051ce930701b97017638f2091efef0b3be330fe1cf534d31c7040c8eb55d73d8e397644584d642e370ed2c109f6df61a6da020f6df5f5756cfccbdf9216 SHA512 f397be62edf59bcb36767e338427684274c3ec900d96f92c75859c61ae52f78c42a551bb298e256b76f65bc7b5765c453a07baa61dcb01bfb93ca8a41612b521
DIST mcfly-0.3.4.tar.gz 193516 BLAKE2B e30e438460788ab385924e729d1bd1a00eb6642eaa2f09d378ad20431218dee56153ac8a22c310b733202ac1929dc4e8c800ad480c66cfe3a21f96a79cff43b6 SHA512 49a69c6b4af6814333860262ced4d0d83703d397f5c2f46f9d4351eec9def91c0eff39069982ae67c8fbd5371d562e9e6afbb778472d83dee13aace62f456bf2
+DIST mcfly-0.3.6.tar.gz 194334 BLAKE2B b461acc03a30d063f4b2b0c90fe37414823b708d07d4298ed8f1a6042831d5e6b50137a17fe58efc1eb379e35496a2b9eca443b4de75b39442bd3413054d0d46 SHA512 0f76c38604f95056fc611bd9599ce7812c2286d85239fa0cf8447718f33ef8020c307c1ff0e7e9cdf7aa0e554916ecf6695529164762978fa4ac9b4ac70445be
DIST memchr-2.0.1.crate 9858 BLAKE2B ccf5530245bdcf1b892b98858d1cfd8cdeec3765422f6d1503bfaf3e48744dabfbc1767212b310d1951f1594ec3d4ca09447ca72782ed272cc396113a7f9fef8 SHA512 50daeb73062c30b244c8fec965ff0c69c29571022a9228dafd1ed397164956e39fbe260b8adce33522b5cedcd7f9135500ac45d6bc0b5e72bf9e89ebea0954d1
DIST nodrop-0.1.12.crate 3033 BLAKE2B 69792f5ac9722dc570749795b6e0e6c6373c44614bf5861846af08d426d18e5929ad3c5b957adf3480e8c77444cec9d33b3e8b272eea9c7200f0cedf0d78e7ac SHA512 8f2856a6467715565ea5b3be181fc957f6cbc885797c15582ef5be5a71089201292ea58f94877496737dfd427b19523228fa4bde49d9413a8399d2e7888b99aa
DIST pkg-config-0.3.11.crate 13227 BLAKE2B f22a748d9330848379d9bcc32026c9ba4bcffc043495b864af95dde36ce3fe71344bf5b0534aa61574f677b9a3d1ec0e09f774dea0ee57c1810f1e6bd7edc1e4 SHA512 c5e53a9dd777bce55889fdf7028418443896890ff120beb2fda5e5fcc55624aaefc2ac058c2b4bc88519d48bacc477351b0ab1c4d4a65b4e4bf66a69a419aae6
diff --git a/app-shells/mcfly/mcfly-0.3.6.ebuild b/app-shells/mcfly/mcfly-0.3.6.ebuild
new file mode 100644
index 000000000000..f0929706903c
--- /dev/null
+++ b/app-shells/mcfly/mcfly-0.3.6.ebuild
@@ -0,0 +1,96 @@
+# Copyright 2017-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CRATES="
+ansi_term-0.11.0
+argon2rs-0.2.5
+arrayvec-0.4.7
+atty-0.2.10
+backtrace-0.3.9
+backtrace-sys-0.1.24
+bitflags-1.0.3
+blake2-rfc-0.2.18
+cc-1.0.18
+cfg-if-0.1.5
+clap-2.32.0
+cloudabi-0.0.3
+constant_time_eq-0.1.3
+csv-1.0.1
+csv-core-0.1.4
+dirs-1.0.4
+failure-0.1.2
+failure_derive-0.1.2
+fuchsia-zircon-0.3.3
+fuchsia-zircon-sys-0.3.3
+libc-0.2.42
+libsqlite3-sys-0.10.0
+linked-hash-map-0.4.2
+lru-cache-0.1.1
+memchr-2.0.1
+nodrop-0.1.12
+pkg-config-0.3.11
+proc-macro2-0.4.20
+quote-0.6.8
+rand-0.4.3
+rand-0.5.5
+rand_core-0.2.1
+redox_syscall-0.1.40
+redox_termios-0.1.1
+redox_users-0.2.0
+relative-path-0.4.0
+rusqlite-0.15.0
+rustc-demangle-0.1.9
+scoped_threadpool-0.1.9
+serde-1.0.75
+shellexpand-1.0.0
+strsim-0.7.0
+syn-0.14.9
+synstructure-0.9.0
+termion-1.5.1
+textwrap-0.10.0
+time-0.1.40
+unicode-segmentation-1.2.1
+unicode-width-0.1.5
+unicode-xid-0.1.0
+vcpkg-0.2.4
+vec_map-0.8.1
+winapi-0.3.5
+winapi-i686-pc-windows-gnu-0.4.0
+winapi-x86_64-pc-windows-gnu-0.4.0
+"
+
+inherit cargo
+
+DESCRIPTION="Context-aware bash history search replacement (crtl-r)"
+HOMEPAGE="https://github.com/cantino/mcfly"
+SRC_URI="https://github.com/cantino/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris ${CRATES})"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+DEPEND="dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED="/usr/bin/mcfly"
+
+src_install() {
+ cargo_src_install
+
+ insinto "/usr/share/${PN}"
+ doins "${PN}.bash"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ local p="/usr/share/${PN}/${PN}.bash"
+
+ elog "To start using ${PN}"
+ elog "Add the following to your ~/.bashrc"
+ elog
+ elog "[[ -f ${p} ]] && source ${p}"
+}