summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-04 13:59:58 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-04 14:00:30 +0100
commit6da887f1b2eaadc441e75eb2c19182ff4a64b717 (patch)
tree598bf0906530a989cca6739f135af8b3c8ca5ef1
parentnet-libs/nodejs: EAPI=6. (diff)
downloadgentoo-6da887f1b2eaadc441e75eb2c19182ff4a64b717.tar.gz
gentoo-6da887f1b2eaadc441e75eb2c19182ff4a64b717.tar.bz2
gentoo-6da887f1b2eaadc441e75eb2c19182ff4a64b717.zip
sys-devel/bc: Added missing virtual/yacc dependency.
Closes: https://bugs.gentoo.org/593924 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sys-devel/bc/bc-1.06.95-r2.ebuild15
-rw-r--r--sys-devel/bc/bc-1.07.1-r1.ebuild34
2 files changed, 28 insertions, 21 deletions
diff --git a/sys-devel/bc/bc-1.06.95-r2.ebuild b/sys-devel/bc/bc-1.06.95-r2.ebuild
index 6730e90a8280..e74a6b74e03b 100644
--- a/sys-devel/bc/bc-1.06.95-r2.ebuild
+++ b/sys-devel/bc/bc-1.06.95-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -15,13 +15,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="libedit readline static"
-RDEPEND="!readline? ( libedit? ( dev-libs/libedit:= ) )
+RDEPEND="
+ !readline? ( libedit? ( dev-libs/libedit:= ) )
readline? (
>=sys-libs/readline-4.1:0=
>=sys-libs/ncurses-5.2:=
- )"
-DEPEND="${RDEPEND}
- sys-devel/flex"
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+"
src_prepare() {
epatch "${FILESDIR}"/${P}-void_uninitialized.patch #349339
diff --git a/sys-devel/bc/bc-1.07.1-r1.ebuild b/sys-devel/bc/bc-1.07.1-r1.ebuild
index fcd02f0f33eb..7efced6d3eb0 100644
--- a/sys-devel/bc/bc-1.07.1-r1.ebuild
+++ b/sys-devel/bc/bc-1.07.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit flag-o-matic toolchain-funcs
@@ -14,30 +14,32 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="libedit readline static"
-RDEPEND="!readline? ( libedit? ( dev-libs/libedit:= ) )
+RDEPEND="
+ !readline? ( libedit? ( dev-libs/libedit:= ) )
readline? (
>=sys-libs/readline-4.1:0=
>=sys-libs/ncurses-5.2:=
- )"
-DEPEND="${RDEPEND}
+ )
+"
+DEPEND="
+ ${RDEPEND}
sys-apps/ed
- sys-devel/flex"
+ sys-devel/flex
+ virtual/yacc
+"
src_configure() {
- local libedit
+ local myconf=(
+ $(use_with readline)
+ )
if use readline ; then
- libedit="--without-libedit"
+ myconf+=( --without-libedit )
else
- libedit=$(use_with libedit)
+ myconf+=( $(use_with libedit) )
fi
use static && append-ldflags -static
- # Clobber any CONFIG_SHELL setting the user has forced on us.
- # We should be able to delete this w/the next release as it
- # should use updated autoconf.
- CONFIG_SHELL=/bin/bash \
- econf \
- $(use_with readline) \
- ${libedit}
+
+ econf "${myconf[@]}"
# Do not regen docs -- configure produces a small fragment that includes
# the version info which causes all pages to regen (newer file). #554774