summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-02 23:14:51 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-02 23:19:18 +0200
commit70085e39cdb961b4af4e415e36f897b81c4e618f (patch)
treebd5e6b7345542121aa3d70c76039483ea025197a
parentdev-util/xdelta: Remove unnecessary USE=test (diff)
downloadgentoo-70085e39cdb961b4af4e415e36f897b81c4e618f.tar.gz
gentoo-70085e39cdb961b4af4e415e36f897b81c4e618f.tar.bz2
gentoo-70085e39cdb961b4af4e415e36f897b81c4e618f.zip
net-misc/aria2: Drop old
-rw-r--r--net-misc/aria2/Manifest3
-rw-r--r--net-misc/aria2/aria2-1.19.0.ebuild148
-rw-r--r--net-misc/aria2/aria2-1.19.2.ebuild149
-rw-r--r--net-misc/aria2/aria2-1.21.0.ebuild149
4 files changed, 0 insertions, 449 deletions
diff --git a/net-misc/aria2/Manifest b/net-misc/aria2/Manifest
index caa4a650f4e..18e16be5621 100644
--- a/net-misc/aria2/Manifest
+++ b/net-misc/aria2/Manifest
@@ -1,6 +1,3 @@
DIST aria2-1.15.2.tar.bz2 2043212 SHA256 6400431f4248f7a779ae8216ec2711b56ad7481fc659f06db1f22ed97b260836 SHA512 6fc09ba1f682d13db829a3f5881a06ea0d0d2c1622511408f149cc109a12a01b19cec34caeeac10982061e9633bbb67e9ec40c23ee39a418fec6fb604af23bbe WHIRLPOOL b9544bb5359fc22dca5ba4e5328086deb0cf7d40fc69e7528ed57f14a89b30ffa6022ab7bfbe5f2fbd150b3974272286ff2f26d011bccaf5f973ccca00f2a44e
-DIST aria2-1.19.0.tar.bz2 2155310 SHA256 ae2b6fce7a0974c9156415cccf2395cd258580ab34eec2b34a8e76120b7240ce SHA512 ba505b45f84266543cb403752cc3592469545dea806e77bd7b7fec1fbe7ed5baf14372cf6dea840ccbdd054cd0c92cdeb4516eb52b167aca03909000f02aec95 WHIRLPOOL b13502f9dd646832799af6a0db199e87abae042c0e48b778f9b782d56d838c5b9d36bc04c487534f3fe1c59e970dc34702facc5508927325e34bcffa39946519
-DIST aria2-1.19.2.tar.xz 1377356 SHA256 3605486dd495cd8c2f672b7d0b763397989d831396862f15730697ebcf0ad53e SHA512 ae3fb231fa9f989a8c4f8015d7e64db2b62b922548839a884454ef1fc6dc024363b482268200efa234ac71a1dba969aaefbeb81c811223e2e117f3adae9a8468 WHIRLPOOL 10f4ad709e26f29685b05e5db4fde687c733404a994649d4f5c5a8f66bf60142ae3bc65179db7b83766e32663100b5c7c58f1b6e4a6f6a4d2f089176604a8c95
-DIST aria2-1.21.0.tar.xz 1438608 SHA256 225c5f2c8acc899e0a802cdf198f82bd0d3282218e80cdce251b1f9ffacf6580 SHA512 2862d82f064de160b64705ee5ae9180e7402859c7c0d9bc5421b1368cebd143e0a0e2e971713cd27f11efbeffe6618e801309ff34b12aeb00060b9de58652251 WHIRLPOOL 07030ec26b002c98f8a76984bec1594b76dba404c40dbda8d4d80d682ee41ac7667c45c9fb723fa335906ebf0f462f4d2bd924ce64422a26d23d7da4ae5b62d9
DIST aria2-1.23.0.tar.xz 1493704 SHA256 585185866415bf1120e4bf0a484e7dfec2e9e7c5305023b15ad0f66f90391f93 SHA512 c64877f5d2a2fd9c45b0a592af508dab25c4f4610fb56243db77f660a004c48e567f0c6be707c8f44b8f6b1a3e7f90e0d1be77b421e56957b5a24b1252ffc5fd WHIRLPOOL 5a6ab2a6b002b3279a9a96071f878029928d19c29f4442fa1c1fb26099976443bb8d260105fdafe59020749e1f9f481a81ca7c80af96fb0d49f3de4d0b3e14f1
DIST aria2-1.24.0.tar.xz 1495632 SHA256 35a496d2704ffb07e0b0dcac16c6d9b2854327967f984218517403d187f7bf37 SHA512 3e7f3fc2cd30edb5813b0d0fe6742671000730aa8d7e41e5396ab673912b8492885273de740985517b4a16efccedb1bdffb9bfdc235aa0d5fc31d2b547ae61e7 WHIRLPOOL 31a22233c5aacfaf8ee93da4bc13af0138ab6bc6eec6a458cb846834d61ddf2f1082a69a1eb24ee8feaad65d426a8fd4c235ffd886dbee44fb8749ecf79c3f0e
diff --git a/net-misc/aria2/aria2-1.19.0.ebuild b/net-misc/aria2/aria2-1.19.0.ebuild
deleted file mode 100644
index 367eb2bfcfd..00000000000
--- a/net-misc/aria2/aria2-1.19.0.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit bash-completion-r1 eutils
-
-DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
-HOMEPAGE="http://aria2.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="adns bittorrent +gnutls jemalloc libuv +libxml2 metalink +nettle nls sqlite scripts ssh ssl tcmalloc test xmlrpc"
-
-CDEPEND="sys-libs/zlib:0=
- ssl? (
- app-misc/ca-certificates
- gnutls? ( >=net-libs/gnutls-1.2.9:0= )
- !gnutls? ( dev-libs/openssl:0= ) )
- adns? ( >=net-dns/c-ares-1.5.0:0= )
- bittorrent? (
- ssl? (
- gnutls? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- !ssl? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- jemalloc? ( dev-libs/jemalloc )
- libuv? ( dev-libs/libuv:0= )
- metalink? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )
- sqlite? ( dev-db/sqlite:3= )
- ssh? ( net-libs/libssh2:= )
- tcmalloc? ( dev-util/google-perftools )
- xmlrpc? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )"
-
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.12.0:0 )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libiconv virtual/libintl )
- scripts? ( dev-lang/ruby )"
-
-REQUIRED_USE="jemalloc? ( !tcmalloc )
- tcmalloc? ( !jemalloc )"
-
-pkg_setup() {
- if use scripts && use !xmlrpc && use !metalink; then
- ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
- ewarn "and aria2mon scripts against the local aria2."
- fi
-}
-
-src_prepare() {
- epatch_user
- sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
-}
-
-src_configure() {
- local myconf=(
- # threads, epoll: check for best portability
-
- # do not try to compile and run a test LIBXML program
- --disable-xmltest
- # enable the shared library
- --enable-libaria2
- # zlib should always be available anyway
- --with-libz
- --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
-
- # optional features
- $(use_enable bittorrent)
- $(use_enable metalink)
- $(use_enable nls)
- $(use_with sqlite sqlite3)
- $(use_with adns libcares)
- $(use_with libuv)
- $(use_with jemalloc)
- $(use_with tcmalloc)
- )
-
- # SSL := gnutls / openssl
- # USE=ssl
- # + USE=gnutls -> gnutls
- # + USE=-gnutls -> openssl
-
- if use ssl; then
- myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
- else
- myconf+=( --without-gnutls --without-openssl )
- fi
-
- # message-digest := nettle / gcrypt / openssl
- # bignum := nettle+gmp / gcrypt / openssl
- # bittorrent := message-digest + bignum
- # USE=bittorrent
- # + USE=(ssl -gnutls) -> openssl
- # + USE=nettle -> nettle+gmp
- # + USE=-nettle -> gcrypt
-
- if use !bittorrent || use ssl && use !gnutls; then
- myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
- else
- myconf+=( $(use_with !nettle libgcrypt)
- $(use_with nettle libnettle) $(use_with nettle libgmp) )
- fi
-
- # metalink+xmlrpc := libxml2 / expat
- # USE=(metalink || xmlrpc)
- # + USE=libxml2 -> libxml2
- # + USE=-libxml2 -> expat
-
- if use metalink || use xmlrpc; then
- myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
- else
- myconf+=( --without-libexpat --without-libxml2 )
- fi
-
- # Note:
- # - always enable gzip/http compression since zlib should always be available anyway
- # - always enable epoll since we can assume kernel 2.6.x
- # - other options for threads: solaris, pth, win32
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- rm -rf "${D}"/usr/share/doc/aria2 \
- "${D}"/usr/share/doc/${PF}/README{,.html}
-
- dobashcomp doc/bash_completion/aria2c
- use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
-}
-
-pkg_postinst() {
- if use xmlrpc || use metalink; then
- elog "If you would like to use the additional aria2mon and aria2rpc tools,"
- elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
- fi
-}
diff --git a/net-misc/aria2/aria2-1.19.2.ebuild b/net-misc/aria2/aria2-1.19.2.ebuild
deleted file mode 100644
index 512ee767a54..00000000000
--- a/net-misc/aria2/aria2-1.19.2.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit bash-completion-r1 eutils
-
-DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
-HOMEPAGE="http://aria2.sourceforge.net/"
-SRC_URI="https://github.com/tatsuhiro-t/${PN}/releases/download/release-${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="adns bittorrent +gnutls jemalloc libuv +libxml2 metalink +nettle nls sqlite scripts ssh ssl tcmalloc test xmlrpc"
-
-CDEPEND="sys-libs/zlib:0=
- ssl? (
- app-misc/ca-certificates
- gnutls? ( >=net-libs/gnutls-1.2.9:0= )
- !gnutls? ( dev-libs/openssl:0= ) )
- adns? ( >=net-dns/c-ares-1.5.0:0= )
- bittorrent? (
- ssl? (
- gnutls? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- !ssl? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- jemalloc? ( dev-libs/jemalloc )
- libuv? ( dev-libs/libuv:0= )
- metalink? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )
- sqlite? ( dev-db/sqlite:3= )
- ssh? ( net-libs/libssh2:= )
- tcmalloc? ( dev-util/google-perftools )
- xmlrpc? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.12.0:0 )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libiconv virtual/libintl )
- scripts? ( dev-lang/ruby )"
-
-REQUIRED_USE="jemalloc? ( !tcmalloc )
- tcmalloc? ( !jemalloc )"
-
-pkg_setup() {
- if use scripts && use !xmlrpc && use !metalink; then
- ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
- ewarn "and aria2mon scripts against the local aria2."
- fi
-}
-
-src_prepare() {
- epatch_user
- sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
-}
-
-src_configure() {
- local myconf=(
- # threads, epoll: check for best portability
-
- # do not try to compile and run a test LIBXML program
- --disable-xmltest
- # enable the shared library
- --enable-libaria2
- # zlib should always be available anyway
- --with-libz
- --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
-
- # optional features
- $(use_enable bittorrent)
- $(use_enable metalink)
- $(use_enable nls)
- $(use_with sqlite sqlite3)
- $(use_with adns libcares)
- $(use_with libuv)
- $(use_with jemalloc)
- $(use_with tcmalloc)
- )
-
- # SSL := gnutls / openssl
- # USE=ssl
- # + USE=gnutls -> gnutls
- # + USE=-gnutls -> openssl
-
- if use ssl; then
- myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
- else
- myconf+=( --without-gnutls --without-openssl )
- fi
-
- # message-digest := nettle / gcrypt / openssl
- # bignum := nettle+gmp / gcrypt / openssl
- # bittorrent := message-digest + bignum
- # USE=bittorrent
- # + USE=(ssl -gnutls) -> openssl
- # + USE=nettle -> nettle+gmp
- # + USE=-nettle -> gcrypt
-
- if use !bittorrent || use ssl && use !gnutls; then
- myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
- else
- myconf+=( $(use_with !nettle libgcrypt)
- $(use_with nettle libnettle) $(use_with nettle libgmp) )
- fi
-
- # metalink+xmlrpc := libxml2 / expat
- # USE=(metalink || xmlrpc)
- # + USE=libxml2 -> libxml2
- # + USE=-libxml2 -> expat
-
- if use metalink || use xmlrpc; then
- myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
- else
- myconf+=( --without-libexpat --without-libxml2 )
- fi
-
- # Note:
- # - always enable gzip/http compression since zlib should always be available anyway
- # - always enable epoll since we can assume kernel 2.6.x
- # - other options for threads: solaris, pth, win32
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- rm -rf "${D}"/usr/share/doc/aria2 \
- "${D}"/usr/share/doc/${PF}/README{,.html}
-
- dobashcomp doc/bash_completion/aria2c
- use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
-}
-
-pkg_postinst() {
- if use xmlrpc || use metalink; then
- elog "If you would like to use the additional aria2mon and aria2rpc tools,"
- elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
- fi
-}
diff --git a/net-misc/aria2/aria2-1.21.0.ebuild b/net-misc/aria2/aria2-1.21.0.ebuild
deleted file mode 100644
index 40ee99f0865..00000000000
--- a/net-misc/aria2/aria2-1.21.0.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit bash-completion-r1 eutils
-
-DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
-HOMEPAGE="http://aria2.sourceforge.net/"
-SRC_URI="https://github.com/tatsuhiro-t/${PN}/releases/download/release-${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="adns bittorrent +gnutls jemalloc libuv +libxml2 metalink +nettle nls sqlite scripts ssh ssl tcmalloc test xmlrpc"
-
-CDEPEND="sys-libs/zlib:0=
- ssl? (
- app-misc/ca-certificates
- gnutls? ( >=net-libs/gnutls-1.2.9:0= )
- !gnutls? ( dev-libs/openssl:0= ) )
- adns? ( >=net-dns/c-ares-1.5.0:0= )
- bittorrent? (
- ssl? (
- gnutls? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- !ssl? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- jemalloc? ( dev-libs/jemalloc )
- libuv? ( dev-libs/libuv:0= )
- metalink? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )
- sqlite? ( dev-db/sqlite:3= )
- ssh? ( net-libs/libssh2:= )
- tcmalloc? ( dev-util/google-perftools )
- xmlrpc? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.12.0:0 )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libiconv virtual/libintl )
- scripts? ( dev-lang/ruby )"
-
-REQUIRED_USE="jemalloc? ( !tcmalloc )
- tcmalloc? ( !jemalloc )"
-
-pkg_setup() {
- if use scripts && use !xmlrpc && use !metalink; then
- ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
- ewarn "and aria2mon scripts against the local aria2."
- fi
-}
-
-src_prepare() {
- epatch_user
- sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
-}
-
-src_configure() {
- local myconf=(
- # threads, epoll: check for best portability
-
- # do not try to compile and run a test LIBXML program
- --disable-xmltest
- # enable the shared library
- --enable-libaria2
- # zlib should always be available anyway
- --with-libz
- --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
-
- # optional features
- $(use_enable bittorrent)
- $(use_enable metalink)
- $(use_enable nls)
- $(use_with sqlite sqlite3)
- $(use_with adns libcares)
- $(use_with libuv)
- $(use_with jemalloc)
- $(use_with tcmalloc)
- )
-
- # SSL := gnutls / openssl
- # USE=ssl
- # + USE=gnutls -> gnutls
- # + USE=-gnutls -> openssl
-
- if use ssl; then
- myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
- else
- myconf+=( --without-gnutls --without-openssl )
- fi
-
- # message-digest := nettle / gcrypt / openssl
- # bignum := nettle+gmp / gcrypt / openssl
- # bittorrent := message-digest + bignum
- # USE=bittorrent
- # + USE=(ssl -gnutls) -> openssl
- # + USE=nettle -> nettle+gmp
- # + USE=-nettle -> gcrypt
-
- if use !bittorrent || use ssl && use !gnutls; then
- myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
- else
- myconf+=( $(use_with !nettle libgcrypt)
- $(use_with nettle libnettle) $(use_with nettle libgmp) )
- fi
-
- # metalink+xmlrpc := libxml2 / expat
- # USE=(metalink || xmlrpc)
- # + USE=libxml2 -> libxml2
- # + USE=-libxml2 -> expat
-
- if use metalink || use xmlrpc; then
- myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
- else
- myconf+=( --without-libexpat --without-libxml2 )
- fi
-
- # Note:
- # - always enable gzip/http compression since zlib should always be available anyway
- # - always enable epoll since we can assume kernel 2.6.x
- # - other options for threads: solaris, pth, win32
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- rm -rf "${D}"/usr/share/doc/aria2 \
- "${D}"/usr/share/doc/${PF}/README{,.html}
-
- dobashcomp doc/bash_completion/aria2c
- use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
-}
-
-pkg_postinst() {
- if use xmlrpc || use metalink; then
- elog "If you would like to use the additional aria2mon and aria2rpc tools,"
- elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
- fi
-}