summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-25 22:13:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-25 23:33:55 +0200
commit700c02a5d0d652853417099669381ff59214efa5 (patch)
treec3cf6feb32f8bb901b4ba8134fcba76f30b00042
parentdev-qt/qtsql: Backport mysql dev branch fix (diff)
downloadgentoo-700c02a5d0d652853417099669381ff59214efa5.tar.gz
gentoo-700c02a5d0d652853417099669381ff59214efa5.tar.bz2
gentoo-700c02a5d0d652853417099669381ff59214efa5.zip
dev-qt/qtsql: Drop 5.12.5 (r0)
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtsql/qtsql-5.12.5.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-qt/qtsql/qtsql-5.12.5.ebuild b/dev-qt/qtsql/qtsql-5.12.5.ebuild
deleted file mode 100644
index ba9ab526b7ec..000000000000
--- a/dev-qt/qtsql/qtsql-5.12.5.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="SQL abstraction library for the Qt5 framework"
-SLOT=5/$(ver_cut 1-3) # bug 639140
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
-fi
-
-IUSE="freetds mysql oci8 odbc postgres +sqlite"
-
-REQUIRED_USE="
- || ( freetds mysql oci8 odbc postgres sqlite )
-"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- freetds? ( dev-db/freetds )
- mysql? ( dev-db/mysql-connector-c:= )
- oci8? ( dev-db/oracle-instantclient:=[sdk] )
- odbc? ( dev-db/unixODBC )
- postgres? ( dev-db/postgresql:* )
- sqlite? ( dev-db/sqlite:3 )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/sql
- src/plugins/sqldrivers
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :sql
-)
-
-src_configure() {
- local myconf=(
- $(qt_use freetds sql-tds plugin)
- $(qt_use mysql sql-mysql plugin)
- $(qt_use oci8 sql-oci plugin)
- $(qt_use odbc sql-odbc plugin)
- $(qt_use postgres sql-psql plugin)
- $(qt_use sqlite sql-sqlite plugin)
- $(usex sqlite -system-sqlite '')
- )
-
- use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")
-
- qt5-build_src_configure
-}