summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-25 20:38:35 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-25 20:38:35 +0100
commit71f83be9beeb1ed4c39d0e0ad442a8aba54a2c8c (patch)
treec9223f7f0176533a033ff5123be8f1810f6ccf9b
parentdev-libs/tntnet: reassing package to myself (diff)
downloadgentoo-71f83be9beeb1ed4c39d0e0ad442a8aba54a2c8c.tar.gz
gentoo-71f83be9beeb1ed4c39d0e0ad442a8aba54a2c8c.tar.bz2
gentoo-71f83be9beeb1ed4c39d0e0ad442a8aba54a2c8c.zip
sci-biology/bwa: Fix -fno-common bug
Closes: https://bugs.gentoo.org/706348 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-biology/bwa/bwa-0.7.16a.ebuild10
-rw-r--r--sci-biology/bwa/files/bwa-0.7.16a-gcc-10.patch7
2 files changed, 13 insertions, 4 deletions
diff --git a/sci-biology/bwa/bwa-0.7.16a.ebuild b/sci-biology/bwa/bwa-0.7.16a.ebuild
index 21fe67143bd2..b29bf210169a 100644
--- a/sci-biology/bwa/bwa-0.7.16a.ebuild
+++ b/sci-biology/bwa/bwa-0.7.16a.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -11,12 +11,14 @@ SRC_URI="mirror://sourceforge/bio-bwa/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
-IUSE=""
KEYWORDS="~amd64 ~x86 ~x64-macos"
RDEPEND="dev-lang/perl"
-PATCHES=( "${FILESDIR}"/${PN}-0.7.15-Makefile.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.15-Makefile.patch
+ "${FILESDIR}"/${PN}-0.7.16a-gcc-10.patch
+)
DOCS=( NEWS.md README-alt.md README.md )
src_configure() {
diff --git a/sci-biology/bwa/files/bwa-0.7.16a-gcc-10.patch b/sci-biology/bwa/files/bwa-0.7.16a-gcc-10.patch
new file mode 100644
index 000000000000..40056ffeaaa9
--- /dev/null
+++ b/sci-biology/bwa/files/bwa-0.7.16a-gcc-10.patch
@@ -0,0 +1,7 @@
+--- a/rle.h
++++ b/rle.h
+@@ -32,3 +32,3 @@ extern "C" {
+
+-const uint8_t rle_auxtab[8];
++extern const uint8_t rle_auxtab[8];
+