summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-23 08:41:47 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-23 12:02:30 +0200
commit7418d2479c14e80aa4d4dbd403150fde1362e4b0 (patch)
tree3f1f6079b92ef380c2e6ec0c6aad35d7177d141f
parentx11-misc/copyq: Drop 3.10.0 (diff)
downloadgentoo-7418d2479c14e80aa4d4dbd403150fde1362e4b0.tar.gz
gentoo-7418d2479c14e80aa4d4dbd403150fde1362e4b0.tar.bz2
gentoo-7418d2479c14e80aa4d4dbd403150fde1362e4b0.zip
dev-python/botocore: Bump to 1.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index db47d9439541..0810416ed28a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.18.10.tar.gz 6899351 BLAKE2B 4de11277fd8df8436818cd50d946e7e5319
DIST botocore-1.18.18.tar.gz 6942407 BLAKE2B e58183d5aa79a210d82c1dc21806c9c86f993498055c52742e4c1ef2f697ae1faf120b9edf8efeb229dad3f3230f0847b534ac071a1e4d32136eacc3c18c7c84 SHA512 a92a20c86390905f22c10e3ba649008b7c9ccab147b6b3aecc89f26dc891aaf38a974fd8ba1f792a38ac89a98dba64a949741445abf7db133f60189d1e8da31e
DIST botocore-1.19.1.tar.gz 6944577 BLAKE2B ade1c8c3318971f25220d2c5bf82879d9a1cf30ed49066d4d13bf04351dc2fa7a910fcba6dba248d33bcf3e244c8b99c7df66cc3edc6f65b38b8ff2412a68e34 SHA512 e0fd4e8c4fca53c7e034e840ffd9f362c3a41a898188980a382d528334204d13a9dcd597b4a1eb8ce792ffb31e31213167b8e6e952353c339612755b88c1c635
DIST botocore-1.19.2.tar.gz 6949309 BLAKE2B 0d13155e32bc44578df8b372ccdceddc13d5012696245f441e0b935c0a58c8f78e38c9aabe03e242159cbc45d8034fe1bfaffc545ce5d2d95aa2a765c778e36a SHA512 88486e813e476b789b7c0b9fa74bc95ac2a67818439f2ff2564fe30c988ec0fb9be8a2f9c2ebce9418d1eeda4c88c94d6d3ec37cec185d48a388577fc2458c88
+DIST botocore-1.19.3.tar.gz 6950797 BLAKE2B f8f97e699e9b31cf56d8a35ff75831e9c545abe1980e4e4af3453c83be6ff6efa51fb9368e984fc871bd1123df283940d42c7adced672bdf21d7a13c3bc6f9b1 SHA512 8eaf72543c5a5e2e4a08cc6998c71971ee9e70d476e384b66472ec2f16d204ae70056925bba1e1476fd55a272750e4907a617e38a96e1b4324e172081a9c1b54
diff --git a/dev-python/botocore/botocore-1.19.3.ebuild b/dev-python/botocore/botocore-1.19.3.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}