summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-24 16:32:10 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-24 16:32:26 +1200
commit7483a7fb9f7806c4533d11ad62562f3e37503321 (patch)
treec10ceccb68c8985eee70665804905a7d403ebdbb
parentdev-ruby/i18n: add 1.8.5 (diff)
downloadgentoo-7483a7fb9f7806c4533d11ad62562f3e37503321.tar.gz
gentoo-7483a7fb9f7806c4533d11ad62562f3e37503321.tar.bz2
gentoo-7483a7fb9f7806c4533d11ad62562f3e37503321.zip
dev-perl/Data-Visitor: -r bump for EAPI7
- EAPI7 - Improve dependencies - Parallel tests Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Data-Visitor/Data-Visitor-0.300.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Data-Visitor/Data-Visitor-0.300.0-r2.ebuild b/dev-perl/Data-Visitor/Data-Visitor-0.300.0-r2.ebuild
new file mode 100644
index 000000000000..4a1dc212a1d3
--- /dev/null
+++ b/dev-perl/Data-Visitor/Data-Visitor-0.300.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DOY
+DIST_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="Visitor style traversal of Perl data structures"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Class-Load-0.60.0
+ >=dev-perl/Moose-0.890.0
+ >=dev-perl/Tie-ToObject-0.10.0
+ >=dev-perl/namespace-clean-0.190.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"