summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 11:33:29 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 13:24:44 +0200
commit748deb9b9cb4a973a2821fc98d13d51430efdb9d (patch)
treed6d2de19a36206e5969168a9605c72fdaf36f9e0
parentgnome-extra/cinnamon-screensaver: [QA] Add missing python metadata variables (diff)
downloadgentoo-748deb9b9cb4a973a2821fc98d13d51430efdb9d.tar.gz
gentoo-748deb9b9cb4a973a2821fc98d13d51430efdb9d.tar.bz2
gentoo-748deb9b9cb4a973a2821fc98d13d51430efdb9d.zip
gnome-extra/gnome-commander: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild12
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild10
2 files changed, 19 insertions, 3 deletions
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild
index 2e2b2fa59300..c812765380d9 100644
--- a/gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild
+++ b/gnome-extra/gnome-commander/gnome-commander-1.4.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="chm doc exif gsf pdf python taglib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="app-text/gnome-doc-utils
>=dev-libs/glib-2.6.0:2
@@ -28,7 +29,10 @@ RDEPEND="app-text/gnome-doc-utils
exif? ( >=media-gfx/exiv2-0.14 )
gsf? ( >=gnome-extra/libgsf-1.12.0 )
pdf? ( >=app-text/poppler-0.18 )
- python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/gnome-vfs-python-2.0.0
+ )
taglib? ( >=media-libs/taglib-1.4 )"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.35.0
@@ -37,6 +41,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
G2CONF="$(use_enable doc scrollkeeper)
$(use_enable python)
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild
index 75cd40645707..f5d9510947ec 100644
--- a/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild
+++ b/gnome-extra/gnome-commander/gnome-commander-1.6.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="chm exif gsf pdf python taglib samba test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
app-text/gnome-doc-utils
@@ -30,7 +31,10 @@ RDEPEND="
gsf? ( >=gnome-extra/libgsf-1.12.0 )
samba? ( >=gnome-base/gnome-vfs-2.0.0[samba] )
pdf? ( >=app-text/poppler-0.18 )
- python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/gnome-vfs-python-2.0.0
+ )
taglib? ( >=media-libs/taglib-1.4 )
"
DEPEND="
@@ -42,6 +46,10 @@ DEPEND="
test? ( >=dev-util/cppunit-1.13.2 )
"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
gnome2_src_configure \
--disable-static \