summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-02-04 17:04:41 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-02-04 18:48:23 +0100
commit75dce071c58731e057ca1b105b09da11a2a6d5ca (patch)
tree03e5811431b74b9fc15db51b37f36295a99c75fe
parentnet-im/transwhat: updated metadata.xml description (diff)
downloadgentoo-75dce071c58731e057ca1b105b09da11a2a6d5ca.tar.gz
gentoo-75dce071c58731e057ca1b105b09da11a2a6d5ca.tar.bz2
gentoo-75dce071c58731e057ca1b105b09da11a2a6d5ca.zip
app-misc/fhem: bump to version 6.0
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-misc/fhem/Manifest1
-rw-r--r--app-misc/fhem/fhem-6.0.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-misc/fhem/Manifest b/app-misc/fhem/Manifest
index b200f36cc24c..b946dd43abf5 100644
--- a/app-misc/fhem/Manifest
+++ b/app-misc/fhem/Manifest
@@ -1 +1,2 @@
DIST fhem-5.9.tar.gz 23267499 BLAKE2B c2c2e4ab21f82fbe67c9e99aed4d1edd6db889aedac0611b5ba2873667520c4aa63d8553e014563f6f6ee58c5792ae1735853f58c8f4ef0599583b2ed23a9efe SHA512 9f75058e698fc33ec64081695db3eb2511f686dedc3107c87d4377f655c8b204892c6f61141de28970f2ed3f8cef5d24124d17ee20ee71a9eb9318bb17335bb8
+DIST fhem-6.0.tar.gz 28562819 BLAKE2B 4bc4f232caf0adc35ded72f380c1d4c816a22304af357f9b204fb856c2053038e3db2d834b7448d3cf43e84d3f435a36d047e48606b9e1083ab4963b38a75301 SHA512 a8e9d74b1d68ad7c9aea0a4d463aa877cb607458cb6ecf76203c96ff2156fd8b8a3b9cb5687ac0a5cd1eca5f94552433de55f3696b7be54a3cfa8df9cf74fbe1
diff --git a/app-misc/fhem/fhem-6.0.ebuild b/app-misc/fhem/fhem-6.0.ebuild
new file mode 100644
index 000000000000..55c757a712da
--- /dev/null
+++ b/app-misc/fhem/fhem-6.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="A GPL'd perl server for house automation"
+HOMEPAGE="https://www.fhem.de/"
+SRC_URI="https://www.fhem.de/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ acct-group/fhem
+ acct-user/fhem
+ dev-perl/Crypt-CBC
+ dev-perl/Device-SerialPort
+ dev-perl/Digest-CRC
+ dev-perl/JSON
+"
+
+DEPEND="media-gfx/pngcrush"
+
+src_prepare() {
+ default
+
+ # Allow install path to be set by DESTDIR in Makefile
+ sed -i -e 's,^\(BINDIR=\),\1'\$\(DESTDIR\)',' Makefile || die
+
+ # Remove docs in Makefile, as they will be installed manually
+ sed -i -e 's/docs//g' Makefile || die
+ sed -i -e '/README_DEMO.txt/d' Makefile || die
+
+ # Remove manpage in Makefile, as it will be installed manually
+ sed -i -e '/fhem.pl.1/d' Makefile || die
+
+ # Remove lcd4linux binaries, as they are provied by app-misc/lcd4linux
+ rm -r contrib/lcd4linux || die
+
+ # Remove log dir, as it will be replaced with a symlink
+ rm -r log || die
+
+ # Fix fhemicon_darksmall.png, as it reports "broken IDAT window length"
+ # Reported to Upstream: https://forum.fhem.de/index.php/topic,86238.0.html
+ pngcrush -fix -force -ow www/images/default/fhemicon_darksmall.png || die
+
+ cp "${FILESDIR}"/fhem.cfg fhem.cfg || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local DOCS=(
+ "CHANGED"
+ "HISTORY"
+ "MAINTAINER.txt"
+ "README.SVN"
+ "README_DEMO.txt"
+ "docs"/*.txt
+ "docs"/*.patch
+ "docs"/*.pdf
+ "docs/changelog"
+ "docs/copyright"
+ "docs/dotconfig"
+ "docs/fhem.odg.readme"
+ "docs/LIESMICH.update-thirdparty"
+ "docs"/README*
+ "docs/X10"
+ )
+
+ if use doc; then
+ local DOCS+=( "docs/X10" )
+ local HTML_DOCS=( "docs/"*.eps "docs/"*.html "docs"/*.jpg "docs"/*.js "docs"/*.odg "docs/"*.png "docs/km271" )
+ fi
+
+ diropts -o fhem -g fhem
+ keepdir "/var/lib/fhem"
+ keepdir "/var/log/fhem"
+ diropts
+
+ dosym ../../var/lib/fhem /opt/fhem/data
+ dosym ../../var/log/fhem /opt/fhem/log
+
+ default
+
+ newinitd "${FILESDIR}"/fhem.initd fhem
+
+ systemd_dounit "${FILESDIR}"/fhem.service
+ systemd_newtmpfilesd "${FILESDIR}"/fhem.tmpfiles fhem.conf
+
+ newman docs/fhem.man fhem.pl.1
+
+ echo 'CONFIG_PROTECT="/opt/fhem /var/lib/fhem"' > "${T}"/99fhem || die
+ doenvd "${T}"/99fhem
+
+ fowners fhem:fhem /opt/fhem/fhem.cfg
+}