summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-02 18:23:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-02 19:16:45 +0100
commit76151f32fbd41247e5d01f88207db2a084f6e661 (patch)
treeb0c2064b8aeb0349e954bad7c46e428a5be188b3
parentdev-db/mariadb: fix flow control statement (diff)
downloadgentoo-76151f32fbd41247e5d01f88207db2a084f6e661.tar.gz
gentoo-76151f32fbd41247e5d01f88207db2a084f6e661.tar.bz2
gentoo-76151f32fbd41247e5d01f88207db2a084f6e661.zip
sys-devel/distcc: Disable CHOST rewrites that break i686 cross
Closes: https://bugs.gentoo.org/773652 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/distcc/distcc-3.3.3-r3.ebuild (renamed from sys-devel/distcc/distcc-3.3.3-r2.ebuild)2
-rw-r--r--sys-devel/distcc/files/distcc-3.3.3-no-rewrite-chost.patch28
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-devel/distcc/distcc-3.3.3-r2.ebuild b/sys-devel/distcc/distcc-3.3.3-r3.ebuild
index b5d02e4bf2ca..729f2211d694 100644
--- a/sys-devel/distcc/distcc-3.3.3-r2.ebuild
+++ b/sys-devel/distcc/distcc-3.3.3-r3.ebuild
@@ -46,6 +46,8 @@ src_prepare() {
eapply "${FILESDIR}/${P}-py38.patch"
# gcc-10 fix, #707502
eapply "${FILESDIR}/${P}-gcc-10-fix.patch"
+ # unbreak CHOST prefix, https://bugs.gentoo.org/773652
+ eapply "${FILESDIR}/${P}-no-rewrite-chost.patch"
eapply_user
# Bugs #120001, #167844 and probably more. See patch for description.
diff --git a/sys-devel/distcc/files/distcc-3.3.3-no-rewrite-chost.patch b/sys-devel/distcc/files/distcc-3.3.3-no-rewrite-chost.patch
new file mode 100644
index 000000000000..dafaa90759b4
--- /dev/null
+++ b/sys-devel/distcc/files/distcc-3.3.3-no-rewrite-chost.patch
@@ -0,0 +1,28 @@
+From c2471d4cf3e2ef2556c150d52860b4e8f04e4994 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ville=20Syrj=C3=A4l=C3=A4?= <ville.syrjala@linux.intel.com>
+Date: Mon, 1 Mar 2021 22:13:36 +0200
+Subject: [PATCH] distcc: fix i686 cross compile
+
+[mgorny: disable toolchain prefix rewriting code that workarounds some
+ Debian invention and breaks everything else]
+
+---
+ src/compile.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/compile.c b/src/compile.c
+index 25df355..e5d655b 100644
+--- a/src/compile.c
++++ b/src/compile.c
+@@ -572,7 +572,7 @@ static int dcc_gcc_rewrite_fqn(char **argv)
+ if (!newcmd)
+ return -ENOMEM;
+
+- if ((t = strstr(target_with_vendor, "-pc-"))) {
++ if (0 && (t = strstr(target_with_vendor, "-pc-"))) {
+ memcpy(newcmd, target_with_vendor, t - target_with_vendor);
+ strcat(newcmd, t + strlen("-pc"));
+ } else
+--
+2.26.2
+