summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-20 10:09:17 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-20 11:09:06 +0100
commit761f99ae251bbedafe1ad076b77023772291dc44 (patch)
tree41809e47c18f84f3fe911374dc1424e85cf11330
parentprofiles: Drop obsolete kde-apps/okular[dpi] nask (diff)
downloadgentoo-761f99ae251bbedafe1ad076b77023772291dc44.tar.gz
gentoo-761f99ae251bbedafe1ad076b77023772291dc44.tar.bz2
gentoo-761f99ae251bbedafe1ad076b77023772291dc44.zip
sys-devel/clang-runtime: Add multilib propagation flags
Add multilib flags and use them to propagate ABI support to runtime packages. This makes it possible to reliably enforce support for a particular ABI via the central package.
-rw-r--r--sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild6
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild b/sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild
index 29c4a2dc6dd9..d2b06e96283d 100644
--- a/sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-3.9.0.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit multilib-build
+
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="http://clang.llvm.org/"
SRC_URI=""
@@ -15,5 +17,5 @@ IUSE="libcxx openmp"
# compiler-rt is installed unconditionally
RDEPEND="
- libcxx? ( ~sys-libs/libcxx-${PV} )
- openmp? ( ~sys-libs/libomp-${PV} )"
+ libcxx? ( ~sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( ~sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
diff --git a/sys-devel/clang-runtime/clang-runtime-9999.ebuild b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
index a29a5419eb1b..d224ca01584b 100644
--- a/sys-devel/clang-runtime/clang-runtime-9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit multilib-build
+
DESCRIPTION="Meta-ebuild for clang runtime libraries"
HOMEPAGE="http://clang.llvm.org/"
SRC_URI=""
@@ -18,7 +20,7 @@ RDEPEND="
~sys-libs/compiler-rt-${PV}
sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV} )
)
- libcxx? ( ~sys-libs/libcxx-${PV} )
- openmp? ( ~sys-libs/libomp-${PV} )"
+ libcxx? ( ~sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( ~sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
REQUIRED_USE="sanitize? ( compiler-rt )"