summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-06-14 10:36:18 -0400
committerCraig Andrews <candrews@gentoo.org>2019-06-14 10:36:18 -0400
commit774d60c67436e41a0762f9fd77b0f15ec4dc1672 (patch)
treee16559e8486ea04c14d879108c81fb550d6845c6
parentnet-p2p/cpuminer-opt: 3.9.3.1 version bump (diff)
downloadgentoo-774d60c67436e41a0762f9fd77b0f15ec4dc1672.tar.gz
gentoo-774d60c67436e41a0762f9fd77b0f15ec4dc1672.tar.bz2
gentoo-774d60c67436e41a0762f9fd77b0f15ec4dc1672.zip
www-apache/mod_h2: 1.15.2 version bump
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.15.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index f95f5f991ecd..870b228b3be1 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -8,3 +8,4 @@ DIST mod_http2-1.14.0.tar.gz 1034167 BLAKE2B f29d3937339562f0b8e21ab5eeaca8ff1ca
DIST mod_http2-1.14.1.tar.gz 1032989 BLAKE2B 15359369f8332d9f9d35cb43468b2cd0d98529155d360176c41ac38c24a94824510b518aaa367cff10672bfdd3c7a24269cca4552d993bf7d63f28f857a1ae78 SHA512 04298f0fd9379ae22ba87f5dc95791091ff95cc90c2e898334cc33a0c5115905ec6cbc93676b3a28786436f351c8971721b2786e70cd498fd73ec64b5f46e611
DIST mod_http2-1.15.0.tar.gz 1036567 BLAKE2B 1ed9fdd7bf13c8ec7ac14b2cd0a109f0cd6e6d1eb8047e1cf6cd107143e23ebb6d9f9ef753942d44ec4d2168e0783dd23dd66b338d8631c504d4cd81b0287b83 SHA512 c3541c930ceee81dfbd688ea155561b6e06aa8ef486830a95e6cfa621f3589aa9c9e15661a4b81463cbe716d02dd28a574e3a74894a74d7c751c88894d378858
DIST mod_http2-1.15.1.tar.gz 1026120 BLAKE2B 724d09bfafc2fe6a288eeebd7fbdcbe2c3d3e146b0afae42ae72be16931904982b07fd55f4c96da6f8718b5058421813ecd186ac4b4161a74ea7b83c38394ed1 SHA512 3564e8e4cb896420b91669d710d70cdecbe45480078c790960fd7d8c788ac9b843517c2af0747932ad53eb048c39765c4ceb2b7de7e04a1bc7fcb57af0117eb9
+DIST mod_http2-1.15.2.tar.gz 1037495 BLAKE2B a6e1afcea50034affc2d505445f0227688a448ef1979de19df42db2e277ba0b1904f249bc55a114901039ce503d164bde92d70d69e70ddf03e3708ee5dd96233 SHA512 c919e9cd2a959d3ccde697424dc40580d52a2620ee476fc675b9f30a030044c2f9872b282e4ab08d4d576c0c7ee08ca2baad5a1d9a456dbd6c007cfef9fca6b3
diff --git a/www-apache/mod_h2/mod_h2-1.15.2.ebuild b/www-apache/mod_h2/mod_h2-1.15.2.ebuild
new file mode 100644
index 000000000000..3e6d435d3f82
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.15.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}