summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-05 11:08:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-05 13:54:27 +0200
commit79dddd4a1489e3155eb06139f084b9e0d4aa7c9c (patch)
tree734b4afbc66e98e2f50753db965cb7e49bbf7e2c
parentdev-scheme/guile: add regex as required bug #596322 (diff)
downloadgentoo-79dddd4a1489e3155eb06139f084b9e0d4aa7c9c.tar.gz
gentoo-79dddd4a1489e3155eb06139f084b9e0d4aa7c9c.tar.bz2
gentoo-79dddd4a1489e3155eb06139f084b9e0d4aa7c9c.zip
media-libs/libebur128: 1.2.2 version bump
Additional upstream fixes to cmake and adding pkgconfig file. Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--media-libs/libebur128/Manifest1
-rw-r--r--media-libs/libebur128/files/libebur128-1.2.2-cmake.patch52
-rw-r--r--media-libs/libebur128/files/libebur128-1.2.2-pkgconfig.patch43
-rw-r--r--media-libs/libebur128/libebur128-1.2.2.ebuild39
4 files changed, 135 insertions, 0 deletions
diff --git a/media-libs/libebur128/Manifest b/media-libs/libebur128/Manifest
index 76e751ea9c61..549751feae60 100644
--- a/media-libs/libebur128/Manifest
+++ b/media-libs/libebur128/Manifest
@@ -4,3 +4,4 @@ DIST libebur128-1.0.2.tar.gz 29794 SHA256 9b334d31a26b47ba6740bb7bbee7a24461d535
DIST libebur128-1.0.3.tar.gz 19804 SHA256 dd90d0e44bd4db1e038d990b4538a7317b2f44f29eaf2e206c247663234d9d52 SHA512 586ae80c31b9ef1d315821cef6901edd3f3d5309299411e969cce18cdc1911639971ad249b3b49edae9195b428557dbfa3281a5dc22da20a245e66c497eb0422 WHIRLPOOL c5d62232ed6bc05bf909a809fc38c15d79d1278ecc708ca94d4b41e37d38985d50764eeff9a6c5a4582baf3963864d512ba90d6b7a90c363b3bb334ebb860fda
DIST libebur128-1.1.0.tar.gz 19318 SHA256 c60e78f4bfda387a0895c64a4fc9850445e3a4425cc98f9140885966ce17c1d1 SHA512 13a0d92eae8d991a15cb090e5f3ca34fbe285bf7e8e01e10b5ccc8be4f066e8bbff6920370d4506284f02dbfca3a5189ddfe9135f195179d356257055768c08a WHIRLPOOL 0775f4b220a690310f736dccd1748fe48c643cf0889378b4238b7aa4cc57967fb77c81f28cd4bdd4de220e832c220d45524fd63834e6e5ce37cfe381118cc0eb
DIST libebur128-1.2.0.tar.gz 21690 SHA256 f4c4ce732ae085214bcc47349f89b61ed53c13721c097e01cb966533ee6b1e5b SHA512 70bae021e4a9c60e1eee5dd2ffb357bda007b9f29cda0a25b9ae453cf389661a238e6300a2bbfb323afe9b0955d2b8468fff91eb1bf2a3d665c9e32c5e80631d WHIRLPOOL 50a861a61bcb7028d6cf94ac669d3876199680f696eff09a699713cbc5047d863f337cebd54988e3061daa420f92454148f642c16fa4abe4e50da6ad1ff76c17
+DIST libebur128-1.2.2.tar.gz 21738 SHA256 1d0d7e855da04010a2432e11fbc596502caf11b61c3b571ccbcb10095fe44b43 SHA512 76cf92824498cc0f73676ce4bf8e58156a0b2d5c686c6a483bbbdba95f879d651a2a3bb3b836e6409e0821aa165dc3c71827f47fd952407fb3e421a0c2c7ebf6 WHIRLPOOL 3ff598a6c1c47bef493770fc139274e02e36b976785d5865df8556df0c3b782a6d9aebfebf6a5ef1e291f5db6c89156cc214e775885f24b0293653003e7fb3cf
diff --git a/media-libs/libebur128/files/libebur128-1.2.2-cmake.patch b/media-libs/libebur128/files/libebur128-1.2.2-cmake.patch
new file mode 100644
index 000000000000..9563ed15319f
--- /dev/null
+++ b/media-libs/libebur128/files/libebur128-1.2.2-cmake.patch
@@ -0,0 +1,52 @@
+From d374f1983966fc3ff65bcd73e5f12d358c4f1273 Mon Sep 17 00:00:00 2001
+From: "Yann E. MORIN" <yann.morin.1998@free.fr>
+Date: Sat, 4 Mar 2017 14:33:07 +0100
+Subject: [PATCH] CMakeList: do not overwrite module path
+
+Currently, the CMakeList.txt completely overwrites the CMAKE_MODULE_PATH
+variable.
+
+This is problematic when an upper-layer buildsystem wants to set its own
+module path to use custom modules.
+
+For example, Buildroot [0] provides a custom platform description [1] to
+fix cross-compilation issue. Overwriting the module path means that this
+custom platform description is not found:
+
+ System is unknown to cmake, create:
+ Platform/Buildroot to use this system, please send your config file
+ to cmake@www.cmake.org so it can be added to cmake
+
+Providing such a custom platform description is what the upstream cmake
+devs suggest [2], quoting:
+
+ If a toolchain file specifies CMAKE_SYSTEM_NAME such that a custom
+ `Platform/MySystem.cmake` file is loaded then the latter can set
+ them [*] as needed for the target platform.
+
+[*] offending settings causing RPATH issues during cross-compilation.
+
+So we need to append to the module path, rather than replace it blindly.
+
+[0] https://buildroot.org/
+[1] https://git.buildroot.org/buildroot/tree/support/misc/Buildroot.cmake
+[2] http://public.kitware.com/pipermail/cmake/2017-February/065063.html
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eea18a6..ff352eb 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
+ project(libebur128 C)
+
+-set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
++list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
+ set(EXECUTABLE_OUTPUT_PATH ${CMAKE_BINARY_DIR})
+ set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR})
+
diff --git a/media-libs/libebur128/files/libebur128-1.2.2-pkgconfig.patch b/media-libs/libebur128/files/libebur128-1.2.2-pkgconfig.patch
new file mode 100644
index 000000000000..7382960711f1
--- /dev/null
+++ b/media-libs/libebur128/files/libebur128-1.2.2-pkgconfig.patch
@@ -0,0 +1,43 @@
+From 13d70019c6d0e94b1ab71d0d2cf80023cc793071 Mon Sep 17 00:00:00 2001
+From: Sebastian Ramacher <sramacher@debian.org>
+Date: Sat, 18 Feb 2017 01:13:03 +0100
+Subject: [PATCH] Add a pkg-config file (fixes #61)
+
+Signed-off-by: Sebastian Ramacher <sramacher@debian.org>
+---
+ ebur128/CMakeLists.txt | 6 ++++++
+ ebur128/libebur128.pc.cmake | 11 +++++++++++
+ 2 files changed, 17 insertions(+)
+ create mode 100644 ebur128/libebur128.pc.cmake
+
+diff --git a/ebur128/CMakeLists.txt b/ebur128/CMakeLists.txt
+index af09ebb..f9a8017 100644
+--- a/ebur128/CMakeLists.txt
++++ b/ebur128/CMakeLists.txt
+@@ -59,3 +59,9 @@ if(BUILD_STATIC_LIBS)
+ else()
+ install(TARGETS ebur128 DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ endif()
++
++#### pkg-config
++configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libebur128.pc.cmake
++ ${CMAKE_CURRENT_BINARY_DIR}/libebur128.pc @ONLY)
++install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libebur128.pc"
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+diff --git a/ebur128/libebur128.pc.cmake b/ebur128/libebur128.pc.cmake
+new file mode 100644
+index 0000000..017fdeb
+--- /dev/null
++++ b/ebur128/libebur128.pc.cmake
+@@ -0,0 +1,11 @@
++prefix=@CMAKE_INSTALL_PREFIX@
++includedir=${prefix}/include
++libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
++
++Name: libebur128
++Description: EBU R 128 standard for loudness normalisation
++Version: @EBUR128_VERSION@
++URL: https://github.com/jiixyj/libebur128
++Libs: -L${libdir} -lebur128
++Libs.private: -lm
++Cflags: -I${includedir}
diff --git a/media-libs/libebur128/libebur128-1.2.2.ebuild b/media-libs/libebur128/libebur128-1.2.2.ebuild
new file mode 100644
index 000000000000..d1e90f816a22
--- /dev/null
+++ b/media-libs/libebur128/libebur128-1.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A library implementing the EBU R128 loudness standard"
+HOMEPAGE="https://github.com/jiixyj/libebur128"
+SRC_URI="https://github.com/jiixyj/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://tech.ebu.ch/files/live/sites/tech/files/shared/testmaterial/ebu-loudness-test-setv05.zip )"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="test? ( app-arch/unzip
+ media-libs/libsndfile[${MULTILIB_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-pkgconfig.patch"
+ "${FILESDIR}/${P}-cmake.patch"
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cd "${WORKDIR}"
+ "${BUILD_DIR}"/r128-test-library | tee test-results
+ grep -c "^FAILED" test-results > /dev/null \
+ && die "At least one test failed"
+}