summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Levermann <simon@slevermann.de>2017-08-14 19:59:47 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-21 04:20:11 +0200
commit7aef8f2d5e64dd0b00a16a81601fddc6f08e6cc4 (patch)
tree0b2e1fb8af32901f7143cb093de3b520dd641979
parentapp-text/xiphos: Bump to 4.0.6a wrt bug 623804 (diff)
downloadgentoo-7aef8f2d5e64dd0b00a16a81601fddc6f08e6cc4.tar.gz
gentoo-7aef8f2d5e64dd0b00a16a81601fddc6f08e6cc4.tar.bz2
gentoo-7aef8f2d5e64dd0b00a16a81601fddc6f08e6cc4.zip
app-crypt/argon2: Fix build under multilib-strict
Bug: https://bugs.gentoo.org/627856 Closes: https://github.com/gentoo/gentoo/pull/5418 Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--app-crypt/argon2/argon2-20161029-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/argon2/argon2-20161029-r1.ebuild b/app-crypt/argon2/argon2-20161029-r1.ebuild
new file mode 100644
index 000000000000..6a2ac3f2695c
--- /dev/null
+++ b/app-crypt/argon2/argon2-20161029-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Password hashing software that won the Password Hashing Competition (PHC)"
+HOMEPAGE="https://github.com/P-H-C/phc-winner-argon2"
+SRC_URI="https://github.com/P-H-C/phc-winner-argon2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 CC0-1.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+S="${WORKDIR}/phc-winner-${P}"
+PATCHES=(
+ "${FILESDIR}/${P}-makefile-soname-symlinks.patch"
+ )
+src_prepare() {
+ default
+ if ! use static-libs; then
+ sed -i -e 's/LIBRARIES = \$(LIB_SH) \$(LIB_ST)/LIBRARIES = \$(LIB_SH)/' Makefile || die "sed failed!"
+ fi
+ sed -i -e 's/-O3 //' Makefile || die "sed failed"
+ sed -i -e 's/-g //' Makefile || die "sed failed"
+ sed -i -e "s/-march=\$(OPTTARGET) /${CFLAGS} /" Makefile || die "sed failed"
+ sed -i -e 's/CFLAGS += -march=\$(OPTTARGET)//' Makefile || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBRARY_REL=$(get_libdir) install || die
+}