summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-02 10:35:44 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-02 12:54:41 +0200
commit7e933523903295a88154547feff531573aba44f8 (patch)
tree3422c38d1a41a121ef8a3bcfc8c45135db20b472
parentmedia-libs/libmad: fixed wrong version in mad.pc (diff)
downloadgentoo-7e933523903295a88154547feff531573aba44f8.tar.gz
gentoo-7e933523903295a88154547feff531573aba44f8.tar.bz2
gentoo-7e933523903295a88154547feff531573aba44f8.zip
media-sound/lame: removed obsolete ebuild
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/lame/lame-3.100-r1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/media-sound/lame/lame-3.100-r1.ebuild b/media-sound/lame/lame-3.100-r1.ebuild
deleted file mode 100644
index ede672f73047..000000000000
--- a/media-sound/lame/lame-3.100-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="LAME Ain't an MP3 Encoder"
-HOMEPAGE="http://lame.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug cpu_flags_x86_mmx +frontend mp3rtp sndfile static-libs"
-
-# These deps are without MULTILIB_USEDEP and are correct since we only build
-# libmp3lame for multilib and these deps apply to the lame frontend executable.
-RDEPEND="
- frontend? (
- >=sys-libs/ncurses-5.7-r7:0=
- sndfile? ( >=media-libs/libsndfile-1.0.2 )
- )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- cpu_flags_x86_mmx? ( dev-lang/nasm )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.96-ccc.patch
- "${FILESDIR}"/${PN}-3.98-gtk-path.patch
- "${FILESDIR}"/${PN}-3.99.5-tinfo.patch
- "${FILESDIR}"/${PN}-3.99.5-msse.patch
-)
-
-src_prepare() {
- default
-
- mkdir libmp3lame/i386/.libs || die #workaround parallel build with nasm
-
- sed -i -e '/define sp/s/+/ + /g' libmp3lame/i386/nasm.h || die
-
- use cpu_flags_x86_mmx || sed -i -e '/AC_PATH_PROG/s:nasm:dIsAbLe&:' configure.in #361879
-
- AT_M4DIR=. eautoreconf
-}
-
-multilib_src_configure() {
- # Only build the frontend for the default ABI.
- local myconf=(
- --disable-mp3x
- --enable-dynamic-frontends
- $(multilib_native_use_enable frontend)
- $(multilib_native_use_enable mp3rtp)
- $(multilib_native_usex sndfile '--with-fileio=sndfile' '')
- $(use_enable debug debug norm)
- $(use_enable static-libs static)
- $(usex cpu_flags_x86_mmx '--enable-nasm' '') #361879
- )
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-}
-
-multilib_src_install() {
- emake \
- DESTDIR="${D}" \
- pkghtmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
- install
-}
-
-multilib_src_install_all() {
- dodoc API ChangeLog HACKING README STYLEGUIDE TODO USAGE
- docinto html
- dodoc misc/lameGUI.html Dll/LameDLLInterface.htm
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-}