summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-09-27 08:49:04 +0200
committerFabian Groffen <grobian@gentoo.org>2019-09-28 10:48:16 +0200
commit7fd54196ad042b7b8f564d6aab6545892493a2de (patch)
treeb3b897131ff2709bb09806f6162c06626f40fdaa
parentmedia-libs/gexiv2: add longdescription (diff)
downloadgentoo-7fd54196ad042b7b8f564d6aab6545892493a2de.tar.gz
gentoo-7fd54196ad042b7b8f564d6aab6545892493a2de.tar.bz2
gentoo-7fd54196ad042b7b8f564d6aab6545892493a2de.zip
app-portage/portage-utils: drop old 0.62, m68k has 0.80 stable now
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--app-portage/portage-utils/Manifest1
-rw-r--r--app-portage/portage-utils/portage-utils-0.62.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/app-portage/portage-utils/Manifest b/app-portage/portage-utils/Manifest
index 0fd600cee709..1f7d72468b3a 100644
--- a/app-portage/portage-utils/Manifest
+++ b/app-portage/portage-utils/Manifest
@@ -1,3 +1,2 @@
-DIST portage-utils-0.62.tar.xz 527216 BLAKE2B ac8331b74998ddb86db55a937992447bccf60611cc259ceb5fe79918c1a43b6dc4633e4ad64462e2df5c39e8d8aa193bd57ab24dcd714e088357eb3cb177e972 SHA512 71b2888cef1bf7549c3829cc7d4bbe2e99a711434bae4fb78c55b9c37815b61623518f19ab87db30f533d771398933c085640dc7c8ffcedf87a70ac702a52fa1
DIST portage-utils-0.74.tar.xz 1587792 BLAKE2B 7c4588e3d44266a5260df42cc685aa03c584248e9970956033e4191a7a842a4b2162110ac99c2bb18645aaafc6ae6ee960e9b26ba0a8863497911eef1e943f64 SHA512 cd3f44c135b3d44e15a95eed41281fce62f225a9d05d5d5bb1be230b2d59cdb87755f011b313a9ec32e4cafdf3b3979c4ef423365edd7dcc472ca2e38c09c83e
DIST portage-utils-0.80.tar.xz 1762692 BLAKE2B 32e4502d517ec088eadf17a4a348b9b9bc33348380b65f93ac7c043150732ba3ff0d18ee96f8877c697a91000fdc036de392d6e6711d62248bb7c57e25d4433f SHA512 cca86877e87e5bd2e9423822db4b7afa15e8f291717c808ef0455b121db0778b2364552e9f1d5e1a8bad3f1f8880ae2b5dbd586bf1dd74d7c4f4e72fa990c78c
diff --git a/app-portage/portage-utils/portage-utils-0.62.ebuild b/app-portage/portage-utils/portage-utils-0.62.ebuild
deleted file mode 100644
index 28eb664c0b5d..000000000000
--- a/app-portage/portage-utils/portage-utils-0.62.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit flag-o-matic toolchain-funcs eutils
-
-DESCRIPTION="small and fast portage helper tools written in C"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
-SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="m68k"
-IUSE="nls static"
-
-RDEPEND="dev-libs/iniparser:0"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- static? ( dev-libs/iniparser:0[static-libs] )"
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- # Avoid slow configure+gnulib+make if on an up-to-date Linux system
- if use prefix || ! use kernel_linux || \
- has_version '<sys-libs/glibc-2.10'
- then
- econf --with-eprefix="${EPREFIX}"
- else
- tc-export CC
- fi
-}
-
-src_compile() {
- emake NLS=$(usex nls)
-}
-
-src_install() {
- default
-
- exeinto /etc/portage/bin
- doexe "${FILESDIR}"/post_sync
- insinto /etc/portage/postsync.d
- doins "${FILESDIR}"/q-reinitialize
-
- # Portage fixes shebangs, we just need to fix the paths in the files
- sed -i \
- -e "s:\(/etc/portage/postsync.d\|/usr/bin/q\):${EPREFIX}&:g" \
- "${ED}"/etc/portage/bin/post_sync \
- "${ED}"/etc/portage/postsync.d/q-reinitialize || die
-}
-
-pkg_preinst() {
- # preserve +x bit on postsync files #301721
- local x
- pushd "${ED}" >/dev/null
- for x in etc/portage/postsync.d/* ; do
- [[ -x ${EROOT}/${x} ]] && chmod +x "${x}"
- done
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "${EPREFIX}/etc/portage/postsync.d/q-reinitialize has been installed for convenience"
- elog "If you wish for it to be automatically run at the end of every --sync:"
- elog " # chmod +x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- elog "Normally this should only take a few seconds to run but file systems"
- elog "such as ext3 can take a lot longer. To disable, simply do:"
- elog " # chmod -x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- fi
-}