summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-15 23:00:44 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:42 +0000
commit8111d0a41b274000576ef2fd1be3e2e9d9afa1d7 (patch)
treefbd732f2b2d50f6555b618e1e7eb44fdb90298ac
parentdev-haskell/foldl: bump up to 1.2.3 (diff)
downloadgentoo-8111d0a41b274000576ef2fd1be3e2e9d9afa1d7.tar.gz
gentoo-8111d0a41b274000576ef2fd1be3e2e9d9afa1d7.tar.bz2
gentoo-8111d0a41b274000576ef2fd1be3e2e9d9afa1d7.zip
sci-mathematics/z3: workaround configure failure on non-ASCII
On my LANG=ru_RU.UTF-8 locale configure step fails as: File "scripts/mk_make.py", line 21, in <module> ... UnicodeEncodeError: 'ascii' codec can't encode characters in position 80-82: ordinal not in range(128) Workaround configure breakage by stabilising locale. Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-mathematics/z3/z3-4.5.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-mathematics/z3/z3-4.5.0.ebuild b/sci-mathematics/z3/z3-4.5.0.ebuild
index 30eea151404e..0cd4becd5485 100644
--- a/sci-mathematics/z3/z3-4.5.0.ebuild
+++ b/sci-mathematics/z3/z3-4.5.0.ebuild
@@ -79,8 +79,13 @@ src_configure() {
$(usex python --python "") \
$(usex java --java "")
elog ./configure "$@"
- ./configure "$@" || die
- ${EPYTHON} scripts/mk_make.py || die
+ # LANG=C to force external tools to output ascii text only
+ # otherwise configure crashes as:
+ # File "scripts/mk_make.py", line 21, in <module>
+ # UnicodeEncodeError: 'ascii' codec can't encode characters in position 80-82: ordinal not in range(128)
+ LANG=C ./configure "$@" || die
+ elog ${EPYTHON} scripts/mk_make.py "$@"
+ LANG=C ${EPYTHON} scripts/mk_make.py || die
}
src_compile() {