summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 11:18:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 11:20:45 +0200
commit8241cf396cdc66bf34c052a6d9adf395754efc83 (patch)
tree218b740f18c3a75202e6a0fe63975003a4892c7e
parentdev-python/pytest-metadata: Remove old (diff)
downloadgentoo-8241cf396cdc66bf34c052a6d9adf395754efc83.tar.gz
gentoo-8241cf396cdc66bf34c052a6d9adf395754efc83.tar.bz2
gentoo-8241cf396cdc66bf34c052a6d9adf395754efc83.zip
dev-python/pytest-pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-pylint/Manifest1
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
index 3297991c13cb..e3b72f5e712a 100644
--- a/dev-python/pytest-pylint/Manifest
+++ b/dev-python/pytest-pylint/Manifest
@@ -1,2 +1 @@
-DIST pytest-pylint-0.17.0.tar.gz 11660 BLAKE2B b536dcaaf0ac652dcbe66018fa22e120782496de58f74003c523eb003ff0556f9b738e528a85724a1e589e18bb0024d99fbeb581b7f5b36ec349ad07da8d26d0 SHA512 a23937ec191ef14829530ac6bf31b882bc250f312e2ba6e3b8cc1187c888511e4b67ffaf5bce176556a621fbf80239b30c43c635898d458bb8d819e92a9f8142
DIST pytest-pylint-0.18.0.tar.gz 12448 BLAKE2B 9d0cecb08fc87d7e2aade47af3f2677431776a425726c281e9abc5fdeebb84f38ab4a97e405ed407b1cd241eb97a8cd90e878af61f818b46cab5f9fba5ca3d5f SHA512 a0716104d288774d4c3ab596f30a33cf439df5031647912574c31eefc3a84e69e82fc362f77e73b437c7566a596d2ff8bf51a332626a7fa7468cea3b916e9ad9
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild
deleted file mode 100644
index d08f66d86c87..000000000000
--- a/dev-python/pytest-pylint/pytest-pylint-0.17.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..8} )
-
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to check source code with pylint"
-HOMEPAGE="https://github.com/carsongee/pytest-pylint"
-# Tests should be included in PyPI tarballs by the next release:
-# https://github.com/carsongee/pytest-pylint/commit/4e7f06701ca06697a22a029db9857fa2fdf7c033
-SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/pylint-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
- >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Disable flake8 and pep8 options
- sed -i -e '/^addopts =/d' tox.ini || die
- # Remove pytest-runner requirement
- sed -i -e "s/'pytest-runner'//" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Required to load the pytest-pylint plugin
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}