summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-10-19 20:24:02 +0100
committerJames Le Cuirot <chewi@gentoo.org>2015-10-19 20:24:31 +0100
commit869d94bea549e9e4894221ddbd46d0e7d0994815 (patch)
tree82774c994c8124190cac70026947732fe2072627
parentgames-action/bzflag: add dependency on net-libs/miniupnpc subslot. Bug #562352 (diff)
downloadgentoo-869d94bea549e9e4894221ddbd46d0e7d0994815.tar.gz
gentoo-869d94bea549e9e4894221ddbd46d0e7d0994815.tar.bz2
gentoo-869d94bea549e9e4894221ddbd46d0e7d0994815.zip
dev-java/gjdoc: EAPI bump and allow the new split anltr-2
Straight to stable because I don't want stable revdeps to hold up the removal of the older antlr-2. I'm going to last-rite gjdoc soon anyway. Package-Manager: portage-2.2.20.1
-rw-r--r--dev-java/gjdoc/gjdoc-0.7.9-r3.ebuild (renamed from dev-java/gjdoc/gjdoc-0.7.9-r2.ebuild)21
1 files changed, 11 insertions, 10 deletions
diff --git a/dev-java/gjdoc/gjdoc-0.7.9-r2.ebuild b/dev-java/gjdoc/gjdoc-0.7.9-r3.ebuild
index 1c1c4fae460c..66f4a2edf2e9 100644
--- a/dev-java/gjdoc/gjdoc-0.7.9-r2.ebuild
+++ b/dev-java/gjdoc/gjdoc-0.7.9-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
+EAPI=5
JAVA_PKG_IUSE="source"
inherit eutils autotools java-pkg-2
@@ -24,12 +24,13 @@ KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x
#
IUSE="xmldoclet"
-RDEPEND=">=virtual/jre-1.4
- >=dev-java/antlr-2.7.1:0[java]"
+CDEPEND=">=dev-java/antlr-2.7.1:0[java(+)]"
-# Refused to emerge with sun-jdk-1.3* complaining about wanting a bigger stack size
-DEPEND="${RDEPEND}
- >=virtual/jdk-1.4"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.4"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.4"
src_prepare() {
epatch "${FILESDIR}/${PN}-0.7.7-gcp.patch"
@@ -49,7 +50,7 @@ src_configure() {
# TODO ideally, would respect JAVACFLAGS
JAVA="java" JAVAC="javac $(java-pkg_javac-args)" \
econf ${myc} \
- $(use_enable xmldoclet) || die "econf failed"
+ $(use_enable xmldoclet)
}
src_compile() {
@@ -63,10 +64,10 @@ src_install() {
done
java-pkg_dolauncher ${PN} --main gnu.classpath.tools.gjdoc.Main
- dodoc AUTHORS ChangeLog NEWS README || die
+ dodoc AUTHORS ChangeLog NEWS README
cd "${S}"/docs
- emake DESTDIR="${D}" install || die "Failed to install documentation"
+ emake DESTDIR="${D}" install
use source && java-pkg_dosrc "${S}/src"/{com,gnu}
}