summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-18 19:57:49 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-18 19:57:49 +0100
commit87bc53fbc14cc579a8a58a4a65c72e7a99870fd4 (patch)
tree4fc3c3bcf30b66f9ac4beacdcef912045f6c3d5b
parentdev-python/ubelt: drop old (diff)
downloadgentoo-87bc53fbc14cc579a8a58a4a65c72e7a99870fd4.tar.gz
gentoo-87bc53fbc14cc579a8a58a4a65c72e7a99870fd4.tar.bz2
gentoo-87bc53fbc14cc579a8a58a4a65c72e7a99870fd4.zip
dev-python/line_profiler: add python3_9
Closes: https://github.com/gentoo/gentoo/pull/18312 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/line_profiler/files/line_profiler-3.0.2-python3_9.patch35
-rw-r--r--dev-python/line_profiler/line_profiler-3.0.2.ebuild6
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/line_profiler/files/line_profiler-3.0.2-python3_9.patch b/dev-python/line_profiler/files/line_profiler-3.0.2-python3_9.patch
new file mode 100644
index 000000000000..74b0677bc70a
--- /dev/null
+++ b/dev-python/line_profiler/files/line_profiler-3.0.2-python3_9.patch
@@ -0,0 +1,35 @@
+From f40a6e102d3c4808155af601ddba7733e597e604 Mon Sep 17 00:00:00 2001
+From: Stefano Rivera <stefano@rivera.za.net>
+Date: Thu, 15 Oct 2020 22:44:50 -0700
+Subject: [PATCH] Python 3.9 dropped gettimeofday configure checks
+
+Upstream status: Accepted [https://github.com/pyutils/line_profiler/pull/31}
+Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
+
+diff --git a/line_profiler/timers.c b/line_profiler/timers.c
+index ae01060..e8ee6c6 100644
+--- a/line_profiler/timers.c
++++ b/line_profiler/timers.c
+@@ -32,10 +32,6 @@ hpTimerUnit(void)
+
+ #else /* !MS_WINDOWS */
+
+-#ifndef HAVE_GETTIMEOFDAY
+-#error "This module requires gettimeofday() on non-Windows platforms!"
+-#endif
+-
+ #if (defined(PYOS_OS2) && defined(PYCC_GCC))
+ #include <sys/time.h>
+ #else
+@@ -48,11 +44,7 @@ hpTimer(void)
+ {
+ struct timeval tv;
+ PY_LONG_LONG ret;
+-#ifdef GETTIMEOFDAY_NO_TZ
+- gettimeofday(&tv);
+-#else
+ gettimeofday(&tv, (struct timezone *)NULL);
+-#endif
+ ret = tv.tv_sec;
+ ret = ret * 1000000 + tv.tv_usec;
+ return ret;
diff --git a/dev-python/line_profiler/line_profiler-3.0.2.ebuild b/dev-python/line_profiler/line_profiler-3.0.2.ebuild
index a48003e8777a..5c5578115921 100644
--- a/dev-python/line_profiler/line_profiler-3.0.2.ebuild
+++ b/dev-python/line_profiler/line_profiler-3.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -26,6 +26,10 @@ DEPEND="test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/ubelt[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${P}-python3_9.patch
+)
+
distutils_enable_tests pytest
python_test() {