summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-12 12:54:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-12 12:57:37 +0200
commit8840ef51bb6c7e9de64dc1254c0b9fc0d929376e (patch)
tree7016f3d4c2d079e2bc628e9abd22211338bf4a60
parentx11-libs/gtk+-3.24.0: fix minimum glib dep (diff)
downloadgentoo-8840ef51bb6c7e9de64dc1254c0b9fc0d929376e.tar.gz
gentoo-8840ef51bb6c7e9de64dc1254c0b9fc0d929376e.tar.bz2
gentoo-8840ef51bb6c7e9de64dc1254c0b9fc0d929376e.zip
games-engines/residualvm: Added live ebuild.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--games-engines/residualvm/residualvm-9999.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/games-engines/residualvm/residualvm-9999.ebuild b/games-engines/residualvm/residualvm-9999.ebuild
new file mode 100644
index 000000000000..7343afbb7e72
--- /dev/null
+++ b/games-engines/residualvm/residualvm-9999.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="A cross-platform 3D game interpreter for play LucasArts' LUA-based 3D adventures"
+HOMEPAGE="http://www.residualvm.org/"
+if [[ "${PV}" = 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/residualvm/residualvm.git"
+else
+ SRC_URI="http://www.residualvm.org/downloads/release/${PV}/${P}-sources.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+# TODO: fix dynamic plugin support
+# games crash without media-libs/libsdl[alsa]
+RDEPEND="
+ media-libs/alsa-lib
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,sound,alsa,joystick,opengl,video]
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # not an autotools script
+ # most configure options currently do nothing, verify on version bump !!!
+ # disable explicitly, otherwise we get unneeded linkage (some copy-paste build system)
+ local myconf=(
+ --backend=sdl
+ --disable-debug
+ --disable-faad
+ --disable-flac
+ --disable-fluidsynth
+ --disable-libunity
+ --disable-mad
+ --disable-sparkle
+ --disable-translation
+ --disable-tremor
+ --disable-vorbis
+ --docdir="/usr/share/doc/${PF}"
+ --enable-all-engines
+ --enable-release-mode
+ --enable-zlib
+ )
+ ./configure "${myconf[@]}" || die "configure failed"
+}
+
+src_compile() {
+ emake \
+ VERBOSE_BUILD=1 \
+ AR="$(tc-getAR) cru" \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ dobin residualvm
+
+ insinto "/usr/share/${PN}"
+ doins gui/themes/modern.zip dists/engine-data/residualvm-grim-patch.lab
+
+ doicon -s scalable icons/${PN}.svg
+ doicon -s 256 icons/${PN}.png
+ domenu dists/${PN}.desktop
+
+ doman dists/${PN}.6
+ dodoc AUTHORS README.md KNOWN_BUGS TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}