summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-03-15 20:49:22 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2016-03-15 20:49:22 +0200
commit8873c4ca0bd4687847b9160f1f80ef2e53549c50 (patch)
tree0268f7a2f2724e1184f7cbf6ed890f598d9de6a9
parentdev-perl/Perl-Critic-Dynamic: x86 stable wrt bug #572140 (diff)
downloadgentoo-8873c4ca0bd4687847b9160f1f80ef2e53549c50.tar.gz
gentoo-8873c4ca0bd4687847b9160f1f80ef2e53549c50.tar.bz2
gentoo-8873c4ca0bd4687847b9160f1f80ef2e53549c50.zip
app-laptop/laptop-mode-tools: version bump
Package-Manager: portage-2.2.26
-rw-r--r--app-laptop/laptop-mode-tools/Manifest1
-rw-r--r--app-laptop/laptop-mode-tools/laptop-mode-tools-1.69.1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/app-laptop/laptop-mode-tools/Manifest b/app-laptop/laptop-mode-tools/Manifest
index 815ea23a7771..69be903600ad 100644
--- a/app-laptop/laptop-mode-tools/Manifest
+++ b/app-laptop/laptop-mode-tools/Manifest
@@ -2,4 +2,5 @@ DIST laptop-mode-tools_1.66.tar.gz 111175 SHA256 0e8488d6112fa7edfa7e4b1084b16f8
DIST laptop-mode-tools_1.67.tar.gz 111730 SHA256 5205e5b4fa0eddcbb14e06a496a9e405cf3873eb5065e03e6a1237e29c8f3cd0 SHA512 a0f8f5c6c2616bbdbe86f82b0dc7ad1bd4b4315fc074b7b97ad29a9dec4e63164d625da732f6b6b9a73dd039d415c06da51c83c5aa1056e7893b65691da1437f WHIRLPOOL 03fd0f7bc7300d7357d6b1f27a38aed54c7b77a7f8633910d3bfa6aede862f24238bde9322398cedea0e6b9d1bcd85b988e56ff1f2aeb62d691a209aa6f2acab
DIST laptop-mode-tools_1.68.1.tar.gz 113137 SHA256 08d08f3d7ad76fb5f48232428584481a8e160421671533ece2648e968b519ba6 SHA512 68e230e3215631cff31157865eac6e73c08534e5481016425a41e1c166746e0df987a21cc158edc4dac5b1469c515eb23c89a51084b4f993debd28befc82064a WHIRLPOOL b421b48627fa2c80af0024c4c8705643330ddcfce5cbcdb0b71462fea466ebbac2b5a254855dba315ca0ab5b056a23a9f5ab5e66c84b15d17e2fcdbefe816589
DIST laptop-mode-tools_1.68.tar.gz 112695 SHA256 a9ceca49a623fecf0d8067cd71d11610a254af7e87a3a462cb4277527a905558 SHA512 1870c0400b32f4bb95f407db64f9e8920391c0758f37fa493545865ba0801ed6d67491c8d69bd7565d72a3437fe01524153fdd4dcf2cd69b49e7f1b0a54ff0c4 WHIRLPOOL 28b5e9fe7744824c4b562e8123e9403020a6096e32960f23592cc4393fce1379cc359602e83ff959187a953965e353d85c42c901c7ec6e382dd1ff67e0fb5699
+DIST laptop-mode-tools_1.69.1.tar.gz 115064 SHA256 4dcc55b10c3fc693daeb6be8d8e190f2b191dce0686a7bea0545a8821b8e7173 SHA512 1f027cec13800e4e0e256983769e45329423264b36112a4d79f3f09c4c01e7d411bbf8c376c67eb6d83224ffdde87e2fed4dc08176a406bc6a29ad3a392dd6d9 WHIRLPOOL a0eedb7db39b204d6b0e61ef2d210d3be37a70c81dbdb11fad4d61042c5f972996a709a793c82d2b636ad37c2873c1d87cc62c5bd279de08d6ce6c49bfa3d113
DIST laptop-mode-tools_1.69.tar.gz 115026 SHA256 7028a646532d30d27cb8ee13a87d6b2f0045b6d8b7fbea3af77f167dd22ccca5 SHA512 5dda4170473b62af1e49cc5d07298c7c5036b5f0fa9ad8b6f01265257a266c52f36a1e02c252544a10a87c7417393b54db98278b8a5bd6c1bd62f9f980e10831 WHIRLPOOL 5b9e48cb90b5da41a0d9864aa5ef2446f933e2b17841c2be9a89337a14150999330e50814642e8ddc648516d3c2c9ef64ce599e4513b8ed61046bfb121063e17
diff --git a/app-laptop/laptop-mode-tools/laptop-mode-tools-1.69.1.ebuild b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.69.1.ebuild
new file mode 100644
index 000000000000..237003404aae
--- /dev/null
+++ b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.69.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib systemd udev
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Linux kernel laptop_mode user-space utilities"
+HOMEPAGE="https://github.com/rickysarraf/laptop-mode-tools/wiki"
+SRC_URI="https://github.com/rickysarraf/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acpi apm bluetooth scsi"
+
+RDEPEND="net-wireless/wireless-tools
+ sys-apps/iproute2
+ sys-apps/ethtool
+ sys-apps/hdparm
+ sys-apps/which
+ acpi? ( sys-power/acpid )
+ apm? ( sys-apps/apmd )
+ bluetooth? ( net-wireless/bluez:= )
+ scsi? ( sys-apps/sdparm )"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # This should avoid conflict with pm-powersave wrt #327443 and #396703
+ cat <<-EOF > "${T}"/${PN}
+ HOOK_BLACKLIST="00powersave"
+ EOF
+}
+
+src_compile() { :; }
+
+src_install() {
+ DESTDIR="${D}" \
+ INIT_D="none" \
+ MAN_D="/usr/share/man" \
+ LIB_D="/usr/$(get_libdir)" \
+ UDEV_D="$(get_udevdir)" \
+ SYSTEMD_UNIT_D="$(systemd_get_unitdir)" \
+ TMPFILES_D="/usr/lib/tmpfiles.d" \
+ ACPI="$(use acpi && echo force || echo disabled)" \
+ PMU="$(false && echo force || echo disabled)" \
+ APM="$(use apm && echo force || echo disabled)" \
+ SYSTEMD=yes \
+ sh ./install.sh || die
+
+ dodoc Documentation/*.txt README.md
+ newinitd "${FILESDIR}"/laptop_mode.init-1.4 laptop_mode
+
+ # See src_prepare()
+ insinto /etc/pm/config.d
+ doins "${T}"/${PN}
+}
+
+pkg_postinst() {
+ if use acpi || use apm; then
+ if use acpi; then
+ daemon_name="acpid"
+ elif use apm; then
+ deamon_name="apmd"
+ fi
+ if [ "$(rc-config list default | grep laptop_mode)" = "" ] || [ "$(rc-config list default | grep ${daemon_name} )" = "" ]; then
+ ewarn "To enable automatic power state event handling,"
+ ewarn "e.g. enabling laptop_mode after unplugging the battery,"
+ ewarn "both laptop_mode and the ${daemon_name} daemon must be"
+ ewarn "added to default runlevel:"
+ if [ "$(rc-config list default | grep laptop_mode)" = "" ]; then
+ ewarn "# rc-update add laptop_mode default"
+ fi
+ if [ "$(rc-config list default | grep ${daemon_name} )" = "" ]; then
+ ewarn "# rc-update add ${daemon_name} default"
+ fi
+ fi
+ else
+ ewarn "Without USE=\"acpi\" or USE=\"apm\" ${PN} can not"
+ ewarn "automatically disable laptop_mode on low battery."
+ ewarn
+ ewarn "This means you can lose up to 10 minutes of work if running"
+ ewarn "out of battery while laptop_mode is enabled."
+ ewarn
+ ewarn "Please see laptop-mode.txt in /usr/share/doc/${PF} for further"
+ ewarn "information."
+ ewarn
+ fi
+}