summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-15 15:13:20 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-15 15:15:15 +0000
commit88ccd962caaf0c9a8247dd9ac512f5bc5824218b (patch)
treeccfbea7719ad4123b4d32fb631aca499c8aff245
parentdev-java/lzma: Version bump. EAPI 5 bump whilst at it. (diff)
downloadgentoo-88ccd962caaf0c9a8247dd9ac512f5bc5824218b.tar.gz
gentoo-88ccd962caaf0c9a8247dd9ac512f5bc5824218b.tar.bz2
gentoo-88ccd962caaf0c9a8247dd9ac512f5bc5824218b.zip
dev-java/lzmajio: EAPI 5 bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-java/lzmajio/lzmajio-0.95-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/lzmajio/lzmajio-0.95-r1.ebuild b/dev-java/lzmajio/lzmajio-0.95-r1.ebuild
new file mode 100644
index 000000000000..50c879357734
--- /dev/null
+++ b/dev-java/lzmajio/lzmajio-0.95-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Implementations of LzmaInputStream/LzmaOutputStream interacting with underlying LZMA en-/decoders"
+HOMEPAGE="http://contrapunctus.net/league/haques/lzmajio/"
+SRC_URI="http://comsci.liu.edu/~league/dist/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="dev-java/lzma:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}"
+
+S="${WORKDIR}/${P}"
+JAVA_GENTOO_CLASSPATH="lzma"
+JAVA_SRC_DIR="net"