summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-13 11:36:56 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-13 12:12:14 -0400
commit88e1fca15b995bbf194918584506b7d49064eeaf (patch)
treeb0d1a2af9bac1db3d39894b8faa0aee0fe726ca3
parentdev-util/devhelp: Drop old versions (diff)
downloadgentoo-88e1fca15b995bbf194918584506b7d49064eeaf.tar.gz
gentoo-88e1fca15b995bbf194918584506b7d49064eeaf.tar.bz2
gentoo-88e1fca15b995bbf194918584506b7d49064eeaf.zip
dev-util/meld: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-util/meld/Manifest1
-rw-r--r--dev-util/meld/meld-3.20.2-r1.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-util/meld/Manifest b/dev-util/meld/Manifest
index a2247f6877b..e4f885b2b55 100644
--- a/dev-util/meld/Manifest
+++ b/dev-util/meld/Manifest
@@ -1,2 +1 @@
-DIST meld-3.20.2.tar.xz 593948 BLAKE2B 9f2fee48405d76f9ae2fd0b0dd4116321aa176059dd4ef217a5c4c8d0edff5859bab72bbca83b2e7d612706f017d1889d68579eaf9838d7784c9ecb74ed7d403 SHA512 9c9074cb879e3574eb9a1025eb1212771419ab0d8e92bf8a99f38e70ca583ff5c8cbeaccb87b414e6ff73a61afa08e10742991d574b810cc90e8c4a5ac82ddaa
DIST meld-3.20.3.tar.xz 615248 BLAKE2B e60e6e9437c27cd217d39d045a5a23000b5b52e99387cfe0612c32ffb31205e467a13c8f42f478515bc8ba0d27814963649c362a7a95ac53e98f14398fd0cb3f SHA512 88052d1a59453e780a7842d2bf4d42ac5db8f5b4aa4b1ec3a931fb8d982d45fd212cfb75bb8395a2ad7b380a6e0c33d020a0562b4ffdf4afdc74d92d6d5751f0
diff --git a/dev-util/meld/meld-3.20.2-r1.ebuild b/dev-util/meld/meld-3.20.2-r1.ebuild
deleted file mode 100644
index 5e3097a134e..00000000000
--- a/dev-util/meld/meld-3.20.2-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_REQ_USE="xml"
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit gnome2 distutils-r1
-
-DESCRIPTION="A graphical diff and merge tool"
-HOMEPAGE="http://meldmerge.org/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.50:2
- $(python_gen_cond_dep '
- >=dev-python/pygobject-3.12:3[cairo,${PYTHON_MULTI_USEDEP}]
- ')
- gnome-base/gsettings-desktop-schemas
- >=x11-libs/gtk+-3.20:3[introspection]
- >=x11-libs/gtksourceview-3.20.0:3.0[introspection]
- >=x11-libs/pango-1.34[introspection]
- x11-themes/hicolor-icon-theme
-"
-DEPEND="${RDEPEND}
- dev-util/intltool
- dev-util/itstool
- sys-devel/gettext
-"
-# dev-python/distro is soft-required in BDEPEND for python3.8 and onwards,
-# but it's mainly needed for debian and derivatives - seems the fallback
-# works fine, as we aren't a special_case, just an annoying warning.
-
-python_compile_all() {
- mydistutilsargs=( --no-update-icon-cache --no-compile-schemas )
-}
-
-python_install() {
- local mydistutilsargs=( --no-update-icon-cache --no-compile-schemas build )
- distutils-r1_python_install
- rm "${ED}"/usr/share/doc/meld-${PV}/{COPYING,NEWS} || die
- rmdir "${ED}"/usr/share/doc/meld-${PV} || die
-}