summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-05-09 06:03:14 +0200
committerJeroen Roovers <jer@gentoo.org>2018-05-09 06:29:46 +0200
commit89a7379e7c15ba126db85529c5327fb1a63db448 (patch)
tree3780c17dbf2bbb364dcbdf18d407d1579d8936c1
parentdev-libs/libuv: Version 1.20.3. (diff)
downloadgentoo-89a7379e7c15ba126db85529c5327fb1a63db448.tar.gz
gentoo-89a7379e7c15ba126db85529c5327fb1a63db448.tar.bz2
gentoo-89a7379e7c15ba126db85529c5327fb1a63db448.zip
net-libs/nghttp2: Version 1.32.0.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.32.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index d496e17e6174..67fcb613a331 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -3,3 +3,4 @@ DIST nghttp2-1.29.0.tar.xz 1544736 BLAKE2B 1708d2c787e27d722aec27890a21e752a9fe6
DIST nghttp2-1.30.0.tar.xz 1545352 BLAKE2B 0d52f973a63632dc1ad235f1b535c24053a8dde52dfbda957c3e40548b4de5db5975639140f207cd9ffe564b6151ed6d97de45ff070eb2cfa3d6b41f52254430 SHA512 4b79f46947777627f0a9e1384ec51ac70e273aef6d46d322aa448731726b8ca606e73dcb171170bbe91fce93c28170ff04e11da56ee90fa28d642e7bc37b50be
DIST nghttp2-1.31.0.tar.xz 1545800 BLAKE2B c0b8130abe7eb16e977cb8d480505d74c41986f15733da2005b1772b4030082c1c0c2e9a0576aae3e88922fc7b17ad9658e916641c3ddb816b45cc0e202b5bf4 SHA512 00342b0517eb9e1044eced4649488d7ad35694e0a1303c4cba2d2be897fb86c5c70f1a5a157799d5c0cf448a6b983f2a2a57ee2bdb5ec762876647f9303446ca
DIST nghttp2-1.31.1.tar.xz 1545400 BLAKE2B 1d1a0982dc36928fe031c26d7adeca3364e0efbef43a7a2e01701614e128c3ab307321fc3e3166f09e71f002bd14d1ad5caaf3242502cbe4e71285591d8f2977 SHA512 e0f5b345b6d794b21fa04bc0c7125f24a877074538ad746451d4a293eb22f1afb9e0e619c69b84f0fc2142a925044a19976af4cffb8426358e95e7d9715d5a4f
+DIST nghttp2-1.32.0.tar.xz 1548528 BLAKE2B 1a1d031fc23ac14236c58a84aa94ee255646d36c9c631000b5d48e39c9fbc16e1b28d82e40bfc96d0fb9e2aa6982ed6bff77bcecdacf220ba8dea0b86d92bcab SHA512 ec7e417fbc5497861d2b6dde5145da1640b36441882824e85940e5ca6ac52ec444aa7123846960f7211dd96462eab421d39f9cc49454f3f52e0dcdb36402044e
diff --git a/net-libs/nghttp2/nghttp2-1.32.0.ebuild b/net-libs/nghttp2/nghttp2-1.32.0.ebuild
new file mode 100644
index 000000000000..ffeb54eded23
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.32.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-werror
+ --without-cython
+ --disable-python-bindings
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}