summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-22 15:58:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-22 15:59:00 +0100
commit91f4f99d403ec7f89ec2c23a91bb1a1dce4d9f4e (patch)
tree5866d35245c604b7192ede6ad3c262f84b08727b
parentwww-client/vivaldi-snapshot: Old (diff)
downloadgentoo-91f4f99d403ec7f89ec2c23a91bb1a1dce4d9f4e.tar.gz
gentoo-91f4f99d403ec7f89ec2c23a91bb1a1dce4d9f4e.tar.bz2
gentoo-91f4f99d403ec7f89ec2c23a91bb1a1dce4d9f4e.zip
app-accessibility/brltty: Bump to version 6.0
Closes: https://bugs.gentoo.org/632630 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-accessibility/brltty/Manifest1
-rw-r--r--app-accessibility/brltty/brltty-6.0.ebuild194
-rw-r--r--app-accessibility/brltty/files/brltty-6.0-udev.patch27
-rw-r--r--app-accessibility/brltty/files/brltty.rc4
4 files changed, 224 insertions, 2 deletions
diff --git a/app-accessibility/brltty/Manifest b/app-accessibility/brltty/Manifest
index 018608d0bc43..2618e8dd7d86 100644
--- a/app-accessibility/brltty/Manifest
+++ b/app-accessibility/brltty/Manifest
@@ -1 +1,2 @@
DIST brltty-5.2.tar.xz 2532684 BLAKE2B 9b0555289177971abe12119f0604eebb196b8f493294741a31c684ebb5546eaccc0a729a8ca6b24e4075f0c29bf371e773743f02e0a102799c44c2293dc9894f SHA512 8e16701e9c9d776c76e3ad0cb4319b2753295fea229bd3f60cb0dffc0b6946037e6f98daafae873238c4eff90d4b8ddb697b7d425e700c5a098aba8fed9eed3f
+DIST brltty-6.0.tar.xz 2879976 BLAKE2B 31bd45b63838d119d940492c615deb27ec47389c68afa39f19da3534324914695343344260799a10deae6ca3de41bedf9b0c1de1f78dbe01a89b694c2aa6e265 SHA512 07344fa902ad169967ca39d19b09dfea24e698011031dd63dce3eb997a4cb86622ee9427b216976b3ef60e5cbabb710a621621447c6bfa2313748fc1a1cf4b06
diff --git a/app-accessibility/brltty/brltty-6.0.ebuild b/app-accessibility/brltty/brltty-6.0.ebuild
new file mode 100644
index 000000000000..badd7a116780
--- /dev/null
+++ b/app-accessibility/brltty/brltty-6.0.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+FINDLIB_USE="ocaml"
+
+inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic \
+ autotools udev systemd python-r1
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://brltty.com/"
+SRC_URI="http://brltty.com/archive/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
+ java +midi ncurses nls ocaml +pcm python usb +speech
+ tcl X"
+REQUIRED_USE="doc? ( api )
+ java? ( api )
+ ocaml? ( api )
+ python? ( api ${PYTHON_REQUIRED_USE} )
+ tcl? ( api )"
+
+COMMON_DEP="bluetooth? ( net-wireless/bluez )
+ gpm? ( >=sys-libs/gpm-1.20 )
+ iconv? ( virtual/libiconv )
+ icu? ( dev-libs/icu:= )
+ python? ( ${PYTHON_DEPS} )
+ ncurses? ( sys-libs/ncurses:0= )
+ nls? ( virtual/libintl )
+ tcl? ( >=dev-lang/tcl-8.4.15:0= )
+ usb? ( virtual/libusb:0 )
+ X? ( x11-libs/libXaw )"
+DEPEND="${COMMON_DEP}"
+BDEPEND="
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.4 )
+ python? ( >=dev-python/cython-0.16[${PYTHON_USEDEP}] )
+"
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ ${COMMON_DEP}"
+
+HTML_DOCS=( "${S}"/Documents/Manual-BrlAPI/. )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0-udev.patch
+ "${FILESDIR}"/${PN}-5.2-respect-AR.patch
+)
+
+src_prepare() {
+ default
+
+ java-pkg-opt-2_src_prepare
+
+ # The code runs `pkg-config` directly instead of locating a suitable
+ # pkg-config wrapper (or respecting $PKG_CONFIG).
+ sed -i \
+ -e 's/\<pkg-config\>/${PKG_CONFIG:-pkg-config}/' \
+ aclocal.m4 configure.ac || die
+
+ # We run eautoconf instead of using eautoreconf because brltty uses
+ # a custom build system that uses autoconf without the rest of the
+ # autotools.
+ eautoconf
+ python_copy_sources
+}
+
+src_configure() {
+ tc-export AR LD PKG_CONFIG
+ # override prefix in order to install into /
+ # braille terminal needs to be available as soon in the boot process as
+ # possible
+ # Also override localstatedir so that the lib/brltty directory is installed
+ # correctly.
+ # Disable stripping since we do that ourselves.
+ local myconf=(
+ --prefix="${EPREFIX}"/
+ --localedir="${EPREFIX}"/usr/share/locale
+ --includedir="${EPREFIX}"/usr/include
+ --localstatedir="${EPREFIX}"/var
+ --disable-stripping
+ --with-install-root="${D}"
+ --with-writable-directory="${EPREFIX}"/run/brltty
+ $(use_enable api)
+ $(use_with beeper beep-package)
+ $(use_enable contracted-braille)
+ $(use_with fm fm-package)
+ $(use_enable gpm)
+ $(use_enable iconv)
+ $(use_enable icu)
+ $(use_enable java java-bindings)
+ $(use_with midi midi-package)
+ $(use_enable nls i18n)
+ $(use_enable ocaml ocaml-bindings)
+ $(use_with pcm pcm-package)
+ $(use_enable speech speech-support)
+ $(use_enable tcl tcl-bindings)
+ $(use_enable X x)
+ $(use_with bluetooth bluetooth-package)
+ $(use_with ncurses curses)
+ $(use_with usb usb-package) )
+
+ econf "${myconf[@]}"
+
+ if use python; then
+ myconf+=( $(use_enable python python-bindings ) )
+
+ python_configure() {
+ econf "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+src_compile() {
+ local JAVAC_CONF=""
+ local OUR_JNI_FLAGS=""
+ if use java; then
+ OUR_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
+ JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
+ fi
+
+ emake JAVA_JNI_FLAGS="${OUR_JNI_FLAGS}" JAVAC="${JAVAC_CONF}"
+
+ if use python; then
+ python_build() {
+ cd "Bindings/Python" || die
+ emake
+ }
+ python_foreach_impl run_in_build_dir python_build
+ fi
+}
+
+src_install() {
+ if use ocaml; then
+ findlib_src_preinst
+ fi
+
+ emake OCAML_LDCONF= install
+
+ if use python; then
+ python_install() {
+ cd "Bindings/Python" || die
+ emake install
+ }
+ python_foreach_impl run_in_build_dir python_install
+ fi
+
+ if use java; then
+ # make install puts the _java.so there, and no it's not $(get_libdir)
+ rm -r "${ED}/usr/lib/java" || die
+ java-pkg_doso Bindings/Java/libbrlapi_java.so
+ java-pkg_dojar Bindings/Java/brlapi.jar
+ fi
+
+ insinto /etc
+ doins Documents/brltty.conf
+ udev_newrules Autostart/Udev/rules 70-brltty.rules
+ newinitd "${FILESDIR}"/brltty.rc brltty
+ systemd_dounit Autostart/Systemd/brltty@.service
+ systemd_dotmpfilesd "${FILESDIR}/${PN}.tmpfiles.conf"
+
+ local libdir="$(get_libdir)"
+ mkdir -p "${ED}"/usr/${libdir}/ || die
+ mv "${ED}"/${libdir}/*.a "${ED}"/usr/${libdir}/ || die
+ gen_usr_ldscript libbrlapi.so
+
+ cd Documents || die
+ mv Manual-BRLTTY/English/BRLTTY.txt BRLTTY-en.txt || die
+ mv Manual-BRLTTY/French/BRLTTY.txt BRLTTY-fr.txt || die
+ mv Manual-BrlAPI/English/BrlAPI.txt BrlAPI-en.txt || die
+ dodoc CONTRIBUTORS ChangeLog HISTORY README* TODO BRLTTY-*.txt
+ if use doc; then
+ dodoc BrlAPI-*.txt
+ HTML_DOCS="Manual-BRLTTY" einstalldocs
+ fi
+
+ keepdir /var/lib/BrlAPI
+ rmdir "${ED}/run/brltty" || die
+ rmdir "${ED}/run" || die
+}
+
+pkg_postinst() {
+ elog
+ elog "please be sure ${ROOT}etc/brltty.conf is correct for your system."
+ elog
+ elog "To make brltty start on boot, type this command as root:"
+ elog
+ elog "rc-update add brltty boot"
+}
diff --git a/app-accessibility/brltty/files/brltty-6.0-udev.patch b/app-accessibility/brltty/files/brltty-6.0-udev.patch
new file mode 100644
index 000000000000..e53b7a6aa664
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-6.0-udev.patch
@@ -0,0 +1,27 @@
+--- brltty-6.0/Autostart/Udev/rules
++++ brltty-6.0/Autostart/Udev/rules
+@@ -276,20 +276,22 @@
+ # FreedomScientific [Focus Blue]
+ ENV{PRODUCT}=="f4e/114/*", ENV{BRLTTY_BRAILLE_DRIVER}="fs", GOTO="brltty_usb_run"
+
++# Seika rules are commented out, because they conflict with USB-to-serial
++# converters.
+ # Device: 10C4:EA60
+ # Generic Identifier
+ # Vendor: Cygnal Integrated Products, Inc.
+ # Product: CP210x UART Bridge / myAVR mySmartUSB light
+ # BrailleMemo [Pocket]
+ # Seika [Braille Display]
+-ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
++#ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
+
+ # Device: 10C4:EA80
+ # Generic Identifier
+ # Vendor: Cygnal Integrated Products, Inc.
+ # Product: CP210x UART Bridge
+ # Seika [Note Taker]
+-ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
++#ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
+
+ # Device: 1148:0301
+ # BrailleMemo [Smart]
diff --git a/app-accessibility/brltty/files/brltty.rc b/app-accessibility/brltty/files/brltty.rc
index 0bc6c6c5375b..100dd29b778a 100644
--- a/app-accessibility/brltty/files/brltty.rc
+++ b/app-accessibility/brltty/files/brltty.rc
@@ -1,10 +1,10 @@
#!/sbin/openrc-run
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
command=/bin/brltty
pidfile=/var/run/brltty.pid
-command_args="-P $pidfile -q"
+command_args="-P ${pidfile} -q"
depend() {
before *