summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2018-10-23 00:14:20 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2018-10-23 00:16:20 +0000
commit94cba792173e44e4b0dc600f3cd3fde119da4c24 (patch)
tree734256f75d011fc485b6891437f22379238b0cdc
parentnet-wireless/kismet: fix deps for both live and beta (diff)
downloadgentoo-94cba792173e44e4b0dc600f3cd3fde119da4c24.tar.gz
gentoo-94cba792173e44e4b0dc600f3cd3fde119da4c24.tar.bz2
gentoo-94cba792173e44e4b0dc600f3cd3fde119da4c24.zip
sys-kernel/kpatch: bump
Signed-off-by: Alice Ferrazzi <alicef@gentoo.org> Package-Manager: Portage-2.3.38, Repoman-2.3.9
-rw-r--r--sys-kernel/kpatch/Manifest1
-rw-r--r--sys-kernel/kpatch/kpatch-0.6.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-kernel/kpatch/Manifest b/sys-kernel/kpatch/Manifest
index 3429f0e7d7b0..c6d912899b9a 100644
--- a/sys-kernel/kpatch/Manifest
+++ b/sys-kernel/kpatch/Manifest
@@ -1,2 +1,3 @@
DIST kpatch-0.4.0.tar.gz 124433 BLAKE2B 6ea18c4d590426f9db95e16d555307e264d1b7db362d421f72eaaf897703f7883c44cc49bd98b48d8789453962259d0b0e301aca325c94be6c21061d0621a9cf SHA512 0bbb49a06d02e9eb026be458eb904cf50f50461a67f16835a306bb3a4a57ef88b86ecf6bca6dfc91b921ba87b4c8b9d532e2a77e987e7c71583b8cb53520a1d7
DIST kpatch-0.6.0.tar.gz 153337 BLAKE2B 5c132b885f9f8bc3c7b514997a0b8b77280d0387431dd3eb73f45da4678b281961a03452b0ec590b37fc9568192135528a9a42bd5005530bd8b9175fe652f7b1 SHA512 7ac27639773a851ad6689743100ff973b4e3a30efc386bdf413c8f6167068d93c2d18820d87e1f1e96405fa3545dcb80a72db0011f07218a692f91f1f3c3655a
+DIST kpatch-0.6.2.tar.gz 148110 BLAKE2B 9903c9423ee6268a0d87c55336e418a964474a3d7f35dd1ad613be7645a932cd09991652cd4a3af0b08a686f39e7c6c7f4b12d80c20c7ecd663aa703821503f8 SHA512 65098195330a2dbea4f8648c87c41f3a7751ffcb83b4e4c5f0a1146f91a8ae8c305d8f111a69304b31f1f12dd26da788af31a5477899bda098b7391cd0a32eca
diff --git a/sys-kernel/kpatch/kpatch-0.6.2.ebuild b/sys-kernel/kpatch/kpatch-0.6.2.ebuild
new file mode 100644
index 000000000000..e9cdeb7b5ac3
--- /dev/null
+++ b/sys-kernel/kpatch/kpatch-0.6.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit linux-info linux-mod flag-o-matic
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dynup/${PN}.git"
+else
+ SRC_URI="https://github.com/dynup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Dynamic kernel patching for Linux"
+HOMEPAGE="https://github.com/dynup/kpatch"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="examples +modules test"
+
+RDEPEND="
+ app-crypt/pesign
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ sys-apps/pciutils
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/elfutils
+ sys-devel/bison
+"
+
+pkg_pretend() {
+ if kernel_is gt 3 9 0; then
+ if ! linux_config_exists; then
+ eerror "Unable to check the currently running kernel for kpatch support"
+ eerror "Please be sure a .config file is available in the kernel src dir"
+ eerror "and ensure the kernel has been built."
+ else
+ # Fail to build if these kernel options are not enabled (see kpatch/kmod/core/Makefile)
+ CONFIG_CHECK="FUNCTION_TRACER HAVE_FENTRY MODULES SYSFS KALLSYMS_ALL"
+ ERROR_FUNCTION_TRACER="CONFIG_FUNCTION_TRACER must be enabled in the kernel's config file"
+ ERROR_HAVE_FENTRY="CONFIG_HAVE_FENTRY must be enabled in the kernel's config file"
+ ERROR_MODULES="CONFIG_MODULES must be enabled in the kernel's config file"
+ ERROR_SYSFS="CONFIG_SYSFS must be enabled in the kernel's config file"
+ ERROR_KALLSYMS_ALL="CONFIG_KALLSYMS_ALL must be enabled in the kernel's config file"
+ fi
+ else
+ eerror
+ eerror "kpatch is not available for Linux kernels below 4.0.0"
+ eerror
+ die "Upgrade the kernel sources before installing kpatch."
+ fi
+
+ check_extra_config
+}
+
+src_prepare() {
+ replace-flags '-O?' '-O1'
+ default
+}
+
+src_compile() {
+ set_arch_to_kernel
+ emake all
+}
+
+src_install() {
+ set_arch_to_kernel
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ einstalldocs
+}