summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-23 17:11:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-23 18:03:02 +0100
commit94edeb1703cfdd6e8b923fba667a04f15dc4fad9 (patch)
tree5e5258762735fae4b4d2d2ca51817a8586fe739b
parentdev-libs/libgcrypt: Add default-on asm useflag (diff)
downloadgentoo-94edeb1703cfdd6e8b923fba667a04f15dc4fad9.tar.gz
gentoo-94edeb1703cfdd6e8b923fba667a04f15dc4fad9.tar.bz2
gentoo-94edeb1703cfdd6e8b923fba667a04f15dc4fad9.zip
dev-util/cmake: Re-enable CommandLineTar test w/ app-arch/libarchive[zstd]
Thanks-to: Keshia Bonaventure <keshia.bonaventure@you-spam.com> Bug: https://bugs.gentoo.org/690186 Closes: https://bugs.gentoo.org/743772 Closes: https://bugs.gentoo.org/766363 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-util/cmake/cmake-3.18.5.ebuild6
-rw-r--r--dev-util/cmake/cmake-3.19.3.ebuild4
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-util/cmake/cmake-3.18.5.ebuild b/dev-util/cmake/cmake-3.18.5.ebuild
index 4c0006310904..4cd2e415b0d0 100644
--- a/dev-util/cmake/cmake-3.18.5.ebuild
+++ b/dev-util/cmake/cmake-3.18.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-CMAKE_MAKEFILE_GENERATOR="emake" # TODO: Re-check with 3.19, see commit 491dddfb; bug #596460
+CMAKE_MAKEFILE_GENERATOR="emake" # Fixed in 3.19, see commit 491dddfb; bug #596460
CMAKE_REMOVE_MODULES_LIST=( none )
inherit bash-completion-r1 cmake elisp-common flag-o-matic multiprocessing \
toolchain-funcs virtualx xdg-utils
@@ -44,6 +44,7 @@ BDEPEND="
dev-python/requests
dev-python/sphinx
)
+ test? ( app-arch/libarchive[zstd] )
"
S="${WORKDIR}/${MY_P}"
@@ -108,7 +109,6 @@ cmake_src_test() {
# CMakeOnly.AllFindModules: pthread issues
# CTest.updatecvs: fails to commit as root
# Fortran: requires fortran
- # RunCMake.CommandLineTar: whatever...
# RunCMake.CompilerLauncher: also requires fortran
# RunCMake.CPack_RPM: breaks if app-arch/rpm is installed because
# debugedit binary is not in the expected location
@@ -120,7 +120,7 @@ cmake_src_test() {
-j "$(makeopts_jobs)" \
--test-load "$(makeopts_loadavg)" \
${ctestargs} \
- -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CommandLineTar|RunCMake.CompilerLauncher|RunCMake.IncompatibleQt|RunCMake.ObsoleteQtMacros|RunCMake.PrecompileHeaders|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
+ -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.IncompatibleQt|RunCMake.ObsoleteQtMacros|RunCMake.PrecompileHeaders|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
|| die "Tests failed"
popd > /dev/null
diff --git a/dev-util/cmake/cmake-3.19.3.ebuild b/dev-util/cmake/cmake-3.19.3.ebuild
index 930417171292..b8777ecdb8d4 100644
--- a/dev-util/cmake/cmake-3.19.3.ebuild
+++ b/dev-util/cmake/cmake-3.19.3.ebuild
@@ -44,6 +44,7 @@ BDEPEND="
dev-python/requests
dev-python/sphinx
)
+ test? ( app-arch/libarchive[zstd] )
"
S="${WORKDIR}/${MY_P}"
@@ -108,7 +109,6 @@ cmake_src_test() {
# CMakeOnly.AllFindModules: pthread issues
# CTest.updatecvs: fails to commit as root
# Fortran: requires fortran
- # RunCMake.CommandLineTar: whatever...
# RunCMake.CompilerLauncher: also requires fortran
# RunCMake.CPack_RPM: breaks if app-arch/rpm is installed because
# debugedit binary is not in the expected location
@@ -120,7 +120,7 @@ cmake_src_test() {
-j "$(makeopts_jobs)" \
--test-load "$(makeopts_loadavg)" \
${ctestargs} \
- -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|DependencyGraph|Fortran|RunCMake.CommandLineTar|RunCMake.CompilerLauncher|RunCMake.IncompatibleQt|RunCMake.ObsoleteQtMacros|RunCMake.PrecompileHeaders|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
+ -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|DependencyGraph|Fortran|RunCMake.CompilerLauncher|RunCMake.IncompatibleQt|RunCMake.ObsoleteQtMacros|RunCMake.PrecompileHeaders|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
|| die "Tests failed"
popd > /dev/null