summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 20:14:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:31:56 +0100
commit94f98b934f7d31fa1c987a30865e5d32f22d6f7b (patch)
tree37a4bd6c4cb85f9c8fd0af7d79b48d5aff1f93a0
parentapp-admin/sud: Port to EAPI 6 (diff)
downloadgentoo-94f98b934f7d31fa1c987a30865e5d32f22d6f7b.tar.gz
gentoo-94f98b934f7d31fa1c987a30865e5d32f22d6f7b.tar.bz2
gentoo-94f98b934f7d31fa1c987a30865e5d32f22d6f7b.zip
app-admin/diradm: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--app-admin/diradm/diradm-2.9.7.1.ebuild39
1 files changed, 16 insertions, 23 deletions
diff --git a/app-admin/diradm/diradm-2.9.7.1.ebuild b/app-admin/diradm/diradm-2.9.7.1.ebuild
index 40dd1892dcc6..2d6459346171 100644
--- a/app-admin/diradm/diradm-2.9.7.1.ebuild
+++ b/app-admin/diradm/diradm-2.9.7.1.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
-
-inherit eutils
+EAPI=6
DESCRIPTION="A nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP"
#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
@@ -14,13 +12,15 @@ SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="samba irixpasswd automount test"
+IUSE="automount irixpasswd samba test"
+REQUIRED_USE="test? ( automount irixpasswd samba )"
+
RDEPEND=">=net-nds/openldap-2.3
sys-apps/gawk
sys-apps/coreutils
sys-apps/grep
dev-lang/perl
- app-shells/bash
+ app-shells/bash:*
sys-apps/sed
virtual/perl-MIME-Base64
samba? (
@@ -36,27 +36,24 @@ DEPEND="
net-nds/openldap[-minimal]
)"
-pkg_setup() {
- use test && elog "Warning, for test usage, diradm is built with all optional features!"
+src_configure() {
+ econf \
+ $(use_enable automount) \
+ $(use_enable irixpasswd) \
+ $(use_enable samba)
}
-src_configure() {
- local myconf
- if use test; then
- myconf="--enable-samba --enable-automount --enable-irixpasswd"
- else
- myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
- fi
- econf ${myconf} || die "econf failed"
+src_test() {
+ emake -j1 check
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork \
- THANKS TODO KNOWN-BUGS || die
+ default
+ dodoc CHANGES.prefork KNOWN-BUGS
+
if use irixpasswd; then
insinto /etc/openldap/schema
- doins irixpassword.schema || die "Failed irixpassword.schema"
+ doins irixpassword.schema
fi
}
@@ -69,7 +66,3 @@ pkg_postinst() {
elog "those packages, with a further fallback to /etc/openldap/ldap.conf"
elog "for server connection settings only."
}
-
-src_test() {
- emake -j1 check
-}