summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-01-27 14:27:56 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-01-27 14:29:03 -0600
commit95c061b0ea87119901a1c81c1eb9dae3d2e2b297 (patch)
tree81efbe109cf8b4da05cddf96ddc72fbbb1a12bbb
parentnet-misc/htpdate: Removed old (diff)
downloadgentoo-95c061b0ea87119901a1c81c1eb9dae3d2e2b297.tar.gz
gentoo-95c061b0ea87119901a1c81c1eb9dae3d2e2b297.tar.bz2
gentoo-95c061b0ea87119901a1c81c1eb9dae3d2e2b297.zip
app-containers/cosign: fix makefile
Thanks to ionen for this fix. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-containers/cosign/cosign-1.5.0.ebuild4
-rw-r--r--app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch13
2 files changed, 17 insertions, 0 deletions
diff --git a/app-containers/cosign/cosign-1.5.0.ebuild b/app-containers/cosign/cosign-1.5.0.ebuild
index f1320114bcd2..801eb64a2691 100644
--- a/app-containers/cosign/cosign-1.5.0.ebuild
+++ b/app-containers/cosign/cosign-1.5.0.ebuild
@@ -13,6 +13,10 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-makefile.patch
+)
+
src_prepare() {
default
mv ../vendor . || die
diff --git a/app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch b/app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch
new file mode 100644
index 000000000000..15cdc7511136
--- /dev/null
+++ b/app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch
@@ -0,0 +1,13 @@
+--- a/Makefile 2022-01-22 16:06:02.000000000 -0500
++++ b/Makefile 2022-01-27 15:06:43.986094208 -0500
+@@ -71,8 +71,8 @@
+ checkfmt: SHELL := /usr/bin/env bash
+ checkfmt: ## Check formatting of all go files
+ @ $(MAKE) --no-print-directory log-$@
+- $(shell test -z "$(shell gofmt -l $(GOFILES) | tee /dev/stderr)")
+- $(shell test -z "$(shell goimports -l $(GOFILES) | tee /dev/stderr)")
++ $(shell test -z "$(shell gofmt -l $(GOFILES) | tee /dev/stderr)")
++ $(shell test -z "$(shell goimports -l $(GOFILES) | tee /dev/stderr)")
+
+ .PHONY: fmt
+ fmt: ## Format all go files